won't play files with a plus sign ("+") in it

Bug #239431 reported by Waldir Leoncio on 2008-06-12
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
vlc (Ubuntu)
Medium
Unassigned
Nominated for Hardy by Stumpy

Bug Description

Binary package hint: vlc

I know this is a minor thing, but it could very much trouble the everyday user.

Apparently, VLC won't play a sound file if it has a plus sign ("+") on its name.

CVE References

Richard Seguin (sectech) wrote :

Thank you for reporting this issue and trying to make Ubuntu better, could you please answer the following questions for me?

1) What version and architecture (32bit or 64bit) are you running?
2) What kind of sound file will it not play? (ex: .wmv, mp3...etc)
3) Have you tried renaming a song that does play to something that has a "+" in it and tried it again?
4) Finally, if you do get an error message can you either attach it to the bug report as a screen snap or cut and paste?

This will help us narrow down the problem your having.

Thanks,

Richard Seguin

Changed in vlc:
status: New → Incomplete
Richard Seguin (sectech) wrote :

* Marking incomplete pending enough information to complete triage

Waldir Leoncio (wleoncio) wrote :

Richard,

I'm using Ubuntu 8.04 for the 32-bit architecture and I've only tested the bug on MP3 files. Renaming a file so as to remove the "+" solves the problem.

I've attached a screenshot of the window that appears when I try to open a file named "O Teatro Mágico - Camarada d'água+.mp3". As requested, the "+" was added to test if VLC would refuse to play it (it plays normally without the "+"). I didn't attach this image before because I thought it was so easily reproducible. :)

Waldir Leoncio (wleoncio) wrote :

Oh, yeah, and the referred messages window (see screenshot) gives the following message:
"main error: no suitable access module for `file:///home/leoncio/M%C3%BAsicas/O%20Teatro%20M%C3%A1gico%20-%20Camarada%20d'%C3%A1gua+.mp3'"

Richard Seguin (sectech) wrote :

Could you try renaming the file to something that doesn't have special characters in it? Like for example "song.mp3" or something like that? I thought it might have been because the + was on the end before the extension, but the mp3 I was using still played.

Thanks,

Richard Seguin

Waldir Leoncio (wleoncio) wrote :

You're right. I've managed to play "song+.mp3" correctly. However, when I rename it to "song +.mp3" (with a space before the plus sign), VLC fails to play it. Can you confirm that?

Now I'm a little bit confused about what exactly is causing the error.

Richard Seguin (sectech) wrote :

I can't confirm that either, the song played fine... I wonder if it has anything to do with language... What keyboard language are you using?

Waldir Leoncio (wleoncio) wrote :

I'm using a generic keyboard, configured with the Brazilian ABNT2 layout. The OS is in US-en, though.

VLC doesn't seem to have a problem with spaces, accents, hyphens, the "ç" character or even some "stranger" characters like "?" and "{". And the other players I have (Kaffeine, MPlayer, Rhythmbox and Totem) play it fine, whatever the name.

I've tested the problem a little bit further, and it seems to occur whenever I have a space and a "+" at the filename, no matter where they are ("song song+.mp3", for example, won't play).

Richard Seguin (sectech) wrote :

I know it's been a while since this bug has been updated, I was just wondering if your still having this issue

Thanks,

Richard Seguin

Changed in vlc:
importance: Undecided → Medium
Waldir Leoncio (wleoncio) wrote :

Yep. Same ol', same ol'... :-/

foundaname (foundaname) wrote :

Hi, I'm experiencing the same problem and can offer a solution.

It hasn't been mentioned that the problem only occurs if you try to open a file with VLC from within Nautilus (Double click if the file type is associated, or right click -> Open with -> vlc).

Any file that contains the characters space and plus in either the filename or the path cannot be played with VLC when being opened from within Nautilus.

The problem is in /usr/share/applications/vlc.desktop

Changing the line
Exec=vlc %U
to
Exec=vlc %F
solves the problem.

Bug 231595 should be marked as a duplicate:
https://bugs.launchpad.net/ubuntu/+source/vlc/+bug/231595

This also solves bug 217305:
https://bugs.launchpad.net/ubuntu/+source/vlc/+bug/217305

Hope this helps.

Launchpad Janitor (janitor) wrote :
Download full text (4.7 KiB)

This bug was fixed in the package vlc - 0.9.2-1ubuntu1

---------------
vlc (0.9.2-1ubuntu1) intrepid; urgency=low

  * New Upstream Release, exception granted by
      - dktrkranz, norsetto, Hobbsee (via irc). LP: #270404

  Changes done in ubuntu:

  * add libxul-dev to build-depends
  * make sure that vlc is build against libxul in configure. This doesn't
    change anything in the package, but makes it more robust if building
    in an 'unclean' chroot or when modifying the package.
  * debian/control: make Vcs-* fields point to the motumedia branch
  * add libx264-dev and libass-dev to build-depends
    LP: #210354, #199870
  * actually enable libass support by passing --enable-libass to configure
  * enable libdca: add libdca-dev to build depends and --enable-libdca
  * install the x264 plugin.

  Changes already in the pkg-multimedia branch in debian:

  * don't install usr/share/vlc/mozilla in debian/mozilla-plugin-vlc.install
  * new upstream .desktop file now registers flash video mimetype LP: #261567
  * add Xb-Npp-Applications to mozilla-plugin-vlc
  * remove duplicate entries in debian/vlc-nox.install

vlc (0.9.2-1) experimental; urgency=low

  [ Christophe Mutricy ]
  * New upstream release
    + Soname changed
    + Bugs fixed upstream: Closes: #487646, #298150, #325069, #392292,
      #458004, #470903, #458004, #423121
    + new upstream fixes various crasher bugs reported in ubuntu:
      LP: #189575, #113927, #103741, #111615, #107899, #112076, #198916, 221428,
          #91679, #96978, #123589, #133528, #231621, #259025
    + plays files with '+' in its name, LP: #239431, #217305
    + New packages: libvlccore0, libvlccore-dev, vlc-plugin-pulse
     (Closes: #471069)
    + Build-depends on libswsale-dev, libshout3-dev, libxpm-dev,
      zlib1g-dev, liblua5.1-0-dev, libschroedinger-dev, libtag1-dev,
      libqt4-dev, libqt4-dev-tools and pkg-config. (Closes: #461324)
    + time display no longer incomplete, LP: #193445
    + fixed volume bar behavior, LP: #250041
    + shout support closes LP: #127594, #84098,
    + Install new modules:
      - vlc-nox: alphamask, blendbench, bluescreen, canvas, cc, cdg, chain,
        colorthres, croppadd, dynamicoverlay, erase, faad, gaussianblur, grain,
        inhibit, lua, memcpy*, mmap, osd_parser, puzzle, remoteosd, rtmp,
        schroedinger, sharpen, stats, subusf, t140, telepathy, v4l2, vmem
      - vlc: qt4
      - vlc-plugin-jack: access_jack
    + Distribute the .pc for libvlc and vlc-plugin (Closes: #289507)
    + Remove wx interface and glide plugin as they've been dropped by upstream
      LP: #205325, #88487, #90603, #150380
    + The Python and java bindings are no longer part of the upstream tarballs
      (Closes: #469011)
    + Temporarly disable libdca module until a pkg with the new
      API get in unstable
    + Delete or refresh patches
    + New patches:
        - 052_as-needed taken from bug #347650 to teach libtool about
          -Wl,--as-needed
  * Install the skins DTD and the default skins it's only 113kB
  * Improve watch file
  * Add a vlc-data package for /usr/share (13 MB)
  * Add a vlc-dbg package (Closes: #491564)
  * Sort vlc.install and vlc-nox.inst...

Read more...

Changed in vlc:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers