Ubuntu

vlc pulseaudio support

Reported by pl4nkton on 2008-02-28
38
Affects Status Importance Assigned to Milestone
VLC media player
Fix Released
Unknown
vlc (Debian)
Fix Released
Unknown
vlc (Ubuntu)
Wishlist
Luke Yelavich

Bug Description

Binary package hint: vlc

vlc upstream provides a pulseaudio plugin:
http://trac.videolan.org/vlc/ticket/1215

Related branches

Murat Gunes (mgunes) on 2008-02-28
Changed in vlc:
importance: Undecided → Wishlist
SK (stephantom) wrote :

We should keep a close watch on this - support for pulseaudio in VLC will be extremely awesome.
As of now I think that this patch hasn't been checked in the VLC tree yet and is relatively untested.

pl4nkton (pl4nkton) wrote :

It is in trunk and nightly builds provide a pulse audio plugin already.
It works well for me, only multichannel don't work.
http://trac.videolan.org/vlc/browser/trunk/modules/audio_output

Changed in vlc:
status: Unknown → Fix Released
Martin Hamrle (hamrle) on 2008-03-01
Changed in vlc:
status: New → Confirmed
John Dong (jdong) wrote :

IMO This should require a feature freeze exception

Luke Yelavich (themuso) wrote :

If anybody wishes to do the leg work for filing a feature freeze exception, I'd certainly be happy to review it. If its also possible to set pulseaudio by default, and allow for a fallback to alsa, this would even be better, as vlc will then work with all desktops out of the box for hardy.

SK (stephantom) wrote :

Fallback to alsa will always be possible. VLC first tries the plugin set up as default and should that one fail tries the other installed plugins.
Setting pulseaudio as default could be possible with a configure option, I'll have to look into that. There are no global configuration files for VLC (see: http://www.videolan.org/doc/faq/en/index.html#id269558).

Siegfried Gevatter (rainct) wrote :

Unsubscribing ubuntu-universe-sponsors because of the last comments. Please subscribe u-u-s again once there is a new debdiff ready. Thanks!

Le Sat 01 Mar 08 � 23:53 -0000, Luke Yelavich a �it :
> If anybody wishes to do the leg work for filing a feature freeze
> exception, I'd certainly be happy to review it. If its also possible to
> set pulseaudio by default, and allow for a fallback to alsa, this would
> even be better, as vlc will then work with all desktops out of the box
> for hardy.
You need to patch the module to set its score higher than the one of
alsa (and esd, arts, oss). VLC core tries the modules in decreasing
score order until it finds one which works.

So with pulse with a big score, it will be tried first and then the
other audio module

hth,

--
Xtophe

Martin Hamrle (hamrle) wrote :

Pulseaudio plugin has now the highest priority, pulse is default audio output plugin.

Daniel Hahler (blueyed) wrote :

Thank you for providing this patch.
Please provide the info required for a FreezeException (see https://wiki.ubuntu.com/FreezeExceptionProcess).
You should then also add a debian/changelog entry to your debdiff and refer to this bug from there.

Martin Hamrle (hamrle) wrote :

  * Add new package with pulse output plugin (LP: #196417)
    - debian/patches/030_pulse.diff:
      + patch from upstream trunk to support pulseaudio output
    - debian/rules:
      + enable pulseaudio
    - debian/control:
      + add dependencies to libpulse-dev
      + new package description

Matti Lindell (mlind) wrote :

Debian bug contains a patch backported from vlc git tree as well.

Changed in vlc:
status: Unknown → New
gfg (tobben88) wrote :

Any chance of seeing a fix for this before Hardy final?

John Dong (jdong) wrote :

As Daniel and Luke both said and everyone seemed to ignore, this is a feature addition and requires the filing of a Feature Freeze Exception. Once this is done and approved, I'd be willing to upload this patch.

Martin Hamrle (hamrle) wrote :

Is anyone who fill Feature Freeze Exception?

Luca Falavigna (dktrkranz) wrote :

I'm doing some tests now, once finished I'll arrange for a FFe.
In the meantime, I'm unsubscribing u-u-s, wait for green light from motu-release before going any further.

Luca Falavigna (dktrkranz) wrote :

FFe requested in bug #204050, are packages available for testing? If not, I'll compile them myself.

SK (stephantom) wrote :

The unstable repos (see: http://nightlies.videolan.org/#debian) have packages ready. I don't know if they're identical the debdiff proposed here (I'd guess no).

Martin Hamrle (hamrle) wrote :

Packages is not available, you must compile it yourself. Here is debdiff against latest 0.8.6.release.d-0ubuntu6.

John Dong (jdong) wrote :

My two cents on this as a ~motu-media, I support these patches going into VLC in Hardy. It is often the 2nd-in-line media player people choose when Totem craps out, and PulseAudio support is very important for Hardy. With that said, I haven't looked terribly closely at the patches so community assistance in testing the given patches is critical to this process :)

Luca Falavigna (dktrkranz) wrote :

Martin, your debdiff does not build actually, see attached log.

Martin Hamrle (hamrle) wrote :

I have added some missing dependencies. Now it builds with pbuilder and in my ppa https://launchpad.net/~hamrle/+archive

Luca Falavigna (dktrkranz) wrote :

Feature Freeze exception granted as per bug #204050, subscribing ubuntu-universe-sponsors.

Luke Yelavich (themuso) on 2008-03-27
Changed in vlc:
assignee: nobody → themuso
status: Confirmed → In Progress
Luke Yelavich (themuso) wrote :

Uploaded, thanks for your work.

Changed in vlc:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vlc - 0.8.6.release.d-0ubuntu7

---------------
vlc (0.8.6.release.d-0ubuntu7) hardy; urgency=low

  * Add new package with pulse output plugin (LP: #196417)
    - debian/patches/030_pulse.diff:
      + patch from upstream trunk to support pulseaudio output
    - debian/rules:
      + enable pulseaudio
    - debian/control:
      + add dependencies to libpulse-dev
      + new package description

 -- Martin Hamrle <email address hidden> Tue, 11 Mar 2008 23:09:49 +0100

Changed in vlc:
status: Fix Committed → Fix Released
Chad Bernier (berniercr) wrote :

how do you get the new pulse audio to work? It doesn't show up in the audio output list.

Luke Yelavich (themuso) wrote :

You need to install the vlc-plugin-pulse package.

Pizuz (florian-fahr) wrote :

Nice to see it working, but wouldnt it be a better idea to install this plugin by default?

At the moment a novice user who heard about the "Just Works" capabilities of Ubuntu would have difficulties getting VLC to work like it used to on Windows, because Pulseaudio is installed by default in Ubuntu and apparently breaks the ALSA module enabled by default in VLC leading to almost complete system lockups once you close VLC and try to do anything with the Gnome panel.

So please make VLC DEPEND on vlc-plugin-pulse.

Murat Gunes (mgunes) wrote :

Bug 208579 is about VLC not using PulseAudio by default.

Changed in vlc:
status: New → Fix Committed
Changed in vlc:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.