[SRU] virtualbox 6.1.10-dfsg-1~ubuntu1.20.04.1 ADT test failure with linux-hwe-5.8 5.8.0-25.26~20.04.1

Bug #1901904 reported by Stefan Bader on 2020-10-28
256
This bug affects 98 people
Affects Status Importance Assigned to Milestone
liblzf (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned
Groovy
Undecided
Unassigned
virtualbox (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned
Groovy
Undecided
Unassigned
virtualbox-ext-pack (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned
Groovy
Undecided
Unassigned
virtualbox-guest-additions-iso (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned
Groovy
Undecided
Unassigned
virtualbox-hwe (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned
Groovy
Undecided
Unassigned

Bug Description

[SRU Justification]

Impact: The build of virtualbox-dkms modules fails in 20.04/Focal when the 5.8 based HWE kernel is installed.
 * Rename of mm->mmap_sem into mmap_lock
 * Modified API to read/write CR4
 * Modified API to access virtual memory areas

Fix: Picking 2 patches from a later version of virtualbox and adjusting the 3rd to match what upstream virtualbox settled in the end with (that enables some code only for kernels between 2.6.23 and 5.8, the compile of virtualbox-dkms succeeds on 5.8.

Testcase: dkms install -m virtualbox -v 6.1.10 -k 5.8.0-*-generic

[ Other info ]
* for groovy, other than fixing this issue, we finally sync 6.1.16 everywhere (due to late upload before release, this change was suitable to a 0 day SRU but I didn't proceed, so now its a good timing to fix it)
* for focal, it needs liblzf, in the system, I removed the embedded version now that the archive has a packaged one

[ Regression Potential ]
This could show runtime issues when used on the 5.8 kernel but that did not work at all with the Focal version of virtualbox. The code generated for older kernels is unchanged.

---

Testing failed on:
    amd64: https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-focal/focal/amd64/v/virtualbox/20201016_103035_8da78@/log.gz

LIBLZF
[ Impact ]
* Needed to SRU newer virtualbox versions

[Regression Potential]
* none, leaf package

[ Other info ]
Please, this is a bundled library in virtualbox, now packaged as system library.
Unfortunately this is missing in focal, but we need to backport virtualbox from time to time (due to kernel changes).

In order to avoid having a special bundled version in virtualbox again (the library is now stripped from sources), and to introduce bugs in packaging, I would really like to add this library (leaf) to focal

Stefan Bader (smb) on 2020-10-28
tags: added: kernel-adt-failure
Changed in virtualbox (Ubuntu Focal):
assignee: nobody → Stefan Bader (smb)
importance: Undecided → Medium
status: New → In Progress
Changed in virtualbox (Ubuntu):
status: New → Fix Released
description: updated
Stefan Bader (smb) on 2020-10-28
description: updated
Stefan Bader (smb) wrote :

With those changes applied in a VM:

# dkms status
virtualbox, 6.1.10, 5.4.0-52-generic, x86_64: installed
virtualbox, 6.1.10, 5.8.0-25-generic, x86_64: installed

description: updated

I'm going to push the update for focal and groovy

Changed in virtualbox (Ubuntu Groovy):
status: New → Confirmed

uploaded in groovy and focal, will need liblzf unblock from new.

Changed in virtualbox (Ubuntu Groovy):
status: Confirmed → In Progress
description: updated
summary: - virtualbox 6.1.10-dfsg-1~ubuntu1.20.04.1 ADT test failure with linux-
- hwe-5.8 5.8.0-25.26~20.04.1
+ [SRU] virtualbox 6.1.10-dfsg-1~ubuntu1.20.04.1 ADT test failure with
+ linux-hwe-5.8 5.8.0-25.26~20.04.1

Hello Stefan, or anyone else affected,

Accepted virtualbox into groovy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/virtualbox/6.1.16-dfsg-4~ubuntu1.20.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-groovy to verification-done-groovy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-groovy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in virtualbox (Ubuntu Groovy):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-groovy
Changed in virtualbox-ext-pack (Ubuntu Groovy):
status: New → Fix Committed
Łukasz Zemczak (sil2100) wrote :

Hello Stefan, or anyone else affected,

Accepted virtualbox-ext-pack into groovy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/virtualbox-ext-pack/6.1.16-1~ubuntu1.20.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-groovy to verification-done-groovy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-groovy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Łukasz Zemczak (sil2100) wrote :

The focal SRU seems to have a LOT of bugs in the .changes file. Accepting it would result in a lot of chaos for the SRU team, as we'd expect all of the bugs to be verified before releasing the SRU - and none of them had the SRU template.

Would it be possible for you to upload virtualbox focal SRU without the unnecessary bugs linked in the .changes? We basically only need the relevant one, so the one related to the new upstream version.

Changed in virtualbox-hwe (Ubuntu Focal):
status: New → In Progress
Changed in virtualbox-hwe (Ubuntu Groovy):
status: New → In Progress

thanks sil2100, I reuploaded and also added a virtualbox-hwe for groovy to sync versions together.

G.

Before accepting focal we need to unblock this
https://bugs.launchpad.net/ubuntu/+source/liblzf/+bug/1897378

Changed in liblzf (Ubuntu Groovy):
status: New → Fix Released
description: updated
Łukasz Zemczak (sil2100) wrote :

Hello Stefan, or anyone else affected,

Accepted virtualbox-hwe into groovy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/virtualbox-hwe/6.1.16-dfsg-4ubuntu1.20.10.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-groovy to verification-done-groovy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-groovy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in virtualbox-hwe (Ubuntu Groovy):
status: In Progress → Fix Committed

I uploaded a new virtualbox-hwe, sorry for that, but I prefer the minor changes in packaging, to drop /var/run and use /run directly.

It shouldn't matter too much, but it has been requested by release team (and I personally agree with that decision)

Łukasz Zemczak (sil2100) wrote :

Hello Stefan, or anyone else affected,

Accepted virtualbox into groovy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/virtualbox/6.1.16-dfsg-6~ubuntu1.20.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-groovy to verification-done-groovy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-groovy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Łukasz Zemczak (sil2100) wrote :

Hello Stefan, or anyone else affected,

Accepted virtualbox-hwe into groovy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/virtualbox-hwe/6.1.16-dfsg-6ubuntu1.20.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-groovy to verification-done-groovy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-groovy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Łukasz Zemczak (sil2100) wrote :
Changed in liblzf (Ubuntu Focal):
status: New → Fix Committed
Timo Aaltonen (tjaalton) wrote :

Hello Stefan, or anyone else affected,

Accepted virtualbox into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/virtualbox/6.1.16-dfsg-6~ubuntu1.20.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in virtualbox (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed-focal
Changed in virtualbox-hwe (Ubuntu Focal):
status: In Progress → Fix Committed
Timo Aaltonen (tjaalton) wrote :

Hello Stefan, or anyone else affected,

Accepted virtualbox-hwe into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/virtualbox-hwe/6.1.16-dfsg-6ubuntu1.20.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in virtualbox-ext-pack (Ubuntu Focal):
status: New → Fix Committed
Timo Aaltonen (tjaalton) wrote :

Hello Stefan, or anyone else affected,

Accepted virtualbox-ext-pack into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/virtualbox-ext-pack/6.1.16-1~ubuntu1.20.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Timo Aaltonen (tjaalton) wrote :

Hello Stefan, or anyone else affected,

Accepted virtualbox-guest-additions-iso into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/virtualbox-guest-additions-iso/6.1.16-1~ubuntu1.20.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in virtualbox-guest-additions-iso (Ubuntu Focal):
status: New → Fix Committed
Sønke Lorenzen (solorenzen) wrote :

I have installed and tested some of the packages on 20.10 and 20.04

On 20.10 I installed

virtualbox-dkms/groovy-proposed
virtualbox-ext-pack/groovy-proposed
virtualbox-qt/groovy-proposed
virtualbox/groovy-proposed

and I could use some previously installed VMs without problems then.

virtualbox-guest-additions-iso/groovy-proposed was not available yet, I try to check tht when its in proposed.

On 20.04 I installed

virtualbox-guest-additions-iso/focal-proposed
virtualbox-qt/focal-proposed
virtualbox/focal-proposed
virtualbox-dkms/focal-proposed

and could also use previously installed VMs without problems.

thanks for confirming, also autopkgtests were good! I will receive some more testing in the next few days and report here if something breaks.

tags: added: verification-done-focal verification-done-groovy
removed: verification-needed-focal verification-needed-groovy
tags: added: verification-done
removed: verification-needed
Changed in liblzf (Ubuntu):
status: New → Fix Released
Changed in virtualbox-ext-pack (Ubuntu):
status: New → Fix Released
Changed in virtualbox-guest-additions-iso (Ubuntu):
status: New → Fix Released
Changed in virtualbox-hwe (Ubuntu):
status: New → Fix Released
Changed in virtualbox-guest-additions-iso (Ubuntu Groovy):
status: New → Fix Released
Changed in virtualbox (Ubuntu Focal):
assignee: Stefan Bader (smb) → nobody
importance: Medium → Undecided
Cristiano Nunes (cfgnunes) wrote :

I have installed and tested here in 20.04.1: without problems.

thanks for testing!

Kopa Rebu (koparebu) wrote :

Hi,

I'd like to ask, is enabling "proposed-updates" the only way to get VirtualBox working again for the current Ubuntu LTS, in less than seven days? I mean, without having to download VirtualBox directly from Oracle, which has its own problems (python 2 dependencies).

If that's the case, is it possible to just install those VirtualBox packages from the "proposed" repository, and nothing else, and get back to using the packages from the "updates" repository once they are released there?

Thanks in advance.

Sønke Lorenzen (solorenzen) wrote :

Hi Kopa,

If you follow the instructions from the linked https://wiki.ubuntu.com/Testing/EnableProposed then you will only get the packages from proposed you specify from proposed.

But you can also follow the links from where Timo wrote "Hello Stefan, or anyone else affected," in the recent comments whee the packages got to proposed

https://launchpad.net/ubuntu/+source/virtualbox/6.1.16-dfsg-6~ubuntu1.20.04.1

https://launchpad.net/ubuntu/+source/virtualbox-guest-additions-iso/6.1.16-1~ubuntu1.20.04.1

https://launchpad.net/ubuntu/+source/liblzf/3.6-2~ubuntu1.20.04.1

and get the deb files from there

Use

    apt list --installed|grep virtualbox

to see what virtualbox packages you have installed now and get the updated ones from the links. You also need https://launchpad.net/ubuntu/focal/+package/liblzf-dev

Kopa Rebu (koparebu) wrote :

Hi Sønke,

Thank you for your helping, I guess downloading the three packages manually (in my case: virtualbox, virtualbox-dkms and virtualbox-qt) would be the easiest way to get them installed.

What I don't know is if, when the fixes get from the "proposed" to the "updates" repositories, I will have to uninstall the packages I manually downloaded and install them again (this time from the repo) in order to keep them managed by apt.

Regards.

@koparebu -- You will need liblzf1 manually downloaded too in order to manually download like that.
In any case, once manually installed, unless you went out of your way to 'pin' or 'hold' the packages, apt/update-manager will happily "upgrade" them in future if they are superseded by newer packages in the repositories, so there is no need to be concerned.

I can confirm virtualbox-6.1.16-dfsg-6 packages (including -ext-pack and -guest-additions-iso) seem to be working well, even succeeds in 'resuming' a VM that was "saved" under 6.1.10 . Exercised many functions and having no issues as-yet.
I tested against the focal-proposed kernel 5.4.0-61, very successfully!. I understand others have been trying the 5.8 kernels already (e.g. ubuntu 20.10).

Kopa Rebu (koparebu) wrote :

Thank you Simon for your advice.

I've manually installed the following proposed packages:

* liblzf1_3.6-2~ubuntu1.20.04.1_amd64.deb
* virtualbox_6.1.16-dfsg-6~ubuntu1.20.04.1_amd64.deb
* virtualbox-dkms_6.1.16-dfsg-6~ubuntu1.20.04.1_amd64.deb
* virtualbox-qt_6.1.16-dfsg-6~ubuntu1.20.04.1_amd64.deb

and I can confirm VirtualBox works again under kernel 5.8.0 from Ubuntu 20.04.

thanks you all for the great testing!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virtualbox - 6.1.16-dfsg-6~ubuntu1.20.10.1

---------------
virtualbox (6.1.16-dfsg-6~ubuntu1.20.10.1) groovy; urgency=medium

   * SRU the latest package for Ubuntu groovy (LP: #1901904)

 -- Gianfranco Costamagna <email address hidden> Thu, 17 Dec 2020 23:06:23 +0100

Changed in virtualbox (Ubuntu Groovy):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for virtualbox has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virtualbox-ext-pack - 6.1.16-1~ubuntu1.20.10.1

---------------
virtualbox-ext-pack (6.1.16-1~ubuntu1.20.10.1) groovy; urgency=medium

  * SRU the latest package for Ubuntu groovy (LP: #1901904)

 -- Gianfranco Costamagna <email address hidden> Thu, 26 Nov 2020 14:50:15 +0100

Changed in virtualbox-ext-pack (Ubuntu Groovy):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virtualbox - 6.1.16-dfsg-6~ubuntu1.20.04.1

---------------
virtualbox (6.1.16-dfsg-6~ubuntu1.20.04.1) focal; urgency=medium

   * SRU the latest package for Ubuntu focal (LP: #1901904)

 -- Gianfranco Costamagna <email address hidden> Thu, 17 Dec 2020 23:06:23 +0100

Changed in virtualbox (Ubuntu Focal):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virtualbox-hwe - 6.1.16-dfsg-6ubuntu1.20.04.1

---------------
virtualbox-hwe (6.1.16-dfsg-6ubuntu1.20.04.1) focal; urgency=medium

  * SRU the latest package for Ubuntu focal (LP: #1901904)

 -- Gianfranco Costamagna <email address hidden> Thu, 17 Dec 2020 23:02:54 +0100

Changed in virtualbox-hwe (Ubuntu Focal):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virtualbox-guest-additions-iso - 6.1.16-1~ubuntu1.20.04.1

---------------
virtualbox-guest-additions-iso (6.1.16-1~ubuntu1.20.04.1) focal; urgency=medium

  * SRU the latest package for Ubuntu focal (LP: #1901904)

virtualbox-guest-additions-iso (6.1.16-1) unstable; urgency=medium

  * New upstream version 6.1.16

virtualbox-guest-additions-iso (6.1.14-1) unstable; urgency=medium

  * New upstream version 6.1.14

virtualbox-guest-additions-iso (6.1.12-1) unstable; urgency=medium

  * New upstream version 6.1.12

 -- Gianfranco Costamagna <email address hidden> Thu, 26 Nov 2020 14:54:18 +0100

Changed in virtualbox-guest-additions-iso (Ubuntu Focal):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virtualbox-hwe - 6.1.16-dfsg-6ubuntu1.20.10.1

---------------
virtualbox-hwe (6.1.16-dfsg-6ubuntu1.20.10.1) groovy; urgency=medium

  * SRU the latest package for Ubuntu groovy (LP: #1901904)

 -- Gianfranco Costamagna <email address hidden> Thu, 17 Dec 2020 23:02:54 +0100

Changed in virtualbox-hwe (Ubuntu Groovy):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virtualbox-ext-pack - 6.1.16-1~ubuntu1.20.04.1

---------------
virtualbox-ext-pack (6.1.16-1~ubuntu1.20.04.1) focal; urgency=medium

  * SRU the latest package for Ubuntu focal (LP: #1901904)

virtualbox-ext-pack (6.1.16-1) unstable; urgency=medium

  * New upstream version 6.1.16
  * Update postinst file

virtualbox-ext-pack (6.1.14-2) unstable; urgency=medium

  * Update accept license keyword and license

virtualbox-ext-pack (6.1.14-1) unstable; urgency=medium

  * New upstream version 6.1.14
  * Update postinst

virtualbox-ext-pack (6.1.12-2) unstable; urgency=medium

  [ Unit 193 ]
  * d/control, d/copyright: Update my email address.

virtualbox-ext-pack (6.1.12-1) unstable; urgency=medium

  * New upstream version 6.1.12
  * Update postinst

 -- Gianfranco Costamagna <email address hidden> Thu, 26 Nov 2020 14:50:15 +0100

Changed in virtualbox-ext-pack (Ubuntu Focal):
status: Fix Committed → Fix Released
Changed in liblzf (Ubuntu Focal):
status: Fix Committed → Fix Released
dizzy5 (x-contact-u) wrote :

Today's Ubuntu update helped fix this for me. I had to run the following to finish setting up...

$ sudo apt-get install virtualbox-dkms
$ sudo modprobe vboxdrv

Download: 'VirtualBox 6.1.16 Oracle VM VirtualBox Extension Pack' from https://www.virtualbox.org/wiki/Downloads

* If it doesn't install automatically, add to VirtualBox > File > Preferences > Extensions

Robie Basak (racb) on 2021-01-27
tags: added: hwe-dkms regression-update
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers