Comment 59 for bug 1818049

Akima (8-me-w) wrote :

Writing to report that the following upgrade (taken from /var/log/apt/history.log) has resolved my Virtualbox issue:

> Upgrade: virtualbox:amd64 (4.3.36-dfsg-1+deb8u1ubuntu1.14.04.2, 4.3.40-dfsg-0ubuntu14.04.1), virtualbox-dkms:amd64 (4.3.36-dfsg-1+deb8u1ubuntu1.14.04.2, 4.3.40-dfsg-0ubuntu14.04.1), virtualbox-qt:amd64 (4.3.36-dfsg-1+deb8u1ubuntu1.14.04.2, 4.3.40-dfsg-0ubuntu14.04.1)

I am now able to launch Virtualbox virtual machines on this system:

> $ uname -a
> Linux hostname 4.4.0-143-generic #169~14.04.2-Ubuntu SMP Wed Feb 13 15:00:41 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

> $ lsb_release -a
> No LSB modules are available.
> Distributor ID: Ubuntu
> Description: Ubuntu 14.04.6 LTS
> Release: 14.04
> Codename: trusty

Note: before applying the Virtualbox updates, I made sure to first reboot back into the 4.4.0-143-generic kernel to be sure that the Virtualbox kernel module(s) were built against the correct kernel. Regarding the others here that have found that the latest Virtualbox updates haven't resolved the issue for them, is it possible that they were not booted into the latest generic kernel when they applied the Virtualbox updates? Perhaps the kernel modules are only built for the running kernel.