virtualbox-dkms: virtualbox kernel module failed to build [gcc: error: unrecognized command line option ‘-fstack-protector-strong’]

Bug #1521734 reported by ndeubert on 2015-12-01
170
This bug affects 32 people
Affects Status Importance Assigned to Milestone
virtualbox (Ubuntu)
High
Unassigned

Bug Description

just ran apt-get update and apt-get dist-upgrade and got this.

ProblemType: Package
DistroRelease: Ubuntu 15.10
Package: virtualbox-dkms 5.0.10-dfsg-2ubuntu1
ProcVersionSignature: Ubuntu 4.2.0-17.21-generic 4.2.3
Uname: Linux 4.2.0-17-generic x86_64
ApportVersion: 2.19.1-0ubuntu5
Architecture: amd64
DKMSKernelVersion: 4.2.0-17-generic
Date: Tue Dec 1 14:24:45 2015
DuplicateSignature: dkms:virtualbox-dkms:5.0.10-dfsg-2ubuntu1:gcc: error: unrecognized command line option ‘-fstack-protector-strong’
InstallationDate: Installed on 2015-06-05 (179 days ago)
InstallationMedia: Xubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422.1)
PackageArchitecture: all
PackageVersion: 5.0.10-dfsg-2ubuntu1
RelatedPackageVersions:
 dpkg 1.18.2ubuntu5.1
 apt 1.0.10.2ubuntu1
SourcePackage: virtualbox
Title: virtualbox-dkms 5.0.10-dfsg-2ubuntu1: virtualbox kernel module failed to build
UpgradeStatus: Upgraded to wily on 2015-11-02 (29 days ago)

ndeubert (ndeubert) wrote :
summary: virtualbox-dkms 5.0.10-dfsg-2ubuntu1: virtualbox kernel module failed to
- build
+ build [gcc: error: unrecognized command line option ‘-fstack-protector-
+ strong’]
tags: removed: need-duplicate-check

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in virtualbox (Ubuntu):
status: New → Confirmed
Changed in virtualbox (Ubuntu):
importance: Undecided → Medium

Hi, for some reasons you seem to have not kmk to build the modules, maybe something like
echo $MAKE

and export MAKE=kmk might help.

cheers,

G.

Changed in virtualbox (Ubuntu):
status: Confirmed → Invalid
status: Invalid → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for virtualbox (Ubuntu) because there has been no activity for 60 days.]

Changed in virtualbox (Ubuntu):
status: Incomplete → Expired
Ville Nummela (ville-nummela) wrote :

Building kernel drivers for newer kernels requires gcc 4.9. Workaround steps:

apt-get install gcc-4.9
rm /usr/bin/gcc
ln -s /usr/bin/gcc-4.9 /usr/bin/gcc
dpkg-reconfigure virtualbox-dkms

Changed in virtualbox (Ubuntu):
status: Expired → Confirmed
summary: - virtualbox-dkms 5.0.10-dfsg-2ubuntu1: virtualbox kernel module failed to
- build [gcc: error: unrecognized command line option ‘-fstack-protector-
- strong’]
+ virtualbox-dkms: virtualbox kernel module failed to build [gcc: error:
+ unrecognized command line option ‘-fstack-protector-strong’]
tags: added: artful
Changed in virtualbox (Ubuntu):
importance: Medium → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers