virtualbox: Lucid alpha2 does not boot

Bug #508777 reported by Michael Schwartzkopff on 2010-01-17
82
This bug affects 17 people
Affects Status Importance Assigned to Milestone
virtualbox-ose (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by JanBrinkmann

Bug Description

My system:
AMD64, virtualbox 3.1.2. In this environment LL-A2 boots three lines:

fsck from util-linux-ng 2.16
/dev/sda1: clean, 48097/247008 files, 209377/987989 blocks
[ 7.688297] piix_smbus 0000:00:07.0: SMBus base address uninitialized - upgrade BIOS or use force_addr=0xaddr

Then the machine freezes.

Greetings,

Michael Schwartzkopff.

olituks (olituks) wrote :

Hello,

I have also the same problem. I have tested with the last virtualbox .deb and with ose edition.

JanBrinkmann (jbrinkmann) wrote :

I can confirm this behaviour on Karmic i386. Here some additional details :

1) virtualbox ose package:

Package: virtualbox-ose
Priority: optional
Section: universe/misc
Installed-Size: 24292
Maintainer: Ubuntu MOTU Developers <email address hidden>
Original-Maintainer: Debian Virtualbox Team <email address hidden>
Architecture: i386
Version: 3.0.8-dfsg-1ubuntu1
Depends: libc6 (>= 2.7), libcurl3 (>= 7.16.2-1), libgcc1 (>= 1:4.1.1), libpython2.6 (>= 2.6), libsdl1.2debian (>= 1.2.10-1), libssl0.9.8 (>= 0.9.8f-5), libstdc++6 (>= 4.2.1), libx11-6, libxcursor1 (>> 1.1.2), libxext6, libxml2 (>= 2.7.4), libxmu6, libxslt1.1 (>= 1.1.18), libxt6, zlib1g (>= 1:1.1.4), python (>= 2.4), python-central (>= 0.6.11), adduser
Recommends: virtualbox-ose-source (= 3.0.8-dfsg-1ubuntu1), virtualbox-ose-qt (= 3.0.8-dfsg-1ubuntu1), libgl1, libhal1
Suggests: virtualbox-guest-additions, libasound2, libpulse0
Conflicts: virtualbox, virtualbox-2.0, virtualbox-2.1, virtualbox-2.2, virtualbox-3.0
Filename: pool/universe/v/virtualbox-ose/virtualbox-ose_3.0.8-dfsg-1ubuntu1_i386.deb
Size: 6330620
MD5sum: 426eb2aba01e8a3a0579ff5207ac516f
SHA1: 820998e81bf569d08731765bd8cf24cce1a99266
SHA256: afdc95924ef8de840386360831694b7c925dfb5d957fce2abb5c8f571c36c683
Description: x86 virtualization solution - base binaries
 VirtualBox is a free x86 virtualization solution allowing a wide range
 of x86 operating systems such as Windows, DOS, BSD or Linux to run on a
 Linux system.
 .
 This package provides the binaries for the Open Source Edition of
 VirtualBox. The virtualbox-ose-source package is also required in order to
 compile the kernel modules needed for virtualbox-ose. A graphical user
 interface for VirtualBox is provided by the package virtualbox-ose-qt.
Homepage: http://www.virtualbox.org/
Python-Version: >= 2.4
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu

2) lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 9.10
Release: 9.10
Codename: karmic

affects: ubuntu → virtualbox-ose (Ubuntu)
Changed in virtualbox-ose (Ubuntu):
status: New → Confirmed
JanBrinkmann (jbrinkmann) wrote :

A fix could be to update the karmic virtualbox version to 3.1.2, since it's a common way to test alphas like lucid in this case, or to evalutate upgrades in a testing environment etc:

https://bugs.launchpad.net/ubuntu/+source/virtualbox-ose/+bug/474625

summary: - Lucid alpha2 does not boot
+ virtualbox: Lucid alpha2 does not boot

This is a problem with the Ubuntu Image, not with the Virtual Box package that is being distributed.

I had similar symptoms, so I went to Windows XP and installed the last version of VirtualBox Free Edition (not Open Source). I tried to boot the Lucid ISO (and yes the checksum was ok). The initial menu came out OK, but after selecting "Try Ubuntu without Installing" or "Install Ubuntu" all I got was a black screen with a white underscore on the upper-left corner.

Maybe this has something to do with the introduction of Plymouth?

Tony Pursell (ajpursell) wrote :

My experience is slightly different. I upgraded VirtualBox on XP to 3.1.2 and Alpha 1 ran OK on it. I then did a fresh install of Alpha 2. This worked until I installed the first batch of updates. Then I got the failure to boot as described by Paulo (black screen with a white underscore on the upper-left corner). So I then did a fresh install of Alpha2 (same iso as before) hoping it would boot, but it does not.

Varga Péter (vpetike) wrote :

Upgraded to SUN VirtualBox 3.1.2 r56127 on karmic, same problem

Varga Péter (vpetike) wrote :

If i install alpha1, then apt-get upgrade, there is no problem. If I do apt-get dist-upgrade, machine freezes. Booting with a recovery cd, and changing GRUB to let me select which kernel to boot, and choosing the old (2.6.32-7) kernel, everything is fine.

Brewster Malevich (brews) wrote :

I confirm #7, but with Alpha 2. It boots off the original .iso but then fails after I upgrade packages. It's gotta be a funky kernel.

Confirmed. Installation of Lucid works fine (Image: lucid-alternate-i386.iso, 15.01.2010). After updating to the machine booting is no longer possible.

The problem does not seem to be kernel related though. The machine hangs directly after "grub loading", before I get the chance to select a kernel. The initial image contained kernel 2.6.32-10 (booted fine), after the update I have 2.6.32-12 (additional). The machine hangs before I have the chance to select either kernel.

David Planella (dpm) wrote :

I've had similar experiences.

My machine does not have hardware virtualization support, and Lucid images were working fine in Virtualbox up to a point. Now they can only start the bootloader, and whenever I try "Try Ubuntu without installing" or "Install Ubuntu", the VM hangs with 100% CPU usage. That's with either the desktop or alternate CDs, and I could reproduce it both in Karmic and Lucid host systems with different virtualbox versions.

There's also bug 518745, which might be a duplicate.

Michael Schwartzkopff (misch) wrote :

Hi,

It seems to be a kernel bus in 2.6.32. I updated my VirtualBox to version 3.1.4 (sic !) which includes a workaround for a bug in the 2.6.32 kernel, virtualization part. See bug 6100 of virtualbox.

Not alpha2 of lucid boots, well at least I see other problems.

So I think this problem should be solved upstream.

Greetings,

Michael Schwartzkopff.

David Planella (dpm) wrote :

Installing the upstream 3.1.4 package did not solve the bug for me, but for the record, here's the direct link to the bug:

  http://www.virtualbox.org/ticket/6100

Booting the image with acpi=off (by pressing F6 and checking the option in the Ubuntu bootloader) as suggested there as a workaround did allow me to boot the image with virtualbox-ose 3.1.2-dfsg-1ubuntu1 (the Lucid one).

Grant Bowman (grantbow) wrote :

This bug stops some people from being able to test Lucid. The F6 acpi workaround (worked for me) needs to be put in various release notes. I hope that some version of virtualbox-ose that fixes this bug (3.1.5+?) also gets into Karmic soon. The Karmic one is currently at version 3.0.8-dfsg-1ubuntu1.

I did some testing with the daily image from today (2010-02-17) and I was able to boot selecting *either* "acpi=off" or "nomodeset". Trying to boot with the default configuration still leads nowhere.

Thanks for testing that, Paulo. That kind of testing can help to isolate
possible fixes.

On Feb 17, 2010 11:45 AM, "Paulo Albuquerque" <email address hidden>
wrote:

I did some testing with the daily image from today (2010-02-17) and I
was able to boot selecting *either* "acpi=off" or "nomodeset". Trying to
boot with the default configuration still leads nowhere.

--
virtualbox: Lucid alpha2 does not boot
https://bugs.launchpad.net/bugs/508777
You received this...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.