virtualbox-ose-modules for 2.6.24-19 missing

Bug #238019 reported by petit-prince
50
Affects Status Importance Assigned to Milestone
virtualbox-ose-modules (Ubuntu)
Fix Released
High
Daniel Hahler
Hardy
Fix Released
High
Unassigned

Bug Description

I just performed an upgrade of Hardy using the update-manager, which installed the latest kernel from the Ubuntu archives: 2.6.24-19. Unfortunately, I couldn't find the matching virtualbox-ose modules. So we need to get them uploaded to the ubuntu archives, and make virtualbox-ose-modules-generic and so on depend on them.

For those of you who want to put some effort into a manual, yet clean workaround:
sudo apt-get install module-assistant
cd /usr/src
sudo m-a a-i virtualbox-ose
It'll do everything (prepare the system, download the sources, compile them, package the binaries and install the package) automagically for you. The resulting package is attached to this post.

All best,
Dan

Revision history for this message
petit-prince (petit-prince) wrote :
Changed in virtualbox-ose-modules:
status: New → Confirmed
Revision history for this message
Daniel Hahler (blueyed) wrote :

I'll upload a package for this, once the modules for -18 get copied to hardy-updates (bug 237278).

Changed in virtualbox-ose-modules:
assignee: nobody → blueyed
importance: Undecided → High
status: Confirmed → In Progress
Revision history for this message
Andrew Stabeno (astabeno) wrote :

We need to figure out a way to streamline this if it is possible. Seems we have had a lot of Kernel updates lately and it the Virtualbox modules are few days behind. Thanks Daniel for getting this started while the kernel is still in proposed updates for this time.

Revision history for this message
Daniel Hahler (blueyed) wrote :

Uploaded.

Andrew, Jeff proposed using DKMS for this and said he'll look into this during the next days, see https://lists.ubuntu.com/archives/kernel-team/2008-June/002526.html.

Changed in virtualbox-ose-modules:
status: In Progress → Fix Committed
Revision history for this message
Steve Langasek (vorlon) wrote :

accepted into hardy-proposed.

Changed in virtualbox-ose-modules:
status: Fix Committed → Fix Released
Revision history for this message
Gabriele Monti (psicus78) wrote :

Hi,
can I ask you why was the setup option removed from vboxdrv?

Revision history for this message
petit-prince (petit-prince) wrote :

Steve,

the package from hardy-proposed appears to work for me.

Thanks.

Changed in virtualbox-ose-modules:
importance: Undecided → High
status: New → Fix Committed
Revision history for this message
Daniel Hahler (blueyed) wrote :

The package works for me, too (I'm the uploader after all).

Since the kernel has been copied to hardy-updates now, please copy this package to hardy-updates, too.

@Gabriele: I had removed it since it should not be necessary after all, when the package is in sync with the kernel.

Revision history for this message
fx5 (packaging) wrote :

Please copy the packages to hardy-updates.

Will virtualbox stop working with every kernel update in the future?

Revision history for this message
SilverWave (silverwave) wrote :

I can confirm that "virtualbox-ose-modules for 2.6.24-19" in "hardy-proposed" work for me.

---
Ubuntu 8.04 64bit
SM-226BW 22" - GF 8600 - Intel Quad Pro Q6600 - Abit AW9D-MAX
4GB GeIL RAM - WD Caviar - Pioneer DVD IDE - 600w OCZ - Saitek KB - FD

Revision history for this message
Daniel Hahler (blueyed) wrote :

Marking verification-done, although I'm not in the sru-verification team.

Revision history for this message
Daniel Hahler (blueyed) wrote :

Martin: I've subscribed you. Can you please copy the package to hardy-updates?

Revision history for this message
Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in virtualbox-ose-modules:
status: Fix Committed → Fix Released
Revision history for this message
David (gaffin) wrote :

I just installed the updates and get this:

Preconfiguring packages ...
Selecting previously deselected package virtualbox-ose.
(Reading database ... 164595 files and directories currently installed.)
Unpacking virtualbox-ose (from .../virtualbox-ose_1.5.6-dfsg-6ubuntu1_i386.deb) ...
Selecting previously deselected package virtualbox-ose-guest-modules-2.6.24-19-generic.
Unpacking virtualbox-ose-guest-modules-2.6.24-19-generic (from .../virtualbox-ose-guest-modules-2.6.24-19-generic_24.0.4_i386.deb) ...
Selecting previously deselected package virtualbox-ose-modules-2.6.24-19-generic.
Unpacking virtualbox-ose-modules-2.6.24-19-generic (from .../virtualbox-ose-modules-2.6.24-19-generic_24.0.4_i386.deb) ...
Setting up virtualbox-ose (1.5.6-dfsg-6ubuntu1) ...
 * Starting VirtualBox host networking...
   ...done.
 * Starting VirtualBox kernel module vboxdrv
   ...done.

Setting up virtualbox-ose-guest-modules-2.6.24-19-generic (24.0.4) ...
FATAL: Error inserting vboxadd (/lib/modules/2.6.24-19-generic/misc/vboxadd.ko): No such device

Setting up virtualbox-ose-modules-2.6.24-19-generic (24.0.4) ...

Revision history for this message
Daniel Hahler (blueyed) wrote :

David, the error is from virtualbox-ose-guest-modules and should get ignored (i.e. not cause any crash report and/or upgrade failure).
The reason probably is, that you've installed the package on the host system, while it only is useful in the guest machines (virtualbox images).

Revision history for this message
hdante (hdante) wrote :

Same problem here, solved with the "m-a" thing. Thanks for the solution.

BTW, this bug is ridiculous. Virtualbox broke for kernels -14, -15, -16, -17, etc. It's not possible that every time a new kernel is released, somebody has to remember updating virtual box drivers, or everybody's system will stop working, specially if the recompiling is trivial.

This bug should be changed to "keep drivers (virtualbox and any other) in sync with every kernel revision".

Revision history for this message
Martin Pitt (pitti) wrote : Re: [Bug 238019] Re: virtualbox-ose-modules for 2.6.24-19 missing

hdante [2008-07-18 19:02 -0000]:
> This bug should be changed to "keep drivers (virtualbox and any other)
> in sync with every kernel revision".

Or, rather, "use dkms for virtualbox kernel modules", so that it will
auto-update itself on user's boxes.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers