package python-virtkey (not installed) failed to install/upgrade: file does not exist: /usr/lib/python2.6/dist-packages/python_virtkey-0.60.0.egg-info

Bug #648695 reported by Fritz Heinrichmeyer
This bug affects 349 people
Affects Status Importance Assigned to Milestone
virtkey
Undecided
Unassigned
virtkey (Ubuntu)
Critical
Bilal Akhtar
Maverick
Critical
Bilal Akhtar

Bug Description

Entpacke python-virtkey (aus .../python-virtkey_0.60.0-0ubuntu1_i386.deb) ...
Richte python-virtkey ein (0.60.0-0ubuntu1) ...
file does not exist: /usr/lib/python2.6/dist-packages/python_virtkey-0.60.0.egg-info
pycentral: pycentral pkginstall: error byte-compiling files (1)
pycentral pkginstall: error byte-compiling files (1)
dpkg: Fehler beim Bearbeiten von python-virtkey (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
Fehler traten auf beim Bearbeiten von:
 python-virtkey

ProblemType: Package
DistroRelease: Ubuntu 10.10
Package: python-virtkey (not installed)
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
Architecture: i386
Date: Mon Sep 27 12:55:10 2010
ErrorMessage: Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release Candidate i386 (20091020.3)
SourcePackage: virtkey
Title: package python-virtkey (not installed) failed to install/upgrade: Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück

Related branches

Revision history for this message
Fritz Heinrichmeyer (fritz-heinrichmeyer) wrote :
Revision history for this message
Fritz Heinrichmeyer (fritz-heinrichmeyer) wrote :

this package is necessary for "onboard" package

Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

confirmed in maverick with 0.60.0-0ubuntu1
setting to critical because python-virtkey is indirectly installed by ubuntu-desktop (via onboard)

summary: - package python-virtkey (not installed) failed to install/upgrade:
- Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1
- zurück
+ package python-virtkey (not installed) failed to install/upgrade: file
+ does not exist: /usr/lib/python2.6/dist-
+ packages/python_virtkey-0.60.0.egg-info
Changed in virtkey (Ubuntu):
importance: Undecided → Critical
status: New → Triaged
Gary M (garym)
tags: added: amd64
Revision history for this message
drink (martin-espinoza) wrote :

Here's some more output to drive the message home.

The following partially installed packages will be configured:
  onboard python-virtkey
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Setting up python-virtkey (0.60.0-0ubuntu1) ...
file does not exist: /usr/lib/python2.6/dist-packages/python_virtkey-0.60.0.egg-info
pycentral: pycentral pkginstall: error byte-compiling files (1)
pycentral pkginstall: error byte-compiling files (1)
dpkg: error processing python-virtkey (--configure):
 subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already
                                                              No apport report written because MaxReports is reached already
                                            dpkg: dependency problems prevent configuration of onboard:
 onboard depends on python-virtkey (>= 0.60.0); however:
  Package python-virtkey is not configured yet.
dpkg: error processing onboard (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 python-virtkey
 onboard
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up python-virtkey (0.60.0-0ubuntu1) ...
file does not exist: /usr/lib/python2.6/dist-packages/python_virtkey-0.60.0.egg-info
pycentral: pycentral pkginstall: error byte-compiling files (1)
pycentral pkginstall: error byte-compiling files (1)
dpkg: error processing python-virtkey (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of onboard:
 onboard depends on python-virtkey (>= 0.60.0); however:
  Package python-virtkey is not configured yet.
dpkg: error processing onboard (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 python-virtkey
 onboard

Revision history for this message
James (jlgrady1) wrote :

I was able to work around the problem using the following commands:

sudo cp /usr/share/pyshared/python_debian-0.1.16ubuntu1.egg-info/PKG-INFO /usr/share/pyshared/python_virtkey-0.60.0.egg-info

sudo apt-get -f install

Revision history for this message
Chen Liang (chenliang) wrote :

I remove the package python-virtkey along with onboard. I don't need a on screen keyboard anyway.

Revision history for this message
Bilal Akhtar (bilalakhtar) wrote :

This bug has a large number of dups! I am sourcing this package, let me check if I am able to fix it.

Revision history for this message
Vladimir Hidalgo (vlad88sv) wrote :

#5 worked for me, just that I need to do this before:
sudo rm /usr/share/pyshared/python_virtkey-0.60.0.egg-info

Otherwise cp complains about overwriting a symbolic link with no target

Changed in virtkey (Ubuntu):
assignee: nobody → Bilal Akhtar (bilalakhtar)
status: Triaged → In Progress
Revision history for this message
Daniel Ward (dwa012) wrote :

I encounted this problem as well today.
I used #5's work around ans the error seems to be resolved.

Revision history for this message
Embridioum (embridioum) wrote :

Yeah, I'm unistalling too.

Revision history for this message
Bill Allan (william-allan-2) wrote :

I am using a Gateway LT22 netbook (AMD Athlon II Neo Processor K125). The keyboard and trackpad (Synaptics) work in Windows 7 but do not work when I boot into Ubuntu 10.10. I must plug into the netbook an external USB keyboard and mouse. Are the two problems related?

Revision history for this message
joopbraak (joopbraak) wrote :

ls -la /usr/lib/python2.6/dist-packages/python_virtkey-0.60.0.egg-info
lrwxrwxrwx 1 root root 50 2010-09-27 15:52 /usr/lib/python2.6/dist-packages/python_virtkey-0.60.0.egg-info -> /usr/share/pyshared/python_virtkey-0.60.0.egg-info

ls -la /usr/share/pyshared/python_virtkey-0.60.0.egg-info
lrwxrwxrwx 1 root root 46 2010-09-27 14:50 /usr/share/pyshared/python_virtkey-0.60.0.egg-info -> /share/pyshared/python_virtkey-0.60.0.egg-info

ls -la /share/pyshared/python_virtkey-0.60.0.egg-info
ls: cannot access /share/pyshared/python_virtkey-0.60.0.egg-info: No such file or directory

Oops !

sudo find / -iname python_virtkey-0.60.0.egg-info -exec ls -la {} +
lrwxrwxrwx 1 root root 50 2010-09-27 15:52 /usr/lib/python2.6/dist-packages/python_virtkey-0.60.0.egg-info -> /usr/share/pyshared/python_virtkey-0.60.0.egg-info
lrwxrwxrwx 1 root root 46 2010-09-27 14:50 /usr/share/pyshared/python_virtkey-0.60.0.egg-info -> /share/pyshared/python_virtkey-0.60.0.egg-info

P.S.
I think the next time it would be wise to not take a German install as main bug and mark the rest as duplicates, now we have 100 duplicates because everyone thinks her/his problem is different.

Revision history for this message
Paul Piscuc (paul.piscuc) wrote :

#5 workd for me also. (using ubuntu 10.10)

Revision history for this message
Bilal Akhtar (bilalakhtar) wrote :

I got the fix, making a debdiff and requesting sponsorship now.

Revision history for this message
Bilal Akhtar (bilalakhtar) wrote :
Revision history for this message
Bilal Akhtar (bilalakhtar) wrote :

Sponsors usually ignore assigned bugs, so I am unassigning myself, but I have the fix attached.

Changed in virtkey (Ubuntu Maverick):
assignee: Bilal Akhtar (bilalakhtar) → nobody
Revision history for this message
Chris Coulson (chrisccoulson) wrote :

Ok, I've uploaded this to Maverick now. Thanks for working on this!

Changed in virtkey (Ubuntu Maverick):
status: In Progress → Fix Committed
Revision history for this message
Bilal Akhtar (bilalakhtar) wrote :

Can assign myself back now :)

Changed in virtkey (Ubuntu Maverick):
assignee: nobody → Bilal Akhtar (bilalakhtar)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package virtkey - 0.60.0-0ubuntu2

---------------
virtkey (0.60.0-0ubuntu2) maverick; urgency=low

  * Prevent include-links from being set in the DH_PYCENTRAL variable
    before the build, this is not needed in this package and generates
    broken symlinks, hence preventing the package from installing properly.
    (LP: #648695)
 -- Bilal Akhtar <email address hidden> Mon, 27 Sep 2010 17:23:47 +0300

Changed in virtkey (Ubuntu Maverick):
status: Fix Committed → Fix Released
Revision history for this message
Danne MCA (danne-mca) wrote :

Fixed to me with: sudo rm /usr/share/pyshared/python_virtkey-0.60.0.egg-info ; sudo cp /usr/share/pyshared/python_debian-0.1.16ubuntu1.egg-info/PKG-INFO /usr/share/pyshared/python_virtkey-0.60.0.egg-info ; sudo apt-get -f install

Revision history for this message
Joel Berger (joel-a-berger) wrote :

Thanks Danne, worked for me

Revision history for this message
Bilal Akhtar (bilalakhtar) wrote : Re: [Bug 648695] Re: package python-virtkey (not installed) failed to install/upgrade: file does not exist: /usr/lib/python2.6/dist-packages/python_virtkey-0.60.0.egg-info

On Mon, 2010-09-27 at 15:38 +0000, Danne MCA wrote:
> Fixed to me with: sudo rm /usr/share/pyshared/python_virtkey-0.60.0.egg-
> info ; sudo cp /usr/share/pyshared/python_debian-0.1.16ubuntu1.egg-info
> /PKG-INFO /usr/share/pyshared/python_virtkey-0.60.0.egg-info ; sudo apt-
> get -f install

Please stop sending any more workarounds; These are sure to confuse new
users, and the bug is now fixed in the latest upload, and updating the
system fixes the mess for me, and for Chris, and (I hope) others as
well.

Revision history for this message
J A (sysjaf) wrote :

#20 worked for me, Thanks!!!

Revision history for this message
whoop (whoopwhoop) wrote :

So do you still have to manually repair this, or does the update correct the affected as well?

Revision history for this message
Craig Chambers (craigchambers2101) wrote :

#20 Worked for me, Thanks Danne

Revision history for this message
John Vivirito (gnomefreak) wrote :

Chris:
This is not fixed as of right now. 9/27/2010 12:28 EST

gnomefreak@Development:~$ sudo dpkg --configure -a
Setting up python-virtkey (0.60.0-0ubuntu1) ...
file does not exist: /usr/lib/python2.6/dist-packages/python_virtkey-0.60.0.egg-info
pycentral: pycentral pkginstall: error byte-compiling files (1)
pycentral pkginstall: error byte-compiling files (1)
dpkg: error processing python-virtkey (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of onboard:
 onboard depends on python-virtkey (>= 0.60.0); however:
  Package python-virtkey is not configured yet.
dpkg: error processing onboard (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 python-virtkey
 onboard

Revision history for this message
John Vivirito (gnomefreak) wrote :

it hasnt been built yet. work around worked for me

Revision history for this message
Fabio Duran Verdugo (fabioduran) wrote :

With this fixed for me too.
Fixed to me with: sudo rm /usr/share/pyshared/python_virtkey-0.60.0.egg-info ; sudo cp /usr/share/pyshared/python_debian-0.1.16ubuntu1.egg-info/PKG-INFO /usr/share/pyshared/python_virtkey-0.60.0.egg-info ; sudo apt-get -f install

Revision history for this message
david reeves (mokoda) wrote :
Download full text (5.5 KiB)

installArchives() failed: Preconfiguring packages ...
Preconfiguring packages ...
(Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 192056 files and directories currently installed.)
Preparing to replace apparmor 2.5.1~rc1-0ubuntu1 (using
.../apparmor_2.5.1~rc1-0ubuntu2_i386.deb) ...
Unpacking replacement apparmor ...
Preparing to replace libapparmor1 2.5.1~rc1-0ubuntu1 (using
.../libapparmor1_2.5.1~rc1-0ubuntu2_i386.deb) ...
Unpacking replacement libapparmor1 ...
Preparing to replace libapparmor-perl 2.5.1~rc1-0ubuntu1 (using
.../libapparmor-perl_2.5.1~rc1-0ubuntu2_i386.deb) ...
Unpacking replacement libapparmor-perl ...
Preparing to replace apparmor-utils 2.5.1~rc1-0ubuntu1 (using
.../apparmor-utils_2.5.1~rc1-0ubuntu2_i386.deb) ...
Unpacking replacement apparmor-utils ...
Processing triggers for ureadahead ...
Processing triggers for man-db ...
Setting up python-virtkey (0.60.0-0ubuntu1) ...
file does not exist:
/usr/lib/python2.6/dist-packages/python_virtkey-0.60.0.egg-info
pycentral: pycentral pkginstall: error byte-compiling files (1)
pycentral pkginstall: error byte-compiling files (1)
dpkg: error processing python-virtkey (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of onboard:
 onboard depends on python-virtkey (>= 0.60.0); however:
  Package python-virtkey is not configured yet.
dpkg: error processing onboard (--configure):
 dependency problems - leaving unconfigured
Setting up apparmor (2.5.1~rc1-0ubuntu2) ...
No apport report written because MaxReports is reached already
No apport report written because MaxReports is reached already
Installing new version of config file
/etc/apparmor.d/abstractions/ubuntu-email ...
 * Starting AppArmor profiles Skipping profile in
/etc/apparmor.d/disable: usr.bin.firefox
Skipping profile in /etc/apparmor.d/disable: usr.bin.firefox-4.0

[ OK ]
 * Reloading AppArmor profiles Skipping profile in
/etc/apparmor.d/disable: usr.bin.firefox
Skipping profile in /etc/apparmor.d/disable: usr.bin.firefox-4.0

[ OK ]
Setting up libapparmor1 (2.5.1~rc1-0ubuntu2) ...
Setting up libapparmor-perl (2.5.1~rc1-0ubuntu2) ...
Setting up apparmor-utils (2.5.1~rc1-0ubuntu2) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Errors were encountered while processing:
 python-virtkey
 onboard
Setting up python-virtkey (0.60.0-0ubuntu1) ...
file does not exist:
/usr/lib/python2.6/dist-packages/python_virtkey-0.60.0.egg-info
pycentral: pycentral pkginstall: error byte-compiling files (1)
pycentral pkginstall: error byte-compiling files (1)
dpkg: error processing python-virtkey (--c...

Read more...

Changed in virtkey (Ubuntu Maverick):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
Revision history for this message
david reeves (mokoda) wrote :

I will ride it out until it is complete.. the workaround did not work for
me..thanks

Still Crazy After All These Years !
Dave Reeves

On Mon, Sep 27, 2010 at 11:51 AM, John Vivirito <email address hidden>wrote:

> it hasnt been built yet. work around worked for me
>
> --
> package python-virtkey (not installed) failed to install/upgrade: file does
> not exist: /usr/lib/python2.6/dist-packages/python_virtkey-0.60.0.egg-info
> https://bugs.launchpad.net/bugs/648695
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (648779).
>
> Status in “virtkey” package in Ubuntu: Fix Released
> Status in “virtkey” source package in Maverick: Fix Released
>
> Bug description:
> Entpacke python-virtkey (aus .../python-virtkey_0.60.0-0ubuntu1_i386.deb)
> ...
> Richte python-virtkey ein (0.60.0-0ubuntu1) ...
> file does not exist:
> /usr/lib/python2.6/dist-packages/python_virtkey-0.60.0.egg-info
> pycentral: pycentral pkginstall: error byte-compiling files (1)
> pycentral pkginstall: error byte-compiling files (1)
> dpkg: Fehler beim Bearbeiten von python-virtkey (--configure):
> Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1
> zurück
> Fehler traten auf beim Bearbeiten von:
> python-virtkey
>
> ProblemType: Package
> DistroRelease: Ubuntu 10.10
> Package: python-virtkey (not installed)
> ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
> Uname: Linux 2.6.35-22-generic i686
> Architecture: i386
> Date: Mon Sep 27 12:55:10 2010
> ErrorMessage: Unterprozess installiertes post-installation-Skript gab den
> Fehlerwert 1 zurück
> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release Candidate i386
> (20091020.3)
> SourcePackage: virtkey
> Title: package python-virtkey (not installed) failed to install/upgrade:
> Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1
> zurück
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/virtkey/+bug/648695/+subscribe
>

Revision history for this message
david reeves (mokoda) wrote :

this seemed to work:
dave@dave-laptop:~]$ sudo rm
/usr/share/pyshared/python_virtkey-0.60.0.egg-info ; sudo cp
/usr/share/pyshared/python_debian-0.1.16ubuntu1.egg-info/PKG-INFO
/usr/share/pyshared/python_virtkey-0.60.0.egg-info ; sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer
required:
  libx264-85 libmodplug0c2
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up python-virtkey (0.60.0-0ubuntu1) ...
Processing triggers for python-central ...
Setting up onboard (0.94.0-0ubuntu1) ...
Processing triggers for python-central ...

Still Crazy After All These Years !
Dave Reeves

On Mon, Sep 27, 2010 at 12:05 PM, Fabio Duran Verdugo <email address hidden>wrote:

> With this fixed for me too.
> Fixed to me with: sudo rm
> /usr/share/pyshared/python_virtkey-0.60.0.egg-info ; sudo cp
> /usr/share/pyshared/python_debian-0.1.16ubuntu1.egg-info/PKG-INFO
> /usr/share/pyshared/python_virtkey-0.60.0.egg-info ; sudo apt-get -f install
>
> --
> package python-virtkey (not installed) failed to install/upgrade: file does
> not exist: /usr/lib/python2.6/dist-packages/python_virtkey-0.60.0.egg-info
> https://bugs.launchpad.net/bugs/648695
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (648779).
>
> Status in “virtkey” package in Ubuntu: Fix Released
> Status in “virtkey” source package in Maverick: Fix Released
>
> Bug description:
> Entpacke python-virtkey (aus .../python-virtkey_0.60.0-0ubuntu1_i386.deb)
> ...
> Richte python-virtkey ein (0.60.0-0ubuntu1) ...
> file does not exist:
> /usr/lib/python2.6/dist-packages/python_virtkey-0.60.0.egg-info
> pycentral: pycentral pkginstall: error byte-compiling files (1)
> pycentral pkginstall: error byte-compiling files (1)
> dpkg: Fehler beim Bearbeiten von python-virtkey (--configure):
> Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1
> zurück
> Fehler traten auf beim Bearbeiten von:
> python-virtkey
>
> ProblemType: Package
> DistroRelease: Ubuntu 10.10
> Package: python-virtkey (not installed)
> ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
> Uname: Linux 2.6.35-22-generic i686
> Architecture: i386
> Date: Mon Sep 27 12:55:10 2010
> ErrorMessage: Unterprozess installiertes post-installation-Skript gab den
> Fehlerwert 1 zurück
> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release Candidate i386
> (20091020.3)
> SourcePackage: virtkey
> Title: package python-virtkey (not installed) failed to install/upgrade:
> Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1
> zurück
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/virtkey/+bug/648695/+subscribe
>

Revision history for this message
Philip Muškovac (yofel) wrote :

This was a bug in the packaging, not an upstream bug.

Changed in python-virtkey:
status: New → Invalid
Revision history for this message
Sebastian Geiger (lanoxx) wrote :

Just tried to upgrade, this does not seem to be fixed. Can anyone give more information?

Revision history for this message
Sebastian Geiger (lanoxx) wrote :

I will reset to "In progress" since I updated after this was supposedly fixed and its not. I dont think that using the workarround in comment #31 is considered a fix either, is it?

Changed in virtkey (Ubuntu Maverick):
status: Fix Released → In Progress
Revision history for this message
Philip Muškovac (yofel) wrote :

This bug has been fixed. The fixed package just isn't completely built and distributed on all mirrors yet. We don't track that on a bug report.

Changed in virtkey (Ubuntu Maverick):
status: In Progress → Fix Released
Revision history for this message
David Smith (xperdition) wrote :

If I am not associated with any bugs,why am I getting 40 e-mails per hour about a bug I merely reported this morning?  This happens every time I decide to report a bug.  I get put on these unending e-mail sprays and it takes an act of Congress to get off.  Launchpad needs better subscription controls.  Where can I submit THAT as a bug?

David S. Smith
(662)346-6396 (mobile)

Romans 6:23 (ESV)
"For the wages of sin is death, but the free gift of God is eternal life in Christ Jesus our Lord."

If I must be constantly convinced for God to merely be
Then my god is already chosen
And my chosen god is me
-DSS

--- On Mon, 9/27/10, LanoxxthShaddow <email address hidden> wrote:

From: LanoxxthShaddow <email address hidden>
Subject: [Bug 648695] Re: package python-virtkey (not installed) failed to install/upgrade: file does not exist: /usr/lib/python2.6/dist-packages/python_virtkey-0.60.0.egg-info
To: <email address hidden>
Date: Monday, September 27, 2010, 1:31 PM

I will reset to "In progress" since I updated after this was supposedly
fixed and its not. I dont think that using the workarround in comment
#31 is considered a fix either, is it?

** Changed in: virtkey (Ubuntu Maverick)
       Status: Fix Released => In Progress

--
package python-virtkey (not installed) failed to install/upgrade: file does not exist: /usr/lib/python2.6/dist-packages/python_virtkey-0.60.0.egg-info
https://bugs.launchpad.net/bugs/648695
You received this bug notification because you are a direct subscriber
of a duplicate bug (648718).

Revision history for this message
psierra (pscbarros) wrote :

I agree with David, this is becoming like spam

> Date: Mon, 27 Sep 2010 18:51:43 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: Re: [Bug 648695] Re: package python-virtkey (not installed) failed to install/upgrade: file does not exist: /usr/lib/python2.6/dist-packages/python_virtkey-0.60.0.egg-info
>
> If I am not associated with any bugs,why am I getting 40 e-mails per
> hour about a bug I merely reported this morning? This happens every
> time I decide to report a bug. I get put on these unending e-mail
> sprays and it takes an act of Congress to get off. Launchpad needs
> better subscription controls. Where can I submit THAT as a bug?
>
>
> David S. Smith
> (662)346-6396 (mobile)
>
> Romans 6:23 (ESV)
> "For the wages of sin is death, but the free gift of God is eternal life in Christ Jesus our Lord."
>
> If I must be constantly convinced for God to merely be
> Then my god is already chosen
> And my chosen god is me
> -DSS
>
> --- On Mon, 9/27/10, LanoxxthShaddow <email address hidden> wrote:
>
>
> From: LanoxxthShaddow <email address hidden>
> Subject: [Bug 648695] Re: package python-virtkey (not installed) failed to install/upgrade: file does not exist: /usr/lib/python2.6/dist-packages/python_virtkey-0.60.0.egg-info
> To: <email address hidden>
> Date: Monday, September 27, 2010, 1:31 PM
>
>
> I will reset to "In progress" since I updated after this was supposedly
> fixed and its not. I dont think that using the workarround in comment
> #31 is considered a fix either, is it?
>
> ** Changed in: virtkey (Ubuntu Maverick)
> Status: Fix Released => In Progress
>
> --
> package python-virtkey (not installed) failed to install/upgrade: file does not exist: /usr/lib/python2.6/dist-packages/python_virtkey-0.60.0.egg-info
> https://bugs.launchpad.net/bugs/648695
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (648718).
>
> --
> package python-virtkey (not installed) failed to install/upgrade: file does not exist: /usr/lib/python2.6/dist-packages/python_virtkey-0.60.0.egg-info
> https://bugs.launchpad.net/bugs/648695
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (648741).

Revision history for this message
Linus Hoppe (linus-hoppe-deactivatedaccount) wrote :

can still confirm

Revision history for this message
Mathieu Marquer (slasher-fun) wrote :

OK so dear all,

* When you report a bug, you're automatically added to the mailing list
about this bug
* If you want to unsubscribe, complaining on the mailing list won't do
anything. BUT clicking on the "unsubscribe" button will.

Revision history for this message
Josh Dalziel (josh-dalziel) wrote :

#20 worked for me. Thanks!

Revision history for this message
Douglas Moore (iamshadow2008) wrote :

Thanks guys, #5 worked perfectly.

Revision history for this message
vagrale (vagrale) wrote :

For me fixed with the last updates!

Revision history for this message
Rafał Cieślak (rafalcieslak256) wrote :

#39 worked, thanks.

Revision history for this message
Fermin Cor (ferminx360) wrote :

Thank to all developers for fix it...I'm Spanish and I'm 16...When I'm more old...I want to be like you.
Thanks and regars!

Revision history for this message
Vincent Gerris (vgerris) wrote :

I had the same problem.
I fixed it by combining post #5 and #8, because i got the error:
cp: not writing through dangling symlink `/usr/share/pyshared/python_virtkey-0.60.0.egg-info'

so:
root@mypad-laptop:/dev/input# sudo rm /usr/share/pyshared/python_virtkey-0.60.0.egg-info
root@mypad-laptop:/dev/input# sudo cp /usr/share/pyshared/python_debian-0.1.16ubuntu1.egg-info/PKG-INFO /usr/share/pyshared/python_virtkey-0.60.0.egg-info
root@mypad-laptop:/dev/input#
root@mypad-laptop:/dev/input# sudo apt-get -f install

that did the trick.
Thanks you!

Revision history for this message
Arenlor (arenlor) wrote :

I just updated, it is fixed now. Give it time to get to your local server.

Revision history for this message
Aritra Dalal (aritra-dalal-gmail) wrote :

confirming that the fix update has been released on the GB servers.

Revision history for this message
Oupamster (oupamster) wrote :

combined #5 & #8 and the problem is fixed. thanks. (10.10 netbook)

Revision history for this message
Daniele Cruciani (daniele-smartango) wrote :

yes, fixed with last update

Revision history for this message
k.l (k-lukaschenko) wrote :

i can confirm that this issue is fixed with the latest update.
thanks!

Revision history for this message
Nils Sundström (yacc08) wrote :

Thanks, noted this myself just now!

> Date: Tue, 28 Sep 2010 09:09:42 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 648695] Re: package python-virtkey (not installed) failed to install/upgrade: file does not exist: /usr/lib/python2.6/dist-packages/python_virtkey-0.60.0.egg-info
>
> i can confirm that this issue is fixed with the latest update.
> thanks!
>
> --
> package python-virtkey (not installed) failed to install/upgrade: file does not exist: /usr/lib/python2.6/dist-packages/python_virtkey-0.60.0.egg-info
> https://bugs.launchpad.net/bugs/648695
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (649308).
>
> Status in python-virtkey extension: Invalid
> Status in “virtkey” package in Ubuntu: Fix Released
> Status in “virtkey” source package in Maverick: Fix Released
>
> Bug description:
> Entpacke python-virtkey (aus .../python-virtkey_0.60.0-0ubuntu1_i386.deb) ...
> Richte python-virtkey ein (0.60.0-0ubuntu1) ...
> file does not exist: /usr/lib/python2.6/dist-packages/python_virtkey-0.60.0.egg-info
> pycentral: pycentral pkginstall: error byte-compiling files (1)
> pycentral pkginstall: error byte-compiling files (1)
> dpkg: Fehler beim Bearbeiten von python-virtkey (--configure):
> Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
> Fehler traten auf beim Bearbeiten von:
> python-virtkey
>
> ProblemType: Package
> DistroRelease: Ubuntu 10.10
> Package: python-virtkey (not installed)
> ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
> Uname: Linux 2.6.35-22-generic i686
> Architecture: i386
> Date: Mon Sep 27 12:55:10 2010
> ErrorMessage: Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release Candidate i386 (20091020.3)
> SourcePackage: virtkey
> Title: package python-virtkey (not installed) failed to install/upgrade: Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/python-virtkey/+bug/648695/+subscribe

Revision history for this message
Bilal Akhtar (bilalakhtar) wrote :

> Thank to all developers for fix it...I'm Spanish and I'm 16...When I'm more old...I want to be like you.
> Thanks and regars!

I fixed this bug, and I am 14! So, you can help even when you are young, you just need to know the required language, and then nothing prevents you from contributing.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Patches