Virt-manager crashes while installing Windows XP guest

Bug #628908 reported by Nathan Crawford on 2010-09-02
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
virt-manager (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: virt-manager

Ubuntu release: 10.10
virt-manager version: 0.8.4-3ubuntu6

I have attempted installation of XP Home 5 times and it has crashed at a different point every time. It seems to occur as I'm moving the mouse pointer in to or out of the window. The crash has only happened during the first part of the install, when the screen is in "dos mode".
Also, the virtual machine seems to be fine; it stays running in the background. It's only virt-manager that crashes.

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: virt-manager 0.8.4-3ubuntu6
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic x86_64
Architecture: amd64
CrashCounter: 1
Date: Thu Sep 2 11:08:28 2010
ExecutablePath: /usr/share/virt-manager/virt-manager.py
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcCmdline: python /usr/share/virt-manager/virt-manager.py
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x4233a2 <PyObject_GetItem+34>: mov 0x70(%rdx),%rax
 PC (0x004233a2) ok
 source "0x70(%rdx)" (0xd002000000000173) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: virt-manager
StacktraceTop:
 PyObject_GetItem ()
 PyEval_EvalFrameEx ()
 PyEval_EvalFrameEx ()
 PyEval_EvalFrameEx ()
 PyEval_EvalFrameEx ()
Title: virt-manager.py crashed with SIGSEGV in PyObject_GetItem()
UserGroups: adm admin cdrom dialout libvirtd lpadmin plugdev sambashare

Nathan Crawford (njcrawford) wrote :

StacktraceTop:
 PyObject_GetItem (o=0x2e17d00, key=0x2687810)
 PyEval_EvalFrameEx (f=0x2cc0d50,
 PyEval_EvalFrameEx (f=0x2cc0b90,
 PyEval_EvalFrameEx (f=0x28e20a0,
 PyEval_EvalFrameEx (f=0x2222140,

Changed in virt-manager (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Nathan Crawford (njcrawford) wrote :

More information:
I have also experienced this cash while running the XP guest after installation. Most frequently it happens when moving the mouse into or out of the console window, but I've also had it happen when clicking various menu items and once when it was just sitting there, with no input at all.

visibility: private → public
Changed in virt-manager (Ubuntu):
status: New → Confirmed
Serge Hallyn (serge-hallyn) wrote :

(Downloading XP in order to reproduce, but marked confirmed as per second
commenter above)

Nathan Crawford (njcrawford) wrote :

I'm changing the status back to new, since I'm the OP and the commenter, and I don't think I'm allowed to confirm my own bug.
More information:
I've now experienced this bug with Windows 7 32 bit and Windows 98. The Windows 98 VM was using QEMU - it won't boot with KVM. At this point, I'm going to guess that the version of Windows doesn't matter.
On all Windows versions, I've seen it more frequently when the VM is configured to use the 'vga' video type than I have with the 'cirrus' type.

Changed in virt-manager (Ubuntu):
status: Confirmed → New
Marc Deslauriers (mdeslaur) wrote :

Nathan,

Have you seen this issue with gtk-vnc 0.4.1-3ubuntu1?
(binary packages are called libgtk-vnc-1.0-0 and python-gtk-vnc)

Changed in virt-manager (Ubuntu):
status: New → Incomplete
Nathan Crawford (njcrawford) wrote :

Marc,
I installed all the latest updates today, among them a new version of python, and I haven't been able to reproduce since then.

Changed in virt-manager (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers