virt-manager.py crashed with SIGSEGV in malloc()

Bug #631527 reported by Krzysztof Matusik on 2010-09-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
virt-manager (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: virt-manager

It seems that this happens when starting/restarting virtual machine and clicking around in graphical console (virtmanger HMI)

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: virt-manager 0.8.4-7ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic x86_64
Architecture: amd64
CrashCounter: 1
Date: Mon Sep 6 14:36:17 2010
EcryptfsInUse: Yes
ExecutablePath: /usr/share/virt-manager/virt-manager.py
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha amd64 (20100803.1)
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcCmdline: python /usr/share/virt-manager/virt-manager.py
ProcEnviron:
 LANG=pl_PL.utf8
 SHELL=/bin/zsh
SegvAnalysis:
 Segfault happened at: 0x7f5bd813d5a5: cmp 0x18(%r15),%r14
 PC (0x7f5bd813d5a5) ok
 source "0x18(%r15)" (0x70000000c00001a) not located in a known VMA region (needed readable region)!
 destination "%r14" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: virt-manager
StacktraceTop:
 ?? () from /lib/libc.so.6
 malloc () from /lib/libc.so.6
 xmlBufferCreateSize () from /usr/lib/libxml2.so.2
 xmlAllocParserInputBuffer ()
 xmlCreatePushParserCtxt ()
Title: virt-manager.py crashed with SIGSEGV in malloc()
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse libvirtd lpadmin netdev plugdev sambashare tape video

visibility: private → public

StacktraceTop:
 _int_malloc (av=0x7f5bd8440e40, bytes=8194) at malloc.c:4636
 *__GI___libc_malloc (bytes=8194) at malloc.c:3660
 xmlBufferCreateSize__internal_alias (
 xmlAllocParserInputBuffer__internal_alias (
 xmlCreatePushParserCtxt__internal_alias (

Changed in virt-manager (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Marc Deslauriers (mdeslaur) wrote :

Thanks for reporting this issue.

Can you reproduce this issue with gtk-vnc 0.4.1-3ubuntu1?
(the binary packages are called libgtk-vnc-1.0-0 and python-gtk-vnc)

Changed in virt-manager (Ubuntu):
status: New → Incomplete
Marc Deslauriers (mdeslaur) wrote :

I'm closing this bug due to lack of activity. I'm pretty sure the updated gtk-vnc fixed this.

Please feel free to open a new bug if this issue comes back.

Changed in virt-manager (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers