virt-manager should be clearer about adding hardware to running virtual machine

Bug #245107 reported by to be removed on 2008-07-03
0
Affects Status Importance Assigned to Milestone
virt-manager
Fix Released
Low
virt-manager (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: virt-manager

When I change the hardware configuration for a running virtual machine, using virt-manager, it does not work. That's OK, changing hardware while a machine is running is usually not something works on real hardware either. The problem here is one of usability: either virt-manager should not let me add the hardware, or it should tell me that the hardware change will occur when the virtual machine is booted up the next time. Right now, it gives me an error message saying that it couldn't add the hardware, yet it is there when the virtual machine boots.

(Specifically, I did this for a network card.)

Changed in virt-manager:
importance: Undecided → Wishlist
status: New → Confirmed

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue for you. Can you try with the latest Ubuntu release? Thanks in advance.

Changed in virt-manager:
status: Confirmed → Incomplete
to be removed (liw) wrote :

The problem still exists in the current Ubuntu release (intrepid).

Changed in virt-manager:
status: Incomplete → Confirmed

Originally reported on https://bugs.launchpad.net/ubuntu/+source/virt-manager/+bug/245107

When I change the hardware configuration for a running virtual machine, using virt-manager, it does not work. That's OK, changing hardware while a machine is running is usually not something works on real hardware either. The problem here is one of usability: either virt-manager should not let me add the hardware, or it should tell me that the hardware change will occur when the virtual machine is booted up the next time. Right now, it gives me an error message saying that it couldn't add the hardware, yet it is there when the virtual machine boots.

Thank you, Lars. I reported your bug to the developers of the software. You can track it and make comments here: https://bugzilla.redhat.com/show_bug.cgi?id=477761

Changed in virt-manager:
importance: Undecided → Unknown
status: New → Unknown
Changed in virt-manager:
status: Unknown → Confirmed

This is fixed in virt-manager 0.6.0: if we can't hotplug the hardware, we pop up a dialog warning the user that attach will only take effect after next VM reboot. Closing as CURRENTRELEASE.

Thank you, Cole, for your quick answer and telling us that this is fixed.

I am closing it because the bug has been fixed in the latest development version of Ubuntu - the Jaunty Jackalope.

If you need a fix for the bug in previous versions of Ubuntu, please follow the instructions for "How to request new packages" at https://help.ubuntu.com/community/UbuntuBackports#request-new-packages

Changed in virt-manager:
status: Confirmed → Fix Released
Changed in virt-manager:
status: Confirmed → Fix Released
Changed in virt-manager:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.