vino-preferences fails to start vino-server

Bug #8428 reported by Jason Toffaletti on 2004-09-23
6
Affects Status Importance Assigned to Milestone
vino (Ubuntu)
Medium
Sebastien Bacher

Bug Description

When I turn on remote desktop with vino-preferences, vino-server does not start.
However, I can run vino-server from the command line and it works fine.

Sebastien Bacher (seb128) wrote :

What's the result of "ps ax | grep vino" in a gnome-terminal ? It works fine here

Jason Toffaletti (jason) wrote :

Created an attachment (id=223)
vino cpu hog

I restarted my machine after an upgrade and now vino-server is running
correctly. It definitely wasn't before. I checked not only ps aux | grep vino,
but also netstat --tcp --listening -p and I tried connecting from several
different machines. And like I originally said, running vino-server from the
command line would work fine.

Now the problem appears to be disabling Remote Desktop. When I turn sharing off
vino-server is still running and when I connect to it with tsclient,
vino-server starts taking up 100% cpu. When I killall -9 vino-server, it comes
right back with a new pid and does the same thing even though sharing is off.

I'm attaching a log of my terminal session that will hopefully shed some light
on this new problem.

Vincent Untz (vuntz) wrote :

Sebastien: should we reopen this bug?

Sebastien Bacher (seb128) wrote :

(In reply to comment #3)
> Sebastien: should we reopen this bug?

We have details, so yes .. but still no problem here, need to dig on this later.

Sebastien Bacher (seb128) wrote :

do you still have this bug ?

Jason Toffaletti (jason) wrote :

On warty vino-server is started correctly by vino-preferences. When I disable
sharing, via vino-preferences, vino-server is still running, but connecting to
it does not work and causes it to exit. I tried going through these steps twice
and the second time I noticed vino-server started using 90% of the cpu for about
10 seconds, but it eventually exited properly. I'd say you can close this bug,
unless you want me to try this on Hoary also.

Sebastien Bacher (seb128) wrote :

no, that's fine. Bug closed, thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.