Disable wallpaper on connection + restart = wallpaper gone forever

Bug #289034 reported by Christoph Korn on 2008-10-25
22
Affects Status Importance Assigned to Milestone
vino
Fix Released
Critical
vino (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: vino

OS: Ubuntu intrepid RC amd64
vino version: 2.24.1-0ubuntu1

I activated the option to disable the wallpaper on connection.
Then I connected to the machine (via viagre) and shut down
it. When I reboot the wallpaper is still gone also no client is connected.

Related branches

Jorge Pereira (jpereiran) wrote :

Hi Christoph!

1) and shutdown the vinagre ou your vnc cliente machine?
2) When you reboot the vnc machine server, your wallpaper gone!?

Jorge Pereira (jpereiran) wrote :

Following the patch for fix this problem!

Christoph Korn (c-korn) wrote :

I have shutdown the intrepid machine (running the server) by connecting to
it using vinagre on the hardy machine (client).

Thanks for your patch.
To test it I have to apply it on these sources.
http://archive.ubuntu.com/ubuntu/pool/main/v/vino/vino_2.24.1.orig.tar.gz
Am I right?

(It's the version in intrepid: http://packages.ubuntu.com/intrepid/vino )

Jorge Pereira (jpereiran) wrote :

i make the patch from the TRUNK of gnome svn

svn co http://svn.gnome.org/svn/vino/trunk

;)

Christoph Korn (c-korn) wrote :

I have tested the patch and it fixes the bug.

Thanks.

Jorge Pereira (jpereiran) wrote :

Thank so much buddy for test the patch, maybe the next release fixed the problem!

[]s

DataGreed (cpr-al-exe) wrote :

I've checked out the trunk, but cannot manage to apply the patch. Bspatch says, that the patch file is corrupt and the default patch application says, that it cannot find required lines in files and doesn't know what to patch :(

Any ideas?

Jonh Wendell (wendell) on 2008-12-14
Changed in vino:
importance: Undecided → Low
status: New → Fix Committed
Changed in vino:
status: Unknown → Fix Released
jeroenl (jeroenl) wrote :

I had the same problem. Great that there will be a solution in future releases, but how to get the wallpaper back?

When the Gnome is started, the wallpaper is loaded, but during all applications are loaded the wallpaper is replaced by the background color. I understand it has something to do with Nautilus, but I can't find the right solution.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vino - 2.25.91-0ubuntu1

---------------
vino (2.25.91-0ubuntu1) jaunty; urgency=low

  * New upstream release (LP: #330215)
    - Install autostart file in $sysconfdir/xgd/autostart. Usually you
      should pass the argument --sysconfdir=/etc to configure (or
      autogen.sh) script.
    - i18n related fixes.
    - Minor fixes. (LP: #196675, #228370, #237883, #289034)
    - Translations (ast, bg, ca, da, es, et, eu, hu, nl, or, pl, pt_BR,
      pt, ro, sv, th, vi, zh_HK, zh_TW)
  * Add Vcs-Bzr in debian/control.in
  * Re-generate debian/control

 -- Didier Roche <email address hidden> Mon, 16 Feb 2009 20:35:56 +0100

Changed in vino:
status: Fix Committed → Fix Released
Pinguin (riebel) wrote :

> I had the same problem. Great that there will be a solution in future releases, but how to get the wallpaper back?
Is there any solution to get the wallpaper back?

Pinguin (riebel) wrote :

> Is there any solution to get the wallpaper back?
Activate the option to disable the wallpaper on connection. Then connect via viagre to the PC and close the connection after a few seconds. After these steps my wallpaper was back :)

@Sebastian Riebel
I am having the same problem and tried your suggestion, but I still do not have a background.

Does anyone else have any suggestions about how to get m wallpaper back? :(

Jorge Pereira (jpereiran) wrote :

@Darwin Survivor

What your version? what you did for this happening?

I am running Ubuntu Intrepid (8.10) 64 bit.

I don't remember doing a whole lot prior to it happening (it was a while ago). I "may" have attempted installing Firefox 3.5, but I can't exactly remember. Sorry.

Gah, remembered just after I hit "submit"....

I was messing around with remote desktop before it happened.
I tried changing "Disable the wallpaper when connected" which worked fine. But once I rebooted, I could no longer get a wallpaper at all except for about 1.5 seconds during the login phase.

I'm pretty sure I messed with Firefox a week or two afterwards, so you can ignore that part of my previous post.

Aha, I figured out what I did wrong. I mis-read your comment and was connecting from the affected computer to ANOTHER computer :p

Connected to localhost and the problem is fixed now.

Changed in vino:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.