Ubuntu

Support low color depth to improve speed

Reported by pt123 on 2008-03-19
142
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Empathy
Invalid
Undecided
Unassigned
Vinagre: VNC client for GNOME
Fix Released
Medium
gtk-vnc
Invalid
Undecided
Unassigned
vino
New
Wishlist
empathy (Ubuntu)
Undecided
Unassigned
Declined for Hardy by Sebastien Bacher
Declined for Karmic by Sebastien Bacher
vinagre (Baltix)
Undecided
Unassigned
vinagre (Ubuntu)
Medium
Unassigned
Declined for Hardy by Sebastien Bacher
Declined for Karmic by Sebastien Bacher

Bug Description

UPDATE: For Empathy's support of low color depth see Bug #514666

Binary package hint: vinagre

I installed Hardy Alpha 4, and updated the packages so I am up to date with Alpha 6. When I tried to remotely connect to a computer on my LAN and it was so slow (and unusable)on Vinagre / Remote Desktop client.

I noticed TS Client had disabled the option for VNC, installing xvnc4viewer enabled it. Xvnc4viewer was much faster and usable.
Are there other settings in Hardy that can be tweaked to fix the awful slowness in Vinagre ?

In Vinagre I couldn't find anyway to change settings for the connection. Is there some way of doing this?

Same here. In LAN (100 MBit/s) xvnc4viewer is MUCH faster.

mxyzptlk (mxyzptlk) wrote :

I use vnc viewers for work every day, and was really looking forward to vinagre.

However, xvnc4viewer and xtightvincviewer are much more useful at this point. They are each much faster, and xtightvncviewer allows me to copy something from my desktop and paste it into something in the vnc session (clumsily, and it doesn't always work).

Vinagre was supposed to be provide that kind of copy/paste functionality and more, but it's not there yet. The copy/paste works, but something as simple as clicking on the format brush in a spreadsheet inside a vnc session, and trying to format another cell, just doesn't work. That's pretty basic functionality that isn't there, but is present in much older systems.

Add to that how slow vinagre is, and I'm afraid it's just not ready. If there were at least a way to manage the visual depth in order to make it run a little snappier, it'd be better off.

Jonh Wendell (wendell) on 2008-05-06
Changed in vinagre:
status: New → Triaged
Changed in vinagre:
status: Unknown → Confirmed
Changed in vinagre:
importance: Undecided → Low

I renamed this bug so it will turn up in search results for "encoding" or "color depth" instead of "too slow". The titles of the duplicate (#231996) and GNOME #485204 were more helpful, but aren't searchable.

If a maintainer could mark this as "enhancement" like #204802, that would also be helpful.

Changed in vinagre:
importance: Low → Wishlist
pt123 (pt123) wrote :

It is more of a bug and than an enhancement as Vinagre is practically unusable because of the slowness.

logari81 (logari81) wrote :

I agree that vinagre is too slow to work with and I've found no way to change settings in order to improve its speed.

Nikolaus Rath (nikratio) wrote :

I'm afraid I have to join the chorus. Vinagre is basically unusable with its high bandwith requirements. Would it be possible to change the default VNC client in dapper to a different application, like xvncviewer? I imagine that an ordinary user becomes very disappointed when his first contact with VNC is made with vinagre. Most likely he will not even consider that the speed problem could be due to the used client rather than VNC itself.

Øyvind Stegard (oyvinst) wrote :

Joining in, too. Vinagre is so slow, something must be wrong with the implementation and/or design choices internally. I'm currently running Vinagre connected to a *local* VNC-session (TightVNC-server) on a brand new quad-core 2.5GHz system with 4GB RAM, and guess what.. IT'S SLOW. Sad, really, because I like how I can manage multiple sessions in Vinagre, and the better desktop integration it provides.

Benjamim (bbbenjy-gmail) wrote :

Vinagra *-* TOO SLOW *-* via internet. A way to change definitions is needed.

Changed in vinagre:
importance: Wishlist → Medium

Vinagre is still very slow in LAN (1Gbit). I would use xvnc4viewer or any other client, but they can't do fullscreen on a dual-head-configuration (put remote-image in the middle of two my two screens) so I am dependent on vinagre.
Arguments or a dialog for changing the vnc-settings would make vinagre more usable.

pt123 (pt123) wrote :

What is the deal with all these new remote desktop applications even though they are newer they are so slow compared xvnc4viewer which was developed so long ago. I thought with open source, applications improve over time as the previous code is available.

Vinagre and gtkvncviewer suffer from this.
https://launchpad.net/gtkvncviewer

The only hope left for us is this application called
Grdc - GTK+/Gnome Remote Desktop Client
http://grdc.sourceforge.net/

Which seems to support color depth
http://sourceforge.net/project/screenshots.php?group_id=248852&ssid=97818

But unfortunate there are no Ubuntu packages to test

Phoenix (phoenix-dominion) wrote :

Joining in....

I have the remote end protected with password - but xvnc4viewer can't handle that.... so I have to stick to the slow vinagre...

regards
Philipp

Philip Wyett (philwyett) wrote :

Philipp,

xvnc4viewer does handle a remote with password. Have you checked the remote is not set to require connections be authorised locally and that is blocking it.

Best thing to do here as it is not related to this bug is ask a question on answers.launchpad.net

Yeah, vinagre is unacceptably slow. It should provide color reduction. The pair vino-server and vinagre should provide lossy compression.

Shahar Or (mightyiam) wrote :

Dear friends,

This feature will be valuable for many users, I think. Non-technical users may not understand why the remote desktop is working so slowly as to be unusable over the internet and might think it to be a bug. "You mean to tell me the remote desktop that's installed by default in Ubuntu is not working overt the internet and I should install a different one?" they might say.

I've commented upstream.

summary: - [Wishlist] Vinagre is very bandwith demaning and should support using
- lower color depth
+ Support low color depth to improve speed
Kalisto (marcford) wrote :

It has been a year since this issue was first brought up and nothing had changed. I accept that these things take time but it should not be included in Ubuntu releases until it works.

Some may argue that it does work but it is just bandwidth intensive. It is however unusable as numerous people have stated above.

Please fix or remove from further releases.

pt123 (pt123) wrote :

Yes please remove Vinagre, a better gui (one which remembers the password) for the VNC client in the Terminal Server Client would be better.

tinahouse (tinahouse) wrote :

I gave up vinagre and came across Grdc. I think it should replace vinagre. It's now in Ubuntu universal repository already, and the web site is offering .deb download for the latest version. It supports color depth and compress quality which vinagre doesn't have.

Shahar Or (mightyiam) wrote :

Dear tinahouse,

Can Grdc connect to Vino? Please see bug #369181.

Many blessings.

xvnc4viewer works with Vino and is already in main. And, of course, it's
much less bandwidth-demanding.

   -Nikolaus

--
 »Time flies like an arrow, fruit flies like a Banana.«

  PGP fingerprint: 5B93 61F8 4EA2 E279 ABF6 02CF A9AD B7F8 AE4E 425C

Rocko (rockorequin) wrote :

I agree: xvnc4viewer is my viewer of preference - it even auto-detects link speeds and adjusts colour depth accordingly. All it lacks is a GUI interface that stores addresses and passwords within the Gnome environment. vinagre does the GUI part nicely - all it lacks is a usable mode for anything but very fast connections.

Vladimir Buell (vbuell) wrote :

I also vote for Terminal Server Client. Such software as remote desktop viewer should be designed as frontend to existing _mature_ clients with capability to switch to another implementation in case if something going wrong, IMHO.

Shahar Or (mightyiam) wrote :

Dear friends,

This issue is in Brainstorm: http://brainstorm.ubuntu.com/idea/19510/

Many blessings.

David Fraser (davidf) wrote :

My bad - gtk-vnc does support various lossy encoding options

Changed in gtk-vnc:
status: New → Invalid
David Fraser (davidf) wrote :

Started working on a patch that I attached to the upstream bug.

Jonh Wendell (wendell) wrote :

Fixed upstream. It will be in 2.29.1 (karmic+1)

Shahar Or (mightyiam) wrote :

Great news!

Thanks, everyone.

Ricardo Fernández (koshrf) wrote :

Any way to get this before waiting for karmic+1 ? I think this is a serious bug, can't use the tool that it is recommended (for vnc) at all, and the fix is done but can't get it until karmic+1 (I could get the source and compile it myself, but it is not the common way among all users ).

Shahar Or (mightyiam) wrote :

I agree with Ricardo. How about cherry-picking this feature for karmic?

Milan Knizek (knizek) wrote :

Getting the fix to Karmic would be great!

bojo42 (bojo42) wrote :

i backported vinagre and gtk-vnc from lucid to karmic: https://launchpad.net/~bojo42/+archive/vnc

Rocko (rockorequin) wrote :

@bojo42: works a treat, thanks. Now if only we could fix the missing local mouse pointer (bug #278489), vinagre would be fully usable!

David Fraser (davidf) wrote :

Backported @bojo42's build from #30 to jaunty in my ppa: https://launchpad.net/~davidf/+archive/ppa

mxyzptlk (mxyzptlk) wrote :

I'm using the backported vinagre, which helps. But I have a question: Is it possible to set a lower color as the default? I'm guessing, if some command line call could be passed for low color, that the default low-color setting could be set via gconf-editor at /desktop/gnome/url-handlers/vnc/command. Right now it's vinagre %s.

I'm trying to help my dad half-way across the U.S., and for some reason we can't get any vnc to work except when he shares his desktop through Empathy. Empathy then calls vinagre, and vinagre defaults to maximum colors; this makes helping him nearly impossible, and it's taking up my entire winter break. If there's a way to make that default to low color, I'd be one happy unpaid tech slave.

Shahar Or (mightyiam) wrote :

I'm having the same issue as scroobious. In fact, although using bojo42's karmic backport, using empathy to share desktop, I'm not enjoying low color. Is it supposed to just happen? Can't see no configuration.

bojo42 (bojo42) on 2010-01-16
description: updated
logari81 (logari81) wrote :
Changed in vinagre (Ubuntu):
status: Triaged → Fix Released
Changed in vinagre (Baltix):
status: New → Fix Released
bojo42 (bojo42) wrote :

for the empathy support of low color support i did a new report. so please head over to Bug #514666

description: updated
Omer Akram (om26er) wrote :

marking invalid for empathy as 514666 us opened and this was not opened initially as empathy bug.

Changed in empathy (Ubuntu):
status: New → Invalid
Omer Akram (om26er) on 2010-03-01
Changed in empathy:
status: New → Invalid
Changed in vinagre:
importance: Unknown → Medium
status: Confirmed → Fix Released
Changed in vino:
importance: Unknown → Wishlist
status: Unknown → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.