Ubuntu

gvim is hidden in menu despite popup indicating it could be found in menu

Reported by Sitsofe Wheeler on 2005-10-16
34
Affects Status Importance Assigned to Milestone
vim (Ubuntu)
High
Unassigned

Bug Description

Description of the problem:
After installing vim-gnome there was no sign of a Gvim menu entry despite gnome-app-install saying it could be found in Applications -> Accessories. It was also not present in the right mouse button menu of text files.

Steps to reproduce:
1. Go to Applications -> Add/Remove...
2. Ensure that Show is on "All available applications" then type vim into the Search field.
3. Tick "Gvim Text Editor" then click apply.
4. Click Apply in the unnamed window that follows.
5. A dialog titled should appear indicating where Gvim is within the menu structure.

Expected result:
"Gvim Text Editor" menu entry to be present in Applications -> Accessories. "Open with Gvim Text Editor" to become be present in the right mouse button menu of text files.

Actual results:
Applications -> Accessories lacks a Gvim option. Right mouse button menu of text files does not have an "Open with Gvim Text Editor" option.

How reproducible is the problem?
It is reproducible every time.

Version information:
Ubuntu Feisty
vim 7.0-164+1ubuntu7
vim-common 7.0-164+1ubuntu7
vim-gnome 7.0-164+1ubuntu7
vim-gui-common 7.0-164+1ubuntu7
vim-runtime 7.0-164+1ubuntu7
vim-tiny 7.0-164+1ubuntu7

Related branches

Jeroen (jeroenubuntu) on 2005-10-23
Changed in vim:
assignee: nobody → motu
status: New → Accepted

I remember it used to be in Accessories, but the .desktop transition changed the deal.

Here is a .desktop file for vim-gtk.
Sorry for not including the whole patch with modification to debian/rules - I don't know the preferred way of generating these (should it be simple 'diff -ruN debian-old debian' in a package directory?)

response to comment #2 : I personally go in the package source do "dch -i" , "dpkg-buildpackage -us -uc -rfakeroot -S" then "cd .." and finally "debdiff old.dsc new.dsc > your_patch.patch" .

Yann Rouillard (yann-pleiades) wrote :

It's main package, why is it assigned to MOTU ?

Sitsofe Wheeler (sitsofe) wrote :

This appears to have been fixed for vim-gnome at least.

> This appears to have been fixed for vim-gnome at least.

No, there is no menu entry.

Sorry,

$ locate gvim.desktop
/usr/share/app-install/desktop/gvim.desktop
/usr/share/applications/gvim.desktop

It was hidden in the Application menu (right click on the application menu and select "Edit Menu") .
May be because I've installed Kubuntu and after switched to Ubuntu ?

Found it hidden in Accessories menu - shouldn't it be in the Programming one? I think it used to be... and SciTE and other end up there. Not that vim is a programmers editor only, but it felt more "right" there.

Johan Kröckel (jnkl) wrote :

I still have the same problem for vim-gnome.
I sum up: The Bug is that the menu-entry is hidden.
But I think all mainly text editors should stay in accessories...

Changed importance to medium.
In a user view, installing an application and can't find his entry on menu is a big problem.
End user do not have to open a terminal or use alt+f2 to launch gvim (if it already know that the name of the command is "gvim")

Changed in vim:
importance: Low → Medium
StefanPotyra (sistpoty) wrote :

unassigning MOTU, as vim is in main.

Changed in vim:
assignee: motu → nobody
Sitsofe Wheeler (sitsofe) wrote :

OK I need to update this bug to reflect that the menu entry shouldn't be hidden by default. I've just installed vim-gnome via Add/Remove... and it popped up a dialog saying that gvim could be launched from Applications -> Accessories.

Attaching screenshot demonstrating this.

description: updated

Fixed on Feisty!

Changed in vim:
status: Confirmed → Fix Released
Sitsofe Wheeler (sitsofe) wrote :

Reopening.

Marco:
No, I'm afraid it isn't. Read the most recent comments again.

Changed in vim:
status: Fix Released → Confirmed
Sitsofe Wheeler (sitsofe) wrote :

(Subscribing gothicx so reply is seen)

Marco Rodrigues (gothicx) wrote :

I've gvim (vim-gnome) installed at Feisty and I've the menu at Applications -> Accessories

Sitsofe Wheeler (sitsofe) wrote :

Marco:
Hmm. What version of vim-gnome did you install? Did you read https://bugs.launchpad.net/ubuntu/+source/vim/+bug/3222/comments/12 which talks about how it is hidden by default? Did you have a version of vim-gnome installed prior to this?

Marco Rodrigues (gothicx) wrote :

I've vim-gnome 7.0-164+1ubuntu7, but I think I've installed it from apt-get, not add/remove.

Marco Rodrigues (gothicx) wrote :

And I've also "Right mouse button menu of text files does not have an "Open with Gvim Text Editor" option." working.. i tried with an .sh file and it shows gvim there..

Marco Rodrigues (gothicx) wrote :

My system is i386.. and yours ?

Sitsofe Wheeler (sitsofe) wrote :

Marco:
i386 too. Can you test this off a LiveCD and see if you get the same result?

/usr/share/applications/gvim.desktop (that comes with vim-gui-common) clearly states the menu item is hidden by default:
MimeType=text/plain;
NoDisplay=true

The livecd is old.. I've the latest updates and it's already fixed. So I can
mark the bug as fixed.

Sitsofe Wheeler wrote:
> Marco:
> i386 too. Can you test this off a LiveCD and see if you get the same result?
>
> /usr/share/applications/gvim.desktop (that comes with vim-gui-common) clearly states the menu item is hidden by default:
> MimeType=text/plain;
> NoDisplay=true
>

--
Marco Rodrigues

http://Marco.Tondela.org

Marco:
I'm pleading with you - test the LiveCD and report back the result. What you have said doesn't make sense for the following reason: vim-gnome is not shipped on the LiveCD. You have to download it after the LiveCD has booted and when you download it you will have to get a fresh list of packages. At that point you will get the latest version of vim-gnome from the security updates area so it will be the latest version. Additionally the /usr/share/applications/gvim.desktop file I have was from vim-gui-common 7.0-164+1ubuntu7.1 .

Please test this off a LiveCD and let us know if you get the same result.

Marco Rodrigues (gothicx) wrote :

It's intentional since 1:6.4-006+2ubuntu1, check the changelog...

vim (1:6.4-006+2ubuntu1) dapper; urgency=low

  * Synchronize with Debian unstable.
  * Convert Ubuntu patches to use quilt.
  * Re-register alternative for `editor'.
  * Install .desktop file again, add attribute NoDisplay=true.

http://changelogs.ubuntu.com/changelogs/pool/main/v/vim/vim_7.1-000+1ubuntu1/changelog

Changed in vim:
status: Confirmed → Rejected
Matthew Paul Thomas (mpt) wrote :

It is wrong for Add/Remove Applications to say that an item is in a particular place in the menus when it isn't. So if this isn't a valid bug in vim, it's a valid bug in gnome-app-install.

Changed in vim:
status: Invalid → New
weijie90 (weijie90) wrote :

I can confirm this bug, in Gutsy.

To show the launcher, use System->Preferences->Main Menu->Accessories->Check "GVim Text Editor".

Jorge O. Castro (jorge) wrote :

Confirming.

Changed in gnome-app-install:
status: New → Confirmed
Sitsofe Wheeler (sitsofe) wrote :

In Hardy the message displayed upon installation is now the following:
"To start a newly installed application double click on it."
and shows a list box with an icon that can be double clicked. However I'm still unhappy that gvim doesn't show itself in the menu when it is installed - this is simply going to make it unnecessarily harder to find after installation.

Version information:
Ubuntu hardy (development branch)
gnome-app-install 0.5.2.5-0ubuntu1

Michael Vogt (mvo) wrote :

The gvim desktop file has:

Categories=Application;Utility;TextEditor;
StartupNotify=true
MimeType=text/plain;
NoDisplay=true

This is why it does not appear in the menu. This is a bug/problem of the vim package. I reassign.

Michael Rooney (mrooney) wrote :

Okay, we just need to remove "NoDisplay=true" (actually, I think this is in a patch against Debian, so we just need to remove it from that). Relative to gvim this is High since people may not be able to find it. Should be an easy fix. Plus it can help eliminate an unnecessary divergence from Debian (bug #248713).

Changed in vim:
importance: Medium → High
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vim - 1:7.1.314-3ubuntu3

---------------
vim (1:7.1.314-3ubuntu3) intrepid; urgency=low

  * runtime/syntax/grub.vim:
    - Add Ubuntu-specific 'quiet' keyword.
  * Remove some unnecessary divergence from Debian, thanks to James Vega
    (LP: #248713):
    - Remove explicit settings of textwidth=0 and nobackup, since those are
      already the defaults.
    - Remove explicit setting of viminfo to a subset of the default, thereby
      adding s10 and h.
    - Remove NoDisplay=true from gvim.desktop; vim-gui-common isn't
      installed by default and there's no reason to withhold the menu entry
      from those who have installed it (LP: #3222).

 -- Colin Watson <email address hidden> Mon, 21 Jul 2008 14:22:09 +0100

Changed in vim:
status: Triaged → Fix Released
Sitsofe Wheeler (sitsofe) wrote :

Woo hoo! Thanks Colin.

Gvim still won't show up on my menu after installation. Have experienced this with Intrepid and Jaunty. Fixed it using weijie90's advice above, "To show the launcher, use System->Preferences->Main Menu->Accessories->Check GVim Text Editor".

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints