dpkg-divert: rename involves overwriting `/usr/share/vim/vim71/doc/help.txt' with different file `/usr/share/vim/vim71/doc/help.txt.vim-tiny', not allowed

Bug #296324 reported by Graziano on 2008-11-10
152
This bug affects 6 people
Affects Status Importance Assigned to Milestone
vim (Debian)
Fix Released
Unknown
vim (Ubuntu)
High
Colin Watson
Jaunty
High
Colin Watson

Bug Description

Binary package hint: vim

Jaunty upgrade.

Preparing to replace vim-runtime 1:7.1.314-3ubuntu3 (using .../vim-runtime_2%3a7.2.025-2ubuntu1_all.deb) ...
Adding `diversion of /usr/share/vim/vim72/doc/help.txt to /usr/share/vim/vim72/doc/help.txt.vim-tiny by vim-runtime'
Adding `diversion of /usr/share/vim/vim72/doc/tags to /usr/share/vim/vim72/doc/tags.vim-tiny by vim-runtime'
Removing `diversion of /usr/share/vim/vim71/doc/help.txt to /usr/share/vim/vim71/doc/help.txt.vim-tiny by vim-runtime'
dpkg-divert: rename involves overwriting `/usr/share/vim/vim71/doc/help.txt' with
  different file `/usr/share/vim/vim71/doc/help.txt.vim-tiny', not allowed
dpkg: error processing /var/cache/apt/archives/vim-runtime_2%3a7.2.025-2ubuntu1_all.deb (--unpack):
 subprocess pre-installation script returned error exit status 2

ProblemType: Package
Architecture: amd64
Dependencies:

DistroRelease: Ubuntu 9.04
ErrorMessage: subprocess pre-installation script returned error exit status 2
NonfreeKernelModules: nvidia
Package: vim-runtime 1:7.1.314-3ubuntu3
PackageArchitecture: all
SourcePackage: vim
Title: package vim-runtime 1:7.1.314-3ubuntu3 failed to install/upgrade: subprocess pre-installation script returned error exit status 2
Uname: Linux 2.6.27-7-generic x86_64

Related branches

workaround is remove vim-tiny, install vim-runtime and install vim-tiny.

Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

I can't reproduce it on i386. As you're running amd64, could you please try to reproduce it in order to check if it's related to this arch ?

Thanks in advance.

Changed in vim:
status: New → Incomplete

I can confirm this with the exact same error messages. I am also running amd64.

Jean-Baptiste Lallement (jibel) wrote :

Thanks for your feedback. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in vim:
importance: Undecided → High
status: Incomplete → Triaged
Shirish Agarwal (shirishag75) wrote :

The workaround given by Graziano doesn't work for me :(

Giving an attachment which describes the same.

Daniel Moerner (dmoerner) wrote :

The problem is that it is setting up vim-runtime before removing vim-tiny. You can solve this problem by either:

aptitude purge vim-tiny vim-runtime:

Or:

dpkg -P vim-tiny && aptitude install vim

Brian Murray (brian-murray) wrote :

From the upstream bug report:

   * [f0116b4] Make vim-runtime Conflict vim-tiny << ${source:Version} to
     ensure diversions don't cause problems when upgrading to a new major
     upstream version. (Closes: #503757)

However, this is problematic for Ubuntu since the package ubuntu-minimal depends on vim-tiny.

Changed in vim:
assignee: nobody → ubuntu-foundations
Miloš Mandarić (mandzo18) wrote :

My upgrade have breaked while installing vim-runtime. I have an i386 arch.
sudo apt-get install -f fixed problems in my case.

Colin Watson (cjwatson) wrote :

I'll take this, although I expect that we'll be following whatever fix James Vega comes up with in Debian.

Brian: I don't see why that's problematic for the reason you describe. Certainly, Conflicts (<< ...) is often an excessively big hammer and it does have its problems, but the effect in practice is likely to be that vim-tiny gets upgraded before vim-runtime, *not* that ubuntu-minimal gets removed.

Changed in vim:
assignee: ubuntu-foundations → kamion
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vim - 2:7.2.079-1ubuntu1

---------------
vim (2:7.2.079-1ubuntu1) jaunty; urgency=low

  * Resynchronise with Debian (diversions fix closes LP: #296324). Remaining
    changes:
    - runtime/syntax/debcontrol.vim:
      + Add "metapackages" to the list of valid sections.
    - runtime/syntax/debchangelog.vim:
      + Add "jaunty" to the list of valid suites.
    - Drop vim-lesstif package and lesstif2-dev build-dependency.
    - Enable Python interpreter on basic builds.
    - Create a .pot file for translations.
    - Disable autoindent, line-wrapping, and backup files by default.
    - runtime/syntax/debsources.vim:
      + Add "jaunty" to debsourcesDistrKeyword
    - runtime/syntax/grub.vim:
      + Add Ubuntu-specific 'quiet' keyword.

vim (2:7.2.079-1) unstable; urgency=low

  * [4d191a4] Update README for patches 50 - 065
  * [37bd8e4] Update README for patches 66 - 079
    - [43035e4] [7.2.068] error when Emacs tags file line is too long (Closes:
      #507116)
  * debian/update-patches:
    - [38e4f12] die if lftp isn't installed
    - [fe1a8f1] Set GIT_AUTHOR_DATE when committing upstream patches
  * [b5182c2] Fix a few typos in the French translation (Closes:
    #511002)
  * [75a19d8] vim-runtime: Remove old version diversions in postinst
    (Closes: #503757)
  * [b170d58] debian/rules: Call dh_desktop for vim-gui-common

vim (2:7.2.049-2) unstable; urgency=low

  * [444b68d] syntax/python.vim: Add missing contained keyword for
    pythonDecoratorName (Closes: #504510)

vim (2:7.2.049-1) unstable; urgency=low

  [ James Vega ]
  * [9525410] Remove EOLd feisty and add jaunty to
    syntax/{debchangelog,debsources}.vim
  * [c154fa3,606fc00] Update README for patches 026 - 049
  * [233b1c9] Add recognition of PRUNENAMES variable to syntax/updatedb.vim
    (Closes: #504084)
  * [f7bfa57] Don't install vim alternatives for vim-tiny. vim-tiny is built
    to act like vi, so the vim alternative just causes more confusion than
    it's worth (by default).
  * [f0116b4] Make vim-runtime Conflict vim-tiny << ${source:Version} to
    ensure diversions don't cause problems when upgrading to a new major
    upstream version. (Closes: #503757)
  * [401c913] Include rgb.txt in vim-runtime (Closes: #505069)
  * [045810d] Fix a typo in ftplugin/gitcommit.vim's comments... (Closes:
    #505165)
  * [b4fe540,3454e66] Correctly highlight Python decorator names. (Closes:
    #504510)

  [ Stefano Zacchiroli ]
  * [64d3690] policy: bump version and copyright year

 -- Colin Watson <email address hidden> Tue, 13 Jan 2009 18:39:18 +0000

Changed in vim:
status: Triaged → Fix Released
Changed in vim:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.