Ubuntu

vim-gnome window does not resize correctly when opening the 1st tab

Reported by N KInkade on 2007-09-07
54
This bug affects 6 people
Affects Status Importance Assigned to Milestone
vim
Undecided
auto-vim-dev
vim (Debian)
Fix Released
Unknown
vim (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: vim-gnome

Problem:
gvim does not correctly resize the window when the first tab is opened, part of the window becomes hidden behind task panel, thus hiding the :ex command and status area making it necessary to manually resize the window again.

Recreate:
    1) launch gvim
    2) expand the window to full size
    3) :tabnew test.txt

Result:
The tab is created properly, but the bottom of the window is forced downward, proportionately to the height of the tab, and behind the task panel of the Gnome desktop.

Expected result:
   gvim should have have shrunk the editing area, not resized the window.

N KInkade (nkinkade) on 2007-09-07
description: updated
markuz (markuz) wrote :

That happens to me too. but that's not exclusive of ubuntu, I use Slackware too and it happens there too.

Deapesh (deapesh) wrote :

Confirming this problem on Ubuntu 2.6.27.11.
Is this issue going to be patched?

Roy Jamison (xteejx) wrote :

I am not able to reproduce this in Jaunty, marking Low, Incomplete.

Changed in vim (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Roy Jamison (xteejx) wrote :

Deapesh: 2.6.27-14.33 is the current version of the linux kernel for Intrepid Ibex. Can you ensure you mark all updates and install all as required before we can confirm this bug report, as there may be some updates that correct this issue. Thank you.

Changed in vim (Ubuntu):
status: Confirmed → Incomplete
Thierry Moisan (thierry-moisan) wrote :

I can reproduce this on gvim with vim version 7.2.79.

Roy Jamison (xteejx) wrote :

I can also confirm this on gvim 7.2.079-1ubuntu5 Jaunty.

Changed in vim (Ubuntu):
status: Incomplete → Confirmed
Roy Jamison (xteejx) wrote :

Upstream do not have a bugtracker, but they are aware of this problem, just to note.

Changed in vim (Debian):
status: Unknown → New
Kevin Kaland (kkaland) wrote :

Also confirming on Jaunty with 7.2.79. My workaround is to just not hit the maximize button but keep the window a touch shy of maximized.

Kevin Kaland (kkaland) wrote :

Weird, this WAS fixed when I upgraded a Jaunty installation to Lucid on my VM, but I just upgraded a Hardy installation (Xubuntu) to Lucid and the problem persists with both vim-gnome and vim-gtk :( anyone know some versions where this doesn't happen?

Roy Jamison (xteejx) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner.
There have been many changes in Ubuntu since the last comment and your problem may have been fixed with some of the updates. It would help us a lot if you could test the current Ubuntu version (10.10). If you can test it, and it is still an issue, we would appreciate if you could upload updated logs by running apport-collect <bug #>, and any other logs that are relevant for this particular issue.

Changed in vim (Ubuntu):
status: Confirmed → Incomplete
N KInkade (nkinkade) wrote :

I'm using Ubuntu 10.10 and vim-gnome 7.2.330-1ubuntu4, and this problem still seems to exist. As others have noted, this isn't exactly an Ubuntu bug, but rather an upstream issue. Even at that, it's pretty benign ... more of a minor annoyance. I suspect this ticket can be closed unless someone plans to patch the package rather than wait for an upstream patch to trickle down.

Roy Jamison (xteejx) wrote :

Even though this was reported to Debian, nothing was done, and so because this affects a recent Ubuntu version, i.e. 10.10, I have emailed the developers directly at <email address hidden> and am awaiting a (hopefully positive) response. I apologise this has not been worked on but I will try to push it through.

Changed in vim (Ubuntu):
status: Incomplete → Triaged
Roy Jamison (xteejx) wrote :

According to the vim developers, this works in vim versions 7.3.75 and 7.3.89 which they have tested. The latest version we have in the development release Natty is 7.3.035 so it may or may not make it into that release, but that is 4 months away and things are likely to change between now and then.
Also, it may be worth looking at the guiheadroom option for vim to see if this can be used as a workaround for now.

Roy Jamison (xteejx) wrote :

I have changed the upstream tracker to bug 608390, the old one has stagnated and is going nowhere, but since the vim developers state that this is fixed in recent versions, the bug is a request to update. Once that is fixed, we will know through the magic of Launchpad :)

Changed in vim (Debian):
status: New → Unknown
Kevin Kaland (kkaland) wrote :

Thanks Teej - sorry for not being responsive. I'm having the issue on a server, so I want to keep it on the LTS. I'll see if I can find a PPA with Vim 7.3 or build it from source. If you can think of a better way to go about it, let me know.

In some cases it can be a rather annoying issue because it kinda interrupts you, making you hit alt + F10 twice and then ctrl+w = to fix the window sizes.

I'm subscribed, so will keep an eye out for the fix.

Roy Jamison (xteejx) wrote :

No problem. As above it hasn't yet hit our repos yet so a fix *in* Ubuntu may be a release away unless it can be quickly thrown in before April. Thanks for the reply. I too will keep an eye on this (and upstream).

Roy Jamison (xteejx) wrote :

Attached diff from upstream which fixes this problem.

tags: added: patch
Changed in vim (Debian):
status: Unknown → New
Changed in vim (Debian):
status: New → Fix Committed
Kevin Kaland (kkaland) wrote :

At this point, is there any way to get this fix on Lucid? If not, is it likely to be backported and available through the backports repos?

Thanks!

Roy Jamison (xteejx) wrote :

The Ubuntu Review team is subscribed to this bug report so should get emails from it.
Is this a possible candidate for SRU for Lucid? I personally don't see too much of a problem diff'ing the patch into the Lucid version and adding the appropriate -XubuntuY. Hopefully we should get a response on that soon.
Also has this patch been incorporated? Can't see anything obvious to say it's been added (maybe I've missed something).
Thanks guys.

davepc (dave-p-clarke) wrote :

Bug still present in vim.gnome on natty exactly as original post describes.

Current fix unmaximise and then maximise.

VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Mar 24 2011 07:07:46)
Included patches: 1-35

Changed in vim (Debian):
status: Fix Committed → Fix Released
Jacobo de Vera (jdevera) wrote :

I just applied the patch posted here to vim7.3 under Maverick and I still see the problem happening.

davepc (dave-p-clarke) wrote :

I can confirm that this bug is fixed with Unity on Ubuntu 12.04 and
VIM - Vi IMproved 7.3 (2010 Aug 15, compiled May 4 2012 04:10:13)
Included patches: 1-429

Changed in vim (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Patches

Remote bug watches

Bug watches keep track of this bug in other bug trackers.