.viminfo file is wrong in Slovenian translation

Bug #1036181 reported by Kovica
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Low
Ubuntu Slovenian Quality Assurance
vim (Ubuntu)
Undecided
Unassigned

Bug Description

I'm using kubuntu 12.04 and Slovenian as default language. The system is fully update with all available fixes.

If I run:
LANG=C vim
then .viminfo looks like this:
# This viminfo file was generated by Vim 7.3.
# You may edit it if you're careful!

# Value of 'encoding' when this file was written
*encoding=utf-8

# hlsearch on (H) or off (h):
~h
# Command Line History (newest to oldest):
:q

# Search String History (newest to oldest):

# Expression History (newest to oldest):

# Input Line History (newest to oldest):

# Input Line History (newest to oldest):

# Registers:

# File marks:

# Jumplist (newest first):

# History of marks within files (newest to oldest):

but if I run vim just by enterin vim then .viminfo file looks like this:
# Ta datoteka viminfo ni bila ustvarjena s programom Vim 7.3.
# Če boste previdni, jo lahko urejate!

# Vrednost 'encoding', ko je ta datoteka bila zapisana
*encoding=utf-8

# hlsearch on (H) or off (h):
~h
# Ukazna vrstica Zgodovina (od najnovejšega do najstarejšega):
:q

# Iskalni niz Zgodovina (od najnovejšega do najstarejšega):

# Izraz Zgodovina (od najnovejšega do najstarejšega):

# Vrstica vnosa Zgodovina (od najnovejšega do najstarejšega):

# Vrstica vnosa Zgodovina (od najnovejšega do najstarejšega):

Št. Vpisov:

# Označbe datoteke:

# Jumplist (newest first):

# Zgodovina označb znotraj datotek (od najnovejših do najstarejših):

The problem is that line
Št. Vpisov:
should look like
#Št. Vpisov:

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: vim 2:7.3.429-2ubuntu2.1
ProcVersionSignature: Ubuntu 3.2.0-29.46-generic 3.2.24
Uname: Linux 3.2.0-29-generic x86_64
ApportVersion: 2.0.1-0ubuntu12
Architecture: amd64
Date: Mon Aug 13 15:10:42 2012
InstallationMedia: Kubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120423)
ProcEnviron:
 LANGUAGE=sl:en
 PATH=(custom, user)
 LANG=sl_SI.UTF-8
 SHELL=/bin/bash
SourcePackage: vim
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Kovica (kovica) wrote :
Gabor Kelemen (kelemeng)
Changed in ubuntu-translations:
assignee: nobody → Ubuntu Slovenian Quality Assurance (ubuntu-l10n-sl)
status: New → Triaged
importance: Undecided → Low
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in vim (Ubuntu):
status: New → Confirmed
Revision history for this message
Andrej Znidarsic (andrejznidarsic) wrote :

Thank you for your report.
This has been already fixed on 07.08.2012 (string in question is at https://translations.launchpad.net/ubuntu/precise/+source/vim/+pots/vim/sl/1157/+translate ) but hasn't been fixed to late to be included in the last language pack update.

It will be fixed for all users upon next language pack release which will be ob 29.09.2012 (see https://wiki.ubuntu.com/Translations/PreciseLanguagePackReleaseSchedule for details).

If you want to recieve language pack updates add a new software source ppa:ubuntu-langpack/ppa .

Changed in ubuntu-translations:
status: Triaged → Fix Committed
Changed in vim (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
Kovica (kovica) wrote :

Understand. Thanks

Revision history for this message
Jure Sah (dustwolfy) wrote :

For the record today this is still not corrected.

Is there a PPA or something where we can find the fix now? It is very annoying.

Revision history for this message
Andrej Znidarsic (andrejznidarsic) wrote :

DustWolf: Add this ppa to software sources to get the latest language pack:

ppa:ubuntu-langpack/ppa

Revision history for this message
Robert Hrovat (robi-hipnos) wrote :

This should be fixed in 12.04 LTS. Why isn't it?

Revision history for this message
Andrej Znidarsic (andrejznidarsic) wrote :

Hello Robert!

I've just tested it and this has been fixed. The problem is language pack update with the fix has not been released as a stable release update yet. Probably there should be one relased for 12.04.2.

In the mean time you can get the newest langpack with this fix included by executing these commands in terminal:

sudo add-apt-repository ppa:ubuntu-langpack/ppa
sudo apt-get update
sudo apt-get upgrade

Revision history for this message
Robert Hrovat (robi-hipnos) wrote :

Oh, I had to remove .viminfo first. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers