Ubuntu

util-linux no longer provides ddate

Reported by Rob Lesslie on 2012-04-26
176
This bug affects 34 people
Affects Status Importance Assigned to Milestone
util-linux (Ubuntu)
Medium
Unassigned

Bug Description

Having just upgraded to 12.04, I was dismayed to discover that ddate is longer present on my system. In previous releases it was provided by util-linux, and according to the online man page (http://manpages.ubuntu.com/manpages/precise/man1/ddate.1.html) it is still supposed to be provided. However:

lesslie@hal:~> ddate
No command 'ddate' found, did you mean:
 Command 'hdate' from package 'libhdate1' (main)
 Command 'sdate' from package 'sdate' (universe)
 Command 'rdate' from package 'rdate' (main)
 Command 'idate' from package 'itools' (universe)
 Command 'date' from package 'coreutils' (main)
ddate: command not found

System information below.

lesslie@hal:~> lsb_release -rd
Description: Ubuntu 12.04 LTS
Release: 12.04

lesslie@hal:~> apt-cache policy util-linux
util-linux:
  Installed: 2.20.1-1ubuntu3
  Candidate: 2.20.1-1ubuntu3
  Version table:
 *** 2.20.1-1ubuntu3 0
        500 http://gb.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

What I expected: ddate to be available on my system
What happened instead: ddate is not available on my system

Changed in util-linux (Ubuntu):
importance: Undecided → Medium
John Pearson (jpearson42) wrote :

Is there a reason for this omission?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in util-linux (Ubuntu):
status: New → Confirmed
Accorte (accorte) wrote :

Also just noticed it even before the upgrade finished. I hope to see it patched in shortly.

Corasol (corasol) wrote :

The change happened upstream, by default util-linux no long builds with ddate enabled and now needs the --enable-ddate option, see:

https://git.kernel.org/?p=utils/util-linux/util-linux.git;a=commit;h=4a8962f3a7cb970b28add7d770528edebbe03635

I'm guessing the Ubuntu package maintainer didn't notice this change.

Franko Burolo (fburolo) wrote :

Sacrilege!

What exactly should we do now to get this back?

All hail Discordia!

Chronon (gopindra) wrote :

I downloaded the source and built the package myself with ddate enabled (just do ./configure --enable-ddate). I hope to see this fixed in Ubuntu.

Leon Weber (leonn) wrote :

I also would like to have ddate back. This has been fixed in debian too: <http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=650321>

Fabio Franco (g-duke) wrote :

Please rebuild util-linux with ddate, this is a matter of respect for our origins.

Franco

Franko Burolo (fburolo) wrote :

And I really don't see what harm it does when built by default. It is really not heavy on resources, it is invisible for most users, and very useful to some.
I totally agree with the Debian folks, and totally disagree with Karel Zak from upstream. It is much crazier to force users to compile util-linux manually, just because they are discordians, than it is to build it by default. Craziness is to assume that somebody is able to do it by just being discordian. And preventing access to such a tool is a violation of some basic human rights.

We want ddate back, please!

P'tang!

Saccharomyces (saccharomyces) wrote :

The lack of ddate breaks several of my scripts.

As has been said, ddate is no longer included by default, you must explicitly pass --enable-ddate option when configuring.

Josh (joshie-squashy) wrote :

The ddate command is important to me. I won't upgrade to 12.04 until this bug is fixed.

Franko Burolo (fburolo) wrote :

Still unassigned... But I am sure the package maintainer for util-linux could do it in a minute or less.

Franko Burolo (fburolo) wrote :

BTW, I have just read this discussion on Fedora: http://osdir.com/ml/fedora-devel-list/2011-08/msg01691.html

Jon said, very reasonably: "[...] there isn't a compelling disk space or security argument, I really don't see why this should be dropped. I'm looking for a clear example of demonstrable harm. It's 14k of silliness, not a rootkit."
On that, Karel Zak acted as a bully, saying: "That's simple, I'm upstream maintainer. The command has been disabled by default in the last stable release. And yes, one I day I'll drop it..."
With only "arguments" being:
"- it's joke rather than anything useful
- it's installed on all systems, but almost nobody uses this crap"

So, by the language and attitudes he is using, and not giving any rational argument, nor option, one can easily assume that this Zak guy from Fedora/Red Hat/upstream has just decided to start his own holy crusade against the "crazy witches" in the wider Linux community.
I think the Ubuntu community should join the Debian one, and refuse to indulge this irrational and intolerant act.

Frink!

Matt Joyce (matt-nycresistor) wrote :

I like ddate. I miss ddate. I want ddate back damn it.

Franko Burolo (fburolo) wrote :

Still unassigned... :-/

Josh (joshie-squashy) wrote :

Here is a workaround. I did this and now I have ddate again.

wget -O bo0ts-ddate.tar.gz https://nodeload.github.com/bo0ts/ddate/tarball/master
tar xzf bo0ts-ddate.tar.gz
sudo apt-get install cmake
cd bo0ts-ddate-79d2c9a
mkdir build
cd build
cmake ..
sudo make install

Patola (patola) wrote :

make install? COME ON! This is too reckless. What's the point in having a system with such a sophisticated package management if you try to opt out of it by scattering files around the filesystem? You should be ashamed.

This is a more responsible recipe (run as root):

$ sudo su -
# apt-get source util-linux
# sed -i 's/2.20.1-1ubuntu3/2.20.1-2/' util-linux-2.20.1/debian/changelog ; sed -i 's/--enable-raw --enable-rdev --enable-partx/--enable-ddate --enable-raw --enable-rdev --enable-partx/' util-linux-2.20.1/debian/rules
# ( cd util-linux-2.20.1 && dpkg-buildpackage )
# dpkg -i util-linux_2.20.1-2_*.deb
# ddate
<Ctrl-D>

These commands download, build and install util-linux_2.20.1-2, which is one minor version more "recent" than the current util-linux_2.20.1-1ubuntu3, so until the next version (which I trust will have this roadblocker bug fixed) you're safe from it wanting to upgrade everytime.

eris23 (jdkatz23) wrote :

Somewhere before the dpkg-buildpackage there should be:

apt-get build-dep util-linux

Josh (joshie-squashy) wrote :

@Patola, I agree that my solution is a hack, and that's why I called it a workaround. Your solution is only a short-term fix, however. The maintainer for util-linux has stated that he plans to drop ddate from util-linux altogether in the future, making it so that compiling with --enable-ddate will no longer work.

I suppose the real solution would be to create a deb package based on the code in that git-hub repository and have it added to the Ubuntu repository, but I don't know how to do that myself.

But for now it is still very much part of util-linux and must be dealt
with in this context. Once it is closer to being dropped and a new
upstream maintainer adopts the code base, then we can start talking
about separate packages.

On Sun, Jul 22, 2012 at 5:28 PM, Josh <email address hidden> wrote:
> @Patola, I agree that my solution is a hack, and that's why I called it
> a workaround. Your solution is only a short-term fix, however. The
> maintainer for util-linux has stated that he plans to drop ddate from
> util-linux altogether in the future, making it so that compiling with
> --enable-ddate will no longer work.
>
> I suppose the real solution would be to create a deb package based on
> the code in that git-hub repository and have it added to the Ubuntu
> repository, but I don't know how to do that myself.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/988925
>
> Title:
> util-linux no longer provides ddate
>
> Status in “util-linux” package in Ubuntu:
> Confirmed
>
> Bug description:
> Having just upgraded to 12.04, I was dismayed to discover that ddate
> is longer present on my system. In previous releases it was provided
> by util-linux, and according to the online man page
> (http://manpages.ubuntu.com/manpages/precise/man1/ddate.1.html) it is
> still supposed to be provided. However:
>
> lesslie@hal:~> ddate
> No command 'ddate' found, did you mean:
> Command 'hdate' from package 'libhdate1' (main)
> Command 'sdate' from package 'sdate' (universe)
> Command 'rdate' from package 'rdate' (main)
> Command 'idate' from package 'itools' (universe)
> Command 'date' from package 'coreutils' (main)
> ddate: command not found
>
> System information below.
>
> lesslie@hal:~> lsb_release -rd
> Description: Ubuntu 12.04 LTS
> Release: 12.04
>
> lesslie@hal:~> apt-cache policy util-linux
> util-linux:
> Installed: 2.20.1-1ubuntu3
> Candidate: 2.20.1-1ubuntu3
> Version table:
> *** 2.20.1-1ubuntu3 0
> 500 http://gb.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
> 100 /var/lib/dpkg/status
>
> What I expected: ddate to be available on my system
> What happened instead: ddate is not available on my system
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/util-linux/+bug/988925/+subscriptions

Franko Burolo (fburolo) wrote :

+1 for that, Saccharomyces! But I also hope that common sense will once again prevail, and ddate will be restored as normal.

And by the way. My workaround was to just install the Debian's (Wheezy) deb package of util-linux. As the ddate flag seems to be the only difference with the Ubuntu one. I did it in June, if I remember well... and still haven't had any problems with that. No dependency issues and the OS overall works just as it should. ddate included. :-)

Can't believe this is still unassigned here...

Matt Ruffalo (mruffalo) wrote :

I had ddate in my .bash_profile, and it is very sad to see that it's no longer built by default.

There have been changes to the relevant parts of util-linux since this change was made, so a simple 'git revert' didn't suffice. I'm considering submitting the patch upstream, but in the mean time a decent workaround would be to enable it for Ubuntu.

Franko Burolo (fburolo) wrote :

4 months, still unassigned...

Fnord.

Adam Funk (a-funk) wrote :

<i>It is much crazier to force users to compile util-linux manually, just because they are discordians, than it is to build it by default. Craziness is to assume that somebody is able to do it by just being discordian.</i>

It's also crazy to assume that only Discordians need to use that dating system occasionally.

Wuestenschiff (wuestenschiff) wrote :

Just wanted to add:

Debian fixed this grave bug in February:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=650321

As the bugs stated there are quite a lot of people usig ddate in scripts. I for example use it in al log-script.

This is Important, there are discordians out there

Hail Eris
   Desertship

Franko Burolo (fburolo) wrote :

hahaha... I must say I agree with Adam Funk, too... :-D After all, I am not really discordian, neither. Just a sympathizer. :-D

Wibble!

Rob Lesslie (roblesslie) wrote :

I have just upgraded to 12.10, and ddate is back in util-linux.

zeimusu (james-kilfiger) on 2012-12-11
Changed in util-linux (Ubuntu):
status: Confirmed → Fix Released
Franko Burolo (fburolo) wrote :

The fix is released for Quantal, but in Precise (latest LTS) it is still an issue... Or am I wrong?

ddate is still missing from util-linux on 12.04 as of today.

I expect annoying problems when I upgrade, but I did not see this coming. It's this kind of thing that is keeping Linux from being ready for the Desktop.

Brent W. Barker (b-w-barker) wrote :

Confirmed, ddate is not available in Ubuntu 12.04 LTS.

Georg Nebehay (gnebehay) wrote :

In order to provide a remedy to this miserable situation I created a personal package archive (ppa) that contains a modified version of util-linux providing ddate for Ubuntu 12.04. To enable it, enter the commands

$ sudo apt-add-repository ppa:gnebehay/util-linux
$ sudo apt-get update
$ sudo apt-get upgrade

and voilà:

$ ddate
Today is Boomtime, the 62nd day of Chaos in the YOLD 3179

Future changes to the original util-linux package will be merged into the ppa. In order to revert to the original version of util-linux, I recommend the use of ppa-purge

$ sudo apt-get install ppa-purge
$ sudo ppa-purge ppa:gnebehay/util-linux

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.