usplash crashed with SIGSEGV in memset_var()

Bug #401432 reported by Henrik on 2009-07-19
480
This bug affects 91 people
Affects Status Importance Assigned to Milestone
usplash (Ubuntu)
Medium
Loïc Minier
usplash-theme-ubuntu (Ubuntu)
Medium
Kenneth Wimer

Bug Description

Binary package hint: usplash

I got this as I logged in.

ProblemType: Crash
Architecture: i386
CrashCounter: 1
Date: Sun Jul 19 18:11:35 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /sbin/usplash
MachineType: KOHJINSHA CO.,LTD. SH series
Package: usplash 0.5.32
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-3-generic root=UUID=3e772e25-db35-4e0c-bcd6-4eed41987af5 ro quiet splash
ProcCmdline: /sbin/usplash -c
ProcEnviron: PATH=(custom, no user)
ProcVersionSignature: Ubuntu 2.6.31-3.19-generic
SegvAnalysis:
 Segfault happened at: 0xf4e4f0 <memset_var+1072>: mov %edi,(%eax)
 PC (0x00f4e4f0) ok
 source "%edi" ok
 destination "(%eax)" (0xb7f0d530) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: usplash
StacktraceTop:
 memset_var () from /lib/libusplash.so.0
 bogl_tcfb_clear () from /lib/libusplash.so.0
 usplash_bogl_clear () from /lib/libusplash.so.0
 usplash_clear () from /lib/libusplash.so.0
 clear_text () from /lib/libusplash.so.0
Tags: ubuntu-unr
Title: usplash crashed with SIGSEGV in memset_var()
Uname: Linux 2.6.31-3-generic i686
UserGroups:

UsplashConf:
 # Usplash configuration file
 # These parameters will only apply after running update-initramfs.

 xres=1024
 yres=600
dmi.bios.date: 08/30/07
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: NAPA0001.86C.0000.D.0708301817
dmi.board.name: S37
dmi.board.vendor: INVENTEC
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: No Enclosure
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrNAPA0001.86C.0000.D.0708301817:bd08/30/07:svnKOHJINSHACO.,LTD.:pnSHseries:pvrNotApplicable:rvnINVENTEC:rnS37:rvrNotApplicable:cvnNoEnclosure:ct1:cvrN/A:
dmi.product.name: SH series
dmi.product.version: Not Applicable
dmi.sys.vendor: KOHJINSHA CO.,LTD.

Henrik (neu242) wrote :

StacktraceTop:?? ()
?? ()

tags: added: apport-failed-retrace
tags: removed: need-i386-retrace
tags: added: need-i386-retrace

StacktraceTop:memset_var () from /lib/libusplash.so.0
bogl_tcfb_clear () from /lib/libusplash.so.0
usplash_bogl_clear () from /lib/libusplash.so.0
usplash_clear () from /lib/libusplash.so.0
clear_text () from /lib/libusplash.so.0

Changed in usplash (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Paul Larson (pwlars) wrote :

Seems unlikely that this would be specific to UNR, but all the reports I'm seeing for it were reported on UNR. Anyone seeing this on desktop?

visibility: private → public

 This is the first time I report a problem on Ubuntu Alpha version.

I run it on an ACER d150 0Bk, as i do with Intrepid. I faced no problem of this kind on Intrepid.

That is all I can do. Sorry.

-----E-mail d'origine-----
De : Paul Larson <email address hidden>
A : <email address hidden>
Envoyé le : Mercredi, 22 Juillet 2009 23:54
Sujet : [Bug 401432] Re: usplash crashed with SIGSEGV in memset_var()

Seems unlikely that this would be specific to UNR, but all the reports
I'm seeing for it were reported on UNR. Anyone seeing this on desktop?

** Visibility changed to: Public

--
usplash crashed with SIGSEGV in memset_var()
https://bugs.launchpad.net/bugs/401432
You received this bug notification because you are a direct subscriber
of a duplicate bug.

Jonathan Nielsen (jmnet) wrote :

I have the standard 'desktop' installed and it happened to me, but I suspect it may have something to do with the odd resolutions found on netbooks (like 1024x600)

Henry S. (snowball2050-gmail) wrote :

I can confirm this on a 'desktop' installation. In particular, on a Asus eee 1000 with 1024x600 resolution.

Jan Hoffmann (jan-hoffmann) wrote :

I'm experiencing this bug with a standard desktop installation on an Eee PC 901 with 1024x600 resolution. But maybe it is related to the intel graphics in general and not only to this resolution.

Andy Whitcroft (apw) wrote :

I have what appears to be the same issue on karmic on a Dell Mini 10v which also has a 1024x600 display.

Paul Larson (pwlars) wrote :

Ok, that's what I was suspecting - seems to be on resolutions of 1024x600 or less. Removing ubuntu-unr tag/subscription since it is not specifically a unr bug. Thanks for the feedback!

tags: removed: ubuntu-unr
chumbert (humbert-chris) wrote :

Same problem on Asus Eee PC 1000h (1024x600). The bug appears only when the session starts.

James Schriver (dashua) wrote :

I have not seen a usplash boot animation on Karmic yet. I have Dell Vostro A90 (Mini 9) and received this same apport trace.

Alan Lord (theopensourcerer) wrote :

I'm running Karmic on an Asus 1008HA and get this error on each power-up.

Same problem with Acer Aspire One, as described in the duplicate bug, number 405422

Same on Dell Mini 9.

On Wed, Jul 29, 2009 at 3:31 AM, Flamarion
Jorge<email address hidden> wrote:
> Same problem with Acer Aspire One, as described in the duplicate bug,
> number 405422
>
> --
> usplash crashed with SIGSEGV in memset_var()
> https://bugs.launchpad.net/bugs/401432
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “usplash” package in Ubuntu: New
>
> Bug description:
> Binary package hint: usplash
>
> I got this as I logged in.
>
> ProblemType: Crash
> Architecture: i386
> CrashCounter: 1
> Date: Sun Jul 19 18:11:35 2009
> DistroRelease: Ubuntu 9.10
> ExecutablePath: /sbin/usplash
> MachineType: KOHJINSHA CO.,LTD. SH series
> Package: usplash 0.5.32
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-3-generic root=UUID=3e772e25-db35-4e0c-bcd6-4eed41987af5 ro quiet splash
> ProcCmdline: /sbin/usplash -c
> ProcEnviron: PATH=(custom, no user)
> ProcVersionSignature: Ubuntu 2.6.31-3.19-generic
> SegvAnalysis:
>  Segfault happened at: 0xf4e4f0 <memset_var+1072>:      mov    %edi,(%eax)
>  PC (0x00f4e4f0) ok
>  source "%edi" ok
>  destination "(%eax)" (0xb7f0d530) not located in a known VMA region (needed writable region)!
> SegvReason: writing unknown VMA
> Signal: 11
> SourcePackage: usplash
> StacktraceTop:
>  memset_var () from /lib/libusplash.so.0
>  bogl_tcfb_clear () from /lib/libusplash.so.0
>  usplash_bogl_clear () from /lib/libusplash.so.0
>  usplash_clear () from /lib/libusplash.so.0
>  clear_text () from /lib/libusplash.so.0
> Tags:  ubuntu-unr
> Title: usplash crashed with SIGSEGV in memset_var()
> Uname: Linux 2.6.31-3-generic i686
> UserGroups:
>
> UsplashConf:
>  # Usplash configuration file
>  # These parameters will only apply after running update-initramfs.
>
>  xres=1024
>  yres=600
> dmi.bios.date: 08/30/07
> dmi.bios.vendor: Phoenix Technologies LTD
> dmi.bios.version: NAPA0001.86C.0000.D.0708301817
> dmi.board.name: S37
> dmi.board.vendor: INVENTEC
> dmi.board.version: Not Applicable
> dmi.chassis.asset.tag: No Asset Tag
> dmi.chassis.type: 1
> dmi.chassis.vendor: No Enclosure
> dmi.chassis.version: N/A
> dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrNAPA0001.86C.0000.D.0708301817:bd08/30/07:svnKOHJINSHACO.,LTD.:pnSHseries:pvrNotApplicable:rvnINVENTEC:rnS37:rvrNotApplicable:cvnNoEnclosure:ct1:cvrN/A:
> dmi.product.name: SH series
> dmi.product.version: Not Applicable
> dmi.sys.vendor: KOHJINSHA CO.,LTD.
>

--
John Byerly
mailto:<email address hidden>

Loïc Minier (lool) wrote :

@Robert Hooker: thanks for the back traces (NB: you're attaching them to a dup now, please attach further info in this main bug. Also note that the printf you commented out seem to cause a different crash.)

The stacktrace in bug #406569 shows:
#3 0x00871096 in usplash_clear (x1=332, y1=457, x2=692, y2=607, colour=0) at libusplash.c:228
while yres is 600. Clearing beyond the screen limits.

This is computed in clear_text() where y2 = y1 + theme->text_height;.

It seems a) our theme crashes on yres < 607 and b) usplash doesn't check screen bounds.

Loïc Minier (lool) wrote :

Could someone please test libusplash0 + usplash 0.5.31 from https://launchpad.net/ubuntu/+source/usplash/0.5.31 (click on "jaunty i386" or "jaunty amd64": does that version work for you?

Loïc Minier (lool) wrote :

I found various inconsistencies in usplash-theme-ubuntu themes, especially themes where text_y + text_height > theme_height. I discussed this with Kenneth Wimer and he said he will fix the theme.

Changed in usplash (Ubuntu):
status: New → Triaged
Changed in usplash-theme-ubuntu (Ubuntu):
assignee: nobody → Kenneth Wimer (kwwii)
importance: Undecided → Medium
status: New → In Progress

Please keep in mind some of these crashes are with the Kubuntu theme too.

Robert Hooker (sarvatt) wrote :

Indeed it was just a theme problem! I installed the mythbuntu usplash theme instead and it works.

Loïc Minier (lool) on 2009-08-05
Changed in usplash (Ubuntu):
assignee: nobody → Loïc Minier (lool)
status: Triaged → Fix Committed
Kenneth Wimer (kwwii) on 2009-08-05
Changed in usplash-theme-ubuntu (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usplash - 0.5.33

---------------
usplash (0.5.33) karmic; urgency=low

  * Fix return type of strncspn in libusplash.h
  * Include usplash-theme.h from libusplash.h as it uses struct usplash_theme
    in declarations.
  * Include libusplash.h in libusplash.c to ensure sanity of prototypes.
  * Remove duplicate testcard_theme definition from libusplash.c.
  * libusplash.c: drop most prototypes for non-static functions which are
    already declared in libusplash.h.
  * Add usplash_sanity_check_theme() and use it to reject themes which have a
    textbox which overflows the theme dimensions; LP: #401432.
  * Also sanity check progressbar dimension for overflows.

 -- Loic Minier <email address hidden> Wed, 05 Aug 2009 12:10:22 +0100

Changed in usplash (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usplash-theme-ubuntu - 0.24

---------------
usplash-theme-ubuntu (0.24) karmic; urgency=low

  [ Kenneth Wimer ]
  * Correcting text box placement values and resolution for some configs
    entries to fix LP: #401432

 -- Loic Minier <email address hidden> Wed, 05 Aug 2009 12:17:01 +0100

Changed in usplash-theme-ubuntu (Ubuntu):
status: Fix Committed → Fix Released

Hi Loic

Where can I find instructions on how to install this bug fix?

Many thanks

Gilly

On Wed, Aug 5, 2009 at 9:35 PM, Launchpad Bug Tracker <
<email address hidden>> wrote:

> This bug was fixed in the package usplash-theme-ubuntu - 0.24
>
> ---------------
> usplash-theme-ubuntu (0.24) karmic; urgency=low
>
> [ Kenneth Wimer ]
> * Correcting text box placement values and resolution for some configs
> entries to fix LP: #401432
>
> -- Loic Minier <email address hidden> Wed, 05 Aug 2009 12:17:01
> +0100
>
> ** Changed in: usplash-theme-ubuntu (Ubuntu)
> Status: Fix Committed => Fix Released
>
> --
> usplash crashed with SIGSEGV in memset_var()
> https://bugs.launchpad.net/bugs/401432
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “usplash” package in Ubuntu: Fix Released
> Status in “usplash-theme-ubuntu” package in Ubuntu: Fix Released
>
> Bug description:
> Binary package hint: usplash
>
> I got this as I logged in.
>
> ProblemType: Crash
> Architecture: i386
> CrashCounter: 1
> Date: Sun Jul 19 18:11:35 2009
> DistroRelease: Ubuntu 9.10
> ExecutablePath: /sbin/usplash
> MachineType: KOHJINSHA CO.,LTD. SH series
> Package: usplash 0.5.32
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-3-generic
> root=UUID=3e772e25-db35-4e0c-bcd6-4eed41987af5 ro quiet splash
> ProcCmdline: /sbin/usplash -c
> ProcEnviron: PATH=(custom, no user)
> ProcVersionSignature: Ubuntu 2.6.31-3.19-generic
> SegvAnalysis:
> Segfault happened at: 0xf4e4f0 <memset_var+1072>: mov %edi,(%eax)
> PC (0x00f4e4f0) ok
> source "%edi" ok
> destination "(%eax)" (0xb7f0d530) not located in a known VMA region
> (needed writable region)!
> SegvReason: writing unknown VMA
> Signal: 11
> SourcePackage: usplash
> StacktraceTop:
> memset_var () from /lib/libusplash.so.0
> bogl_tcfb_clear () from /lib/libusplash.so.0
> usplash_bogl_clear () from /lib/libusplash.so.0
> usplash_clear () from /lib/libusplash.so.0
> clear_text () from /lib/libusplash.so.0
> Tags: ubuntu-unr
> Title: usplash crashed with SIGSEGV in memset_var()
> Uname: Linux 2.6.31-3-generic i686
> UserGroups:
>
> UsplashConf:
> # Usplash configuration file
> # These parameters will only apply after running update-initramfs.
>
> xres=1024
> yres=600
> dmi.bios.date: 08/30/07
> dmi.bios.vendor: Phoenix Technologies LTD
> dmi.bios.version: NAPA0001.86C.0000.D.0708301817
> dmi.board.name: S37
> dmi.board.vendor: INVENTEC
> dmi.board.version: Not Applicable
> dmi.chassis.asset.tag: No Asset Tag
> dmi.chassis.type: 1
> dmi.chassis.vendor: No Enclosure
> dmi.chassis.version: N/A
> dmi.modalias:
> dmi:bvnPhoenixTechnologiesLTD:bvrNAPA0001.86C.0000.D.0708301817:bd08/30/07:svnKOHJINSHACO.,LTD.:pnSHseries:pvrNotApplicable:rvnINVENTEC:rnS37:rvrNotApplicable:cvnNoEnclosure:ct1:cvrN/A:
> dmi.product.name: SH series
> dmi.product.version: Not Applicable
> dmi.sys.vendor: KOHJINSHA CO.,LTD.
>

tags: added: iso-testing
nabilalk (nabilalk) wrote :

How do I install this fix?

https://launchpad.net/ubuntu/karmic/+source/usplash/0.5.33

Ubuntu noob here. Thanks. I'm on Karmic 9.10

To post a comment you must log in.