[hardy] splash screen disappears after a few seconds

Bug #205990 reported by ktulu77 on 2008-03-24
140
This bug affects 11 people
Affects Status Importance Assigned to Milestone
usplash (Ubuntu)
Medium
Unassigned
Nominated for Intrepid by Jeffery Davis

Bug Description

Binary package hint: usplash

I'm using Kubuntu 8.04 64bit.

The splash screen "KUBNTU" disappears when It is writed "Reading files needed to boot".
Perhaps it is because I'm using ReiserFS ?

Update:

This is sometime caused by different values in /etc/initramfs-tools/conf.d/resume and the real UUID of the swap partition given by "sudo blkid"

Actual Solution :

1. Make sure you have the initramfs-tools update
2. sudo blkid
3. Check that swap line UUID from /etc/fstab matches swap UUID from step 2, if not change fstab.
4. Check that the UUID in /etc/initramfs-tools/conf.d/resume matches the swap UUID from step 2, if not change resume file.
5. sudo update-initramfs -u
6. Restart

Saivann Carignan (oxmosys) wrote :

Thanks for your bug report. Can you describe your issue with more details? Example :

Does your computer boot correctly or it stops booting at "reading files needed to boot"?
Do you get any error messages?
Does this happen with only one computer?

Changed in usplash:
assignee: nobody → saivann
status: New → Incomplete

No I have not any messages error, it starts up correcty all is fine.
It is just that the splash disappear. I cannot test on other computer sorry.

2008/3/26, Saïvann Carignan <email address hidden>:
>
> Thanks for your bug report. Can you describe your issue with more
> details? Example :
>
> Does your computer boot correctly or it stops booting at "reading files
> needed to boot"?
> Do you get any error messages?
> Does this happen with only one computer?
>
> ** Changed in: usplash (Ubuntu)
> Assignee: (unassigned) => Saïvann Carignan (saivann)
> Status: New => Incomplete
>
>
> --
> splash sreeen disappear
> https://bugs.launchpad.net/bugs/205990
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Thanks for your fast answer. That sounds strange, perhaps can your attach the files created in your home folder when you copy these commands in a terminal?

dmesg > ~/dmesg.log
uname -a > ~/uname.log
lspci -nnvv > ~/lspci.log
cat /etc/usplash.conf > ~/usplash.conf
cat /boot/grub/menu.lst > ~/menu.lst

ktulu77 (ktulu-highwaytoacdc) wrote :

Here they are !
I remember know that at one moment it says that a filesystem is mounted readonly, but there is a lot of messages before this one so I don't think it is the problem.

Saivann Carignan (oxmosys) wrote :

Thanks for providing these informations. I suspect that this bug has something to do with ubuntu kernel so I add this bug in linux to get comments from linux bug triager. Also, I suggest that you install all updates, there are recent updates that fix issues with recent nvidia cards and amd64. If you find more informations about that particular issue or that the problem disappear after the installation of some update, please keep the bug report updated. I attach all your log files separately to help bug triager. Thanks!

Changed in usplash:
assignee: saivann → nobody
status: Incomplete → New
Saivann Carignan (oxmosys) wrote :
Saivann Carignan (oxmosys) wrote :
Saivann Carignan (oxmosys) wrote :
Saivann Carignan (oxmosys) wrote :
Saivann Carignan (oxmosys) wrote :
description: updated
description: updated

Same bug, using EXT3...

RobinJ (robinacjohnston) wrote :

Using x64 March 31 2008 daily alpha CD ISO I get the same feature on an Intel DQ965GF based system. When booting from install CD usplash works fine, but after typical install onto whole of serial HD usplash starts OK, but drops out to text when switching to progress bar with first displayed message being 'Reading files needed for boot...' By the way, it is using Intel 965 Video chipset, usplash.conf if unconfigured, no vga in menu.lst. No changes made after typical install. Wierd part it that when shutting down, it works fine. Tried it on a Dell M90 and Dell M6300 Laptop and both of these work fine. They use NVidia chipset. Happy to help with any other useful feedback/testing....

Changed in usplash:
importance: Undecided → Low
status: New → Confirmed
importance: Low → Medium
XmIsTeR (xmisterhu) wrote :

Same thing here.
Hardy beta 32bit with the latest updates.
NVIDIA Geforce 8600GTS
AMD64 X2 5600+
Usplash disappears at Reading files needed to boot.

Igor Cota (igor-cota) wrote :

It seems that usplash actually segfaults and exits with "error 6" when booting, you can see it if you remove "quiet" from your boot.lst. It's the first thing written after the splash disappears...

description: updated
XmIsTeR (xmisterhu) wrote :

I booted up with the debug kernel parameter, and now I'm attaching the logs, maybe it helps a bit.

Hi woot,

You mention when you remove the 'quiet' boot option you see that usplash segfaults. Would you be able to take a digital photo of your screen when the segfault occurs and attach it to this bug report. I'm just curious if anything else shows up that may help with the debugging.

Can anyone else boot with the "quiet" option removed and confirm they witness the segfault?

Thanks.

Changed in linux:
status: New → Incomplete
ktulu77 (ktulu-highwaytoacdc) wrote :

I have tried without quiet and splash options and I don't see any segfault ...

Igor Cota (igor-cota) wrote :

Hi Leann,

This is the photo of the two lines i get before when I boot without the "quiet" option. With "quiet", the first line is "reading files needed to boot" as desribed.

Igor Cota (igor-cota) wrote :

Correction; three lines i get before "reading files..."

Saivann Carignan (oxmosys) wrote :

w00t : Thanks for these informations! Can you try to reproduce this bug by starting usplash manually inside one tty and provide debug logs for usplash? All you need to do is to :

1. Switch to one of your ttys once the computer successfully booted.
2. Type this : sudo usplash -c -v >/tmp/usplash.log 2>&1
3. Go back to your graphical session and attach /tmp/usplash.log to that bug report (if it is not empty).

Igor Cota (igor-cota) wrote :

Hi Saïvann,

Every time I do as you've instructed, i get usplash with an empty progress bar (doing nothing) that runs for something like 10 seconds and the usplash.log is unfortuanately always empty!

Martin Polden (martin-polden) wrote :

I'm experiencing the same thing. Usplash disappears right before 'Reading files needed to boot' and I get text output instead.
Running Ubuntu 8.04 beta 32bit with the latest updates as of 06.04.2008. Also using the nvidia-glx-new driver.

Takahani (simon-esneault) wrote :

Hi,

Also experiencing this, but only on my home computer (hardy 32 bit, Athon 2000+, nvidia 4200 ti). At work (hardy 64 bit, Bi-Xeon, nvidia quadro fx 4500), no pb, with nearly exactly the same installation. I can see the two/three lines above too
I'll try reproduce the bug as you said.

Strash (strash) wrote :

Hi,

Same problem for me on my laptop : Hardy 32bits, EXT3 file system, last upgrades.

I can add that during the short part of the booting process where the usplash can be seen, the progress bar is not progressive but just displaying that the computer is working (little orange bar going from left to right).

XmIsTeR (xmisterhu) wrote :

Yep.
It's disappearing just before the progressive bar would start.

Saivann Carignan (oxmosys) wrote :

Can someone follow these instructions to get relevant debugging outputs from usplash?

1. Switch to another tty with CTRL + ALT + F6
2. Start usplash in debug mode with this command : sudo usplash -c -v >/tmp/usplash.log 2>&1
3. Wait few seconds.
4. Go back to your graphical environment and attach the /tmp/usplash.log file (if it is not empty, of course).

Takahani (simon-esneault) wrote :

This procedure gives me an empty usplash.log

Is the syntax exact exact ? I wrote this : sudo usplash -c -v >/tmp/usplash.log 2>&1 without any change

XmIsTeR (xmisterhu) wrote :

Yeah, it gives an emtpy file.
But isn't there a script file somewhere, what we can edit to start usplash in debug mode at the boot process?

Saivann Carignan (oxmosys) wrote :

The command was exact, thanks for trying, apparently that it launches successfully outside of the boot process..

XmIsTeR : Would be very interesting, I don't know about this..

Leszek (bigl-aff) wrote :

Usplash diappears after few seconds also for me - ATI Radeon 9550 card, Hardy beta 32bit desktop with all updates. It was working perfectly in Gutsy. When I try "sudo usplash -c -v >/tmp/usplash.log 2>&1" on console after booting it ends after about 15 seconds and leaves my on tty8 but it was started from tty1.

michaelobst (m-obst) wrote :

I have the same problem on inspiron 6000 notebook with integrated intel graphics. Curiously when I ran one of the older kernels there was no problem, 2.6.24-13 I think but then I did an update initramfs and they were all broken again.

wieman01 (wieman01) wrote :

Same problem here. I am on Kubuntu Hardy Beta. Got a GeForce FX 5900XT, kernel 2.6.24-15-generic. Boot splash would not come up, I can change resolution just fine, but no splash at all.

Anything I can provide?

Whoopie (whoopie79) wrote :

Thanks to Scott James Remnant's patience on IRC, I was able to collect a backtrace.

His statements:
<Keybuk> "usplash segfault in bogl_tcfb_put" and attach the trace
<Keybuk> it looks to me like it's gone out of the bounds of the framebuffer

Definitely not a kernel bug.

Changed in linux:
status: Incomplete → Invalid
Whoopie (whoopie79) wrote :

ok, some more infos requested by Scott:

My notebook is a ThinkPad R52 with a Mobility Radeon X300 graphics card. I'm running on i386 with the 2.6.24-16-generic kernel and a framebuffer console (vga=791).
But the segfault also happens without framebuffer console.

Please find attached the output of:
update-alternatives --display usplash-artwork.so
dpkg-query -W usplash usplash-theme-ubuntu
cat /etc/usplash.conf

Changed in usplash:
status: Confirmed → Triaged
wieman01 (wieman01) wrote :

A solution was posted here... worked for me:

http://ubuntuforums.org/showthread.php?t=746132

Basically what you do is:

1. Make sure you have the initramfs-tools update
2. sudo blkid
3. Check that swap line UUID from /etc/fstab matches swap UUID from step 2, if not change fstab.
4. Check that the UUID in /etc/initramfs-tools/conf.d/resume matches the swap UUID from step 2, if not change resume file.
5. Restart

Thanks to analystscouch for this.

Saivann Carignan (oxmosys) wrote :

Can someone test the solution of wieman01?

wieman01 (wieman01) wrote :

Sorry, my previous post was incomplete. Here we go again:

Basically what you do is:

1. Make sure you have the initramfs-tools update
2. sudo blkid
3. Check that swap line UUID from /etc/fstab matches swap UUID from step 2, if not change fstab.
4. Check that the UUID in /etc/initramfs-tools/conf.d/resume matches the swap UUID from step 2, if not change resume file.
5. Restart
6. sudo update-initramfs -u

Thanks to analystscouch for this.

wieman01 (wieman01) wrote :

Oh, man, how embarrassing... got the sequence wrong this time and I don't know how to edit my posts... Feel free to remove the previous ones:

http://ubuntuforums.org/showthread.php?t=746132

Basically what you do is:

1. Make sure you have the initramfs-tools update
2. sudo blkid
3. Check that swap line UUID from /etc/fstab matches swap UUID from step 2, if not change fstab.
4. Check that the UUID in /etc/initramfs-tools/conf.d/resume matches the swap UUID from step 2, if not change resume file.
5. sudo update-initramfs -u
6. Restart

Thanks to analystscouch for this.

Mathijs Dumon (zandmathijsje) wrote :

I've tested this solution and it solved all my problems!

Thanks wieman01 for bringing this to our attention!

greetz,
Mathijs

Changed in linux:
status: Invalid → New
description: updated
Changed in initramfs-tools:
importance: Undecided → Medium
status: New → Triaged
description: updated
44 comments hidden view all 124 comments
Joachim R. (jro) wrote :

caljohnsmith, yeah I did sudo "update-initramfs -u". I know the usual commands to run when the UUID of swap changed.
As my suspend to ram / hibernate functions are not working, I'll try uswsusp. Strange it is not included in the Ubuntu normal install...

Joachim R. (jro) wrote :

I have just installed uswsusp and its conf file is OK. Now S3 (suspend to ram) is OK, but after another "update-initramfs -u", the splash is still interrupted by text (kernel 2.6.24-19 now).
I don't know if hibernation will work as the "image size" given in uswsusp.conf = swap space - actual ram equals = 5.8 - 4 = 1.8Go
I think to have a correct hibernation, I'll need a 2x4Go swap, but I don't know what to do whith the interrupted splash (except removing quiet option)

caljohnsmith (cal-john-smith) wrote :

Syrion: You may also want to try installing a previous version of the kernel and give it a try. I had some serious issues with the 2.6.24-19 kernel on my machine for some reason, but going back to the 2.6.24-16 fixed some of my problems. Just an idea.

Joachim R. (jro) wrote :

caljohnsmith : nope, I have the problem with each kernel since 2.6.24-16 ...

Salik Rafiq (chameeyass) wrote :

I have this problem too. I am using Hardy 8.04 - 2.6.24-19 (it also happened in -16). UUID all match fine.
BUT I have edited init to add sleep 10 in premount and mount stages. Since I did that the splash disappears
when "Reading files needed to boot".

I suspect a problem with the image created by update-initramfs and not with usplash...though I'm not and expert and perhaps a signal is sent to usplash to kill it.

I can't find anything in my logs about it however. Will hunt around and see what I can find.

Thomas McKay (tom-mckay1) wrote :

wieman01's solution worked for me.

Thank you to everybody working to make ubuntu better!

Cristian Klein (cristiklein) wrote :

Thanks. Also works with Ubuntu Hardy 8.04 i386.

Photon (michael-kogan) wrote :

Thanks, also had this problem on 8.04 x64 and the solution has worked.

Olivier Cortès (olive) wrote :

Hi,

I confirm that this bug can occur on latest Intrepid.
I resized my swap, and obviously it changed its UUID. I didn't think I had to update anything more than fstab…
But I came across the same problem as in this bug : usplash quits just before “reading files needed to boot” message appears on text console.
Using the suggested workaround/fix (blkid → fstab/resume files → rebuild initramfs → reboot) works great and totally solves my problem. USPLASH IS BACK ! YAY !!

But it seems usplash is not hardened on latest intrepid than on hardy, regarding to this swap UUID problem.

I think that /etc/…/resume should be kept empty (or non-existent) if there is only one swap device referenced in fstab, and the one from fstab should be taken if “resume” file is empty or non-existent.

… when redondant/duplicate configuration data leads to problems…

regards,

shafin (mahdee-jameel) wrote :

I'm also having this problem in intrepid. I migrated my HDD to a new one, and changed the swap partition size, now, my new swap partition is not even loaded at startup. And running blkid gives me no uuid for my new swap partition, it says /dev/sda7: TYPE="swap" and nothing more.

Ezra Morris (ezramorris) wrote :

@shafin:
have you tried re-formatting your swap partition?

Alex Maguran (amaguran) wrote :

The "splash" problem showed up after I have switched the swap from a partition to a file. I have tried updating fstab and resume using the UUID associated to the swap file.
Then, I have cleared resume file, but still, the problem was not fixed.

Do you have other suggestions?
Thanks.

Ezra Morris (ezramorris) wrote :

@Alex:
Is it possible that usplash attempts to load before any partitions are mounted? In this case the file would not 'exist' when usplash tried to load.

Alex Maguran (amaguran) wrote :

@Ezra:
I don't think this is the case. If this would be true then the usplash would not be shown at all, right? The last messages displayed during the indeterminate progress indicator were:
- waiting for root file system
- waiting for resume device
This seems to take longer than in the past. Each message is displayed between 5 and 8 seconds. Then, the usplash is "replaced" by the "text mode". It continues with "Reading files needed to boot...".

I have attached "my" files corresponding to the commands listed by Saivann.

Thanks.

Ezra Morris (ezramorris) wrote :

@Alex:
Isn't this the same case when the resume and fstab files are wrong? Unless I'm mistaken, even when you change your RAM to a different partition, (ie. when it can't find it from resume and fstab), the pulsating bar still shows up, but then disappears for the (what would have been) sequential stage.

Ezra Morris (ezramorris) wrote :

@Alex:
Yes, I have checked.
Basically, usplash loads fine (pulsating), but the problem occurs when the system is looking for a 'system resume file'. It cannot find the partition listed in fstab and resume, therefore cannot check for a 'resume file', and drops to a terminal.

So, in your case, the partition holding the swap file is not yet mounted, therefore it is impossible for the system to look for a 'resume file' inside the swap file, and the same problem occurs.

Jithin Emmanuel (jithin1987) wrote :

I had this issue after I was moving my partition around. I increased the sizes of my / and swap partion after removing some of existing partition which changed UUID of swap after performing the solution mentioned my splash screen is back

loko (arph) wrote :

In my case, the fixes above don't work. This is because i have a encrypted swap with /dev/mapper/swap. The problem is, that the UUID of the swap partition is changeing every reboot. So it ist not possible to solves this problem.

because it is changeing i have in fstab: /dev/mapper/swap

But unfortunately this is not accepted by usplash, so the splash-screen goes away at "Reading files needed to boot".

I hope this will be fixed in a way, that is also considering the fact that with encrypted swap there is no static UUID possible.

Workaround for encrypted swap: Use a passphrase instead of using /dev/random as a key. Follow the above instructions.

Any downsides to this, other than slightly less security?

Alex Maguran (amaguran) wrote :

@Ezra:
Sorry for the late response. My swap file is mounted under /mnt:
...
    /mnt/3200Mb.swap none swap sw 0 0
...
Is there something I can do?
Thanks.

Ezra Morris (ezramorris) wrote :

@Alex:
As I said before:
---------------------------
So, in your case, the partition holding the swap file is not yet mounted, therefore it is impossible for the system to look for a 'resume file' inside the swap file, and the same problem occurs.
---------------------------
IE. because it can't access the swap listed in the resume file, it drops to text boot.

I would <always> advise using a separate partition for swap, anyway.

Note: when I said 'resume file' here, I meant stuff in swap holding information about resuming from hibernation, rather than /etc/*/*/resume

Alex Maguran (amaguran) wrote :

@Ezra:
Thanks for the explanation. Still, this sounds to me like a bug. Missing of resume information should be handled "gracefully" and continue normal boot - until http://brainstorm.ubuntu.com/idea/8092/ is implemented.

loko (arph) wrote :

Jeffery Davis,

except your suggested workaround, is there any progress about this bug?
Using a passphrase instead of /dev/urandom is possible but it's not an acceptable solution.
Also, what i do not understand, why /dev/mapper/swap is also not working?

I understand that if i use /dev/urandom for the swap-partition, the UUID of this partition changes at every boot.
But /dev/mapper/swap is always the same. Why disappears the progress bar, even i have /dev/mapper/swap in /etc/fstab?

loko (arph) wrote :

I just got it fixed now. I found on another website the tip that the resume-file in /etc/initramfs-tools/conf.d is not working together with encrypted swap (swap encrypted with /dev/urandom).

The author of the tip wrote: "delete or comment out (#) the "RESUME=" line. Otherwise the splash screen (usplash) will show the console while boot i.e. the splash won't show the full booting time."

So i did, and now bootsplash does not disappear anymore.

rudy (rudyfella2000) wrote :

I have experienced the same problem after resizing some partitions. The proposed fix worked for me.

Changed in usplash:
status: Triaged → Confirmed
Forest Bond (forest-bond) wrote :

My /etc/initramfs-tools/conf.d/resume contained "RESUME=/dev/sdb5", but my swap partition was /dev/sda5. I changed the file to /dev/disk/by-uuid/{correct UUID} and things are now working correctly.

Forest Bond (forest-bond) wrote :

Let me add that I am on Intrepid, to which I upgraded from Hardy. I upgraded prior to final release, though.

It might be nice if update-initramfs made some effort to correct the contents of /etc/initramfs-tools/conf.d/resume. I know that update-initramfs is probably not the ultimate cause if the incorrect value, but that would at least fix it after the fact.

Would this be a policy violation?

Melk79 (smelkus) wrote :

I also ran into this bug on Hardy and it persisted after upgrading to Intrepid. The problem began for me after an unfortunate situation caused by using ext2fs on MS Vista to access some videos from my Ubuntu ext3 partition. At some point, I think Vista either slept or hibernated which caused my ext3 partition and swap partition to be labeled read-only. After some fsck's/fixes and after swapoff and mkswap on /dev/sda5 to restore use of my Ubuntu partition, this bug started occurring. The fix offered by wieman01 through analystscouch solved this problem for me as well.

I didn't have any problems with the splash screen in Hardy but after adding new partitions and doing a fresh install of Intrepid, the splash screen disappears after the OS-selection made in the grub (I'm running Ubuntu Intrepid on /dev/sda1,
Kubuntu on /dev/sda2, have a swap-space on /dev/sda5 and WinXP on a older disc /dev/sb1).

I checked uuid's mentionned. In both cases the file /etc/initramfs-tools/conf.d/resume has the right UUID of the swap-partition (as one can see in ls -alh /dev/disk/by-uuid or cat /etc/fstab).

After "Starting up, please loading" I get a dark screen and a warning from my monitor (Out of range Vf: 86.7 Hf 46.4K).
I tried to add a vga-option after ro quiet splash, but only the option vga=769 removes the monitor-warning, but the screen
stays dark. If I set vga=794 (as it should be - my monitor has a 1280x1024 resolution), the monitor-warning pops up.

The file /etc/usplash.conf has the right settings (xres = 1280, yres = 1024). After a few seconds (splashscreen has ended?) I get the brown screen and the gnome pops up without any problems. This is very odd as with the live-cd I do get the
splash screen (even at shutting down). Dmesg does not reveal any particular problem regaring the screen-resolution
unless this sentence is an indication of the problem? : "Console: colour VGA+ 80*25". Any ideas how to get the splash screen back? (or to make it visible)

Joachim R. (jro) wrote :

I also have a correct UUID in /etc/initramfs-tools/conf.d/resume on a computer that was working perfectly with Hardy. Since Intrepid upgrade, no uspash on shutdown, no usplash on startup !

Pavol Babinčák (scrool) wrote :

When I had in /boot/grub/menu.lst for kernel resume=/dev/hda5 (where hda5 is my swap partition) usplash segfaults like described above - when it is trying to access swap partition for resume:
usplash[1104]: segfault at b768d580 ip b7ef6bb6 sp bf862e40 error 6 in libusplash.so.0[b7ed2000+28000]

Removing resume kernel parameter helped. Correct UUID value for RESUME in /etc/initramfs-tools/conf.d/resume is enough for resuming from hibernate.

usplash 0.5.25

Tim Fuchs (tim-fuchs) wrote :

I have a question about the workaround:

What do I do when I don't have a swap partition?

Ezra Morris (ezramorris) wrote :

Tim:
I *think* you clear the resume file.

Tim Fuchs (tim-fuchs) wrote :

And by clear you mean delete the file? Or clear its contents?

Right now my /etc/initramfs-tools/conf.d/resume consists only of the following line:

RESUME=UUID=01bd9fb0-8dd9-4b23-a12a-cc4feef1b300

This parition does not exist accoring to blkid:

/dev/sda1: SEC_TYPE="msdos" LABEL="DELLUTILITY" UUID="07D8-0208" TYPE="vfat"
/dev/sda2: UUID="F62CB6232CB5DEB5" LABEL="OS" TYPE="ntfs"
/dev/sda5: LABEL="MEDIADIRECT" UUID="82B9-FD10" TYPE="vfat"
/dev/sda6: UUID="e98b32ed-cc4b-4377-95a1-ac0bba254feb" TYPE="ext3"
/dev/sda7: UUID="8b05aa5d-dc7f-437e-aef5-dc8c19b7befa" SEC_TYPE="ext2" TYPE="ext3"
/dev/sda8: UUID="8b05aa5d-dc7f-437e-aef5-dc8c19b7befa" TYPE="ext3"

but it still is in my fstab:

UUID=01bd9fb0-8dd9-4b23-a12a-cc4feef1b300 none swap sw 0 0

Joel Berger (joel-a-berger) wrote :

I am having this issue as well. I prefer a swapfile, but I lose my usplash to get it.

From watching the boot process I tend to agree with Ezra that the disk is not yet mounted thus the swap cannot be found yet. However the swap does get mounted eventually because I can 'cat /proc/meminfo' and see the swap available.

My questions are, would there be any reason not to remove the swapfile from /etc/fstab and instead swapon /mnt/swap from rc.local? I know its clumsy but it might work.

Also does it matter that I call /mnt/swap from /etc/fstab rather than the UUID that gets printed during the creation as per https://help.ubuntu.com/community/SwapFaq#Example%20of%20making%20a%20swap%20file

Thanks

xq19space (tuxlux) wrote :

Thanks wieman01....your posting #39 saved me.

I cleaned my swap file using "Secure-Delete". After I rebooted I had no splash.

Your solution works:

1. Make sure you have the initramfs-tools update
2. sudo blkid
3. Check that swap line UUID from /etc/fstab matches swap UUID from step 2, if not change fstab.
4. Check that the UUID in /etc/initramfs-tools/conf.d/resume matches the swap UUID from step 2, if not change resume file.
5. sudo update-initramfs -u
6. Restart

LCID Fire (lcid-fire) wrote :

I switched from a swap partition to a swap file.
This problem showed up and I had to remove the UUID=... entry in /etc/initramfs-tools/conf.d/resume and run
sudo update-initramfs -u -k all
as described before.

I had a RESUME=/dev/... in /etc/initramfs-tools/conf.d/resume
Changing it to RESUME=UUID=.... and running 'update-initramfs -u' fixed it.

It would help if, both during boot and update-initramfs rungs, a message was printed when theRESUME= line seems to be incorrect (wrong UUID or device name instead of UUID).

armag.info (fatal) wrote :

Actual Solution :

1. Make sure you have the initramfs-tools update
2. sudo blkid
3. Check that swap line UUID from /etc/fstab matches swap UUID from step 2, if not change fstab.
4. Check that the UUID in /etc/initramfs-tools/conf.d/resume matches the swap UUID from step 2, if not change resume file.
5. sudo update-initramfs -u
6. Restart

THIS WORKS!!!

I just copied my entire disk to another, bigger one with dd utility. Of cource I had all UUID messed up. And my bootscreen showed me the process instead of usplash. Thanks a lot!

Phillip Susi (psusi) wrote :

The usplash package has been superseded by plymouth and has been removed from the Ubuntu archive. Closing all related bugs.

Changed in usplash (Ubuntu):
status: Confirmed → Invalid
Phillip Susi (psusi) on 2011-12-15
no longer affects: initramfs-tools (Ubuntu)
Displaying first 40 and last 40 comments. View all 124 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers