Gutsy splash video mode wrong

Bug #164587 reported by jerrylamos on 2007-11-22
4
Affects Status Importance Assigned to Milestone
usplash (Ubuntu)
Undecided
Unassigned

Bug Description

Gutsy release level splash evidently is hard coded to 1280x1024 screen resolution.
This system can display max 1024x768. That has worked fine with Dapper, Edgy, Feisty, and several Gutsy tribes - only the release level has this bug.

From some hints on Ubuntu Forums: "Gutsy install Out of range video when bootup" I saw that /etc/splash.conf was set to 1280x1024. That won't work on my LCD screen. Changing the entries to 1024x768 fixed the shutdown splash screen, but the bootup video mode is still wrong.

There's a further suggestion to add " vga=791" to the kernel line in /boot/grub/menu.lst. I'll give that a try.

Both these involve editing system files with attendant exposure to screwing up the system, and I wouldn't recommend the beginner, newbie, or anyone not familiar with command line to do.

Is there any possibility of changing the splash video mode back to the way it was on Dapper, Edgy, Feisty, early Gutsy? Wouldn't that just be an "update"? We seem to get updates every day or two.
Thank you, Jerry

jerrylamos (jerrylamos) wrote :

Nope, adding " vga=791" didn't work. Note this monitor is max 60 Hz. What does Splash use? It's not in /etc/usplash.conf

I can supply any dmesg or log or lspvvi (however that is spelled) or try any suggestions I can figure out how to test.

Thank you, Jerry

jerrylamos (jerrylamos) wrote :

From the Ubuntu Hardy forum: Are they EVER going to fix all the splash screen problems?
change /etc/usplash.conf to
xres=1024
yres=768
then run
sudo dpkg-reconfigure usplash
which worked for me, but not others.
I rather don't think the user new to Ubuntu is going to find that solution, or for that matter be comfortable with root command line.....

Jerry

jerrylamos (jerrylamos) wrote :

Hardy Alpha 1 20071128 has the same problem, "can't display this video mode" because splash is trying to display 1280x1024 on a monitor that will do 1024x768 max. Note Hardy CD Live splash works fine. The workaround of changing usplash.conf and dpkg-reconfigure in the previous post worked.
Jerry

SK (stephantom) wrote :

Confirmed on Gutsy final and Hardy. After issuing a dkpg-reconfigure command, the shutdown screen displays correctly. The startup screen still uses a 4:3 ratio of resolution (my display as a 16:10 ratio).

der_vegi (m-may) wrote :

Same here on Hardy daily-live 20071211. While booting, my computer shows a black screen, after starting X it works. Also I noticed, that display tty1-6 works while booting.

Saivann Carignan (oxmosys) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 150930, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers