Ubuntu

usplash crashed with SIGSEGV in __svgalib_get_perm() [ioperm/in issue]

Reported by Sebastien Vajda on 2007-09-25
534
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Medium
Kees Cook
usplash (Ubuntu)
Medium
Kees Cook

Bug Description

LATEST VERSION TESTED:
0.5.16

Binary package hint: usplash

did a aptitude upgrade yesterday and rebooted only now. nothing else to mention.

ProblemType: Crash
Architecture: amd64
Date: Tue Sep 25 11:28:06 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /sbin/usplash
NonfreeKernelModules: nvidia
Package: usplash 0.5.5
PackageArchitecture: amd64
ProcCmdline: /sbin/usplash -c -x 1024 -y 768
ProcCwd: /dev/.initramfs
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=/sbin:/bin:/usr/sbin:/usr/bin
 LANG=en_US.UTF-8
Signal: 11
SourcePackage: usplash
StacktraceTop:
 __svgalib_get_perm () from /lib/libusplash.so.0
 vga_setchipset () from /lib/libusplash.so.0
 usplash_svga_init () from /lib/libusplash.so.0
 usplash_init () from /lib/libusplash.so.0
 usplash_setup () from /lib/libusplash.so.0
Title: usplash crashed with SIGSEGV in __svgalib_get_perm()
Uname: Linux blackstone 2.6.22-12-rt #1 SMP PREEMPT RT Sun Sep 23 21:11:52 GMT 2007 x86_64 GNU/Linux
UserGroups:

Sebastien Vajda (sebvajda) wrote :

StacktraceTop:__svgalib_get_perm () at /build/buildd/usplash-0.5.5/svgalib/src/libvga.h:294
vga_setchipset (c=19) at /build/buildd/usplash-0.5.5/svgalib/src/vga.c:1569
usplash_svga_init () at usplash_svga.c:139
usplash_init () at libusplash.c:193
usplash_setup (xres=1024, yres=768, v=0) at libusplash.c:476

Changed in usplash:
importance: Undecided → Medium
Kees Cook (kees) on 2008-03-08
Changed in usplash:
assignee: nobody → desktop-bugs
status: New → Confirmed
Kees Cook (kees) on 2008-03-08
description: updated
description: updated
description: updated
Jamie Strandboge (jdstrand) wrote :

Confirmed that it still crashes with usplash 0.5.16.

Jamie Strandboge (jdstrand) wrote :

I rebooted with the old -11 kernel and then again with the new -12 kernel, and this time no crash. I thought it might have had something to do with when I logged in, so I tried again and logged in as soon as gdm popped up, and still no crash. Seems the problem is intermittent.

Jamie Strandboge (jdstrand) wrote :

Just finished upgrading to latest hardy and rebooted and it crashed again.

Savvas Radevic (medigeek) wrote :

we know Jamie:
$ apt-cache policy usplash
  Installed: 0.5.16
  Candidate: 0.5.16

It's noted on the bug description, and we're awaiting a dev to take care of it :)

Kees Cook (kees) wrote :

I've added a kernel task because this appears to be a problem somewhere between ioperm() and inb(). This is the only way that I know of that an "in" can segfault. In fact, I was able to reproduce the issue with the attached program. It would always segv. However, after a reboot, the behavior went away (same kernel). Something somewhere is very odd. :)

Kees Cook (kees) wrote :

This reproducer shows a SEGV for me after I start a kvm VM.

Changed in linux:
status: Unknown → Confirmed
Kees Cook (kees) wrote :
Changed in linux:
milestone: none → ubuntu-8.04
status: New → Triaged
Changed in usplash:
assignee: desktop-bugs → keescook
status: Confirmed → Invalid
Changed in linux:
status: Confirmed → In Progress
Steve Langasek (vorlon) on 2008-03-25
Changed in linux:
importance: Undecided → Medium
Kees Cook (kees) on 2008-03-25
Changed in linux:
assignee: nobody → keescook
status: Triaged → Fix Committed
jayp (jayp-free) wrote :

apparently I have the same problem. I have the progress bar appear during the boot, but about 5 sec after the desktop appears, usplash just crash don't know why since I haven't started any other program manually yet at that time.

Changed in linux:
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.24-13.23

---------------
linux (2.6.24-13.23) hardy; urgency=low

  [Alessio Igor Bogani]

  * rt: Updated configuration files

  [Ben Collins]

  * openvz: New custom flavour for OpenVZ
  * config: Disable IDE AMD driver in favor of PATA version
    - LP: #181561
  * config: Disable IDE VIA driver in favor of PATA version
    - LP: #181561
  * drivers/video: Restore gutsy backlight dimming behavior
    - LP: #205261
  * build/config: Enable CONFIG_CIFS_WEAK_PW_HASH
    - LP: #202445

  [Colin Ian King]

  * SAUCE: Add support for version 4 of Chelsio NICs in cxgb3 driver
    - LP: #201893

  [Kees Cook]

  * AppArmor: re-add missing "type" field in syslog reports.
    - LP: #202888
  * kvm: reset TSS on x86_64 to avoid ioperm bitmap corruption
    - LP: #144900

  [Stefan Bader]

  * USB: EHCI: add separate IAA watchdog timer
    - LP: #198619
  * SAUCE: Always use SCO protocol (disable eSCO support)
    - LP: #39414
  * PM: Introduce PM_EVENT_HIBERNATE callback state
    - LP: #201086

  [Tim Gardner]

  * Disable DRM suspend/resume on pre-915 Intel chips
    - LP: #207496
  * frame buffer regression - screen blank except for blinking cursor after fbcon
    vtswitch
    - LP: #201591

 -- Tim Gardner <email address hidden> Wed, 19 Mar 2008 10:05:05 -0400

Changed in linux:
status: Fix Committed → Fix Released
Savvas Radevic (medigeek) wrote :

I think this is connected to bug 203299
I'm still facing that problem, usplash crashing on shutdown

Should I mark it as confirmed again?

Changed in linux:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.