usb_modeswitch_dispatcher crashed with SIGSEGV in __strlen_ia32()

Bug #1155975 reported by Juraj on 2013-03-16
170
This bug affects 37 people
Affects Status Importance Assigned to Milestone
usb-modeswitch (Ubuntu)
Medium
Unassigned

Bug Description

usb_modeswitch_[2088]: segfault at 0 ip b758b6f1 sp bfdb7fcc error 4 in libc-2.17.so[b750d000+1ad000]

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: usb-modeswitch 1.2.3+repack0-1ubuntu3
ProcVersionSignature: Ubuntu 3.8.0-12.21-generic 3.8.2
Uname: Linux 3.8.0-12-generic i686
ApportVersion: 2.9.1-0ubuntu1
Architecture: i386
Date: Sat Mar 16 16:29:20 2013
ExecutablePath: /usr/sbin/usb_modeswitch_dispatcher
InstallationDate: Installed on 2013-03-15 (0 days ago)
InstallationMedia: Ubuntu-GNOME 13.04 "Raring Ringtail" - Alpha i386 (20130313)
MarkForUpload: True
ProcCmdline: usb_modeswitch_dispatcher --switch-mode /7-1:1.0 /lib/udev/usb_modeswitch
ProcEnviron:

SegvAnalysis:
 Segfault happened at: 0xb758b6f1: mov (%eax),%ecx
 PC (0xb758b6f1) ok
 source "(%eax)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%ecx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: usb-modeswitch
StacktraceTop:
 ?? () from /lib/i386-linux-gnu/libc.so.6
 strdup () from /lib/i386-linux-gnu/libc.so.6
 ?? ()
 ?? ()
 __libc_start_main () from /lib/i386-linux-gnu/libc.so.6
Title: usb_modeswitch_dispatcher crashed with SIGSEGV in strdup()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Juraj (juraj-hrcka) wrote :
Juraj (juraj-hrcka) wrote :

lsusb:
Bus 007 Device 003: ID 05c6:0015 Qualcomm, Inc.

Juraj (juraj-hrcka) wrote :

usb_modeswitch_[1816]: segfault at 0 ip b75cc6f1 sp bfc92d4c error 4 in libc-2.17.so[b754e000+1ad000]

The same on Lubuntu

Juraj (juraj-hrcka) on 2013-03-18
information type: Private → Public

StacktraceTop:
 __strlen_ia32 () at ../sysdeps/i386/i686/multiarch/../../i586/strlen.S:98
 __GI___strdup (s=0x0) at strdup.c:41
 ?? ()
 ?? ()
 __libc_start_main (main=0x8049120, argc=4, ubp_av=0xbfdbb234, init=0x804dda0, fini=0x804de10, rtld_fini=0xb76f1600 <_dl_fini>, stack_end=0xbfdbb22c) at libc-start.c:260

Changed in usb-modeswitch (Ubuntu):
importance: Undecided → Medium
summary: - usb_modeswitch_dispatcher crashed with SIGSEGV in strdup()
+ usb_modeswitch_dispatcher crashed with SIGSEGV in __strlen_ia32()
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in usb-modeswitch (Ubuntu):
status: New → Confirmed
Juraj (juraj-hrcka) wrote :

Just installed fresh 13.04 32bit release. The same error occured..

Huzaeni (julungpujut) wrote :

i have same problem, on fresh install 13.04... can't connect with usb modem.

Andrei Lisin (terranium) wrote :

The dispatcher expects PATH environment variable and fails at strdup(getenv("PATH")); because usb_modeswitch script doesn't export PATH variable:

PATH=/sbin:/usr/sbin:$PATH

should be

export PATH=/sbin:/usr/sbin:$PATH

for the variable to appear in the environment

Artyom Kazak (artyom-kazak) wrote :

Still remains on 13.10.

Pasha Orekhov (orehovpasha) wrote :

Problem is in DNA. See bug 927954.

next problem:
dev_top[strlen(dev_top)] = '\0';

Pasha Orekhov (orehovpasha) wrote :
Pasha Orekhov (orehovpasha) wrote :

patch2 fixes
dev_top[strlen(dev_top)] = '\0';

The attachment "usb_modeswitch_dispatcher.c.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usb-modeswitch - 2.1.1+repack0-1ubuntu1

---------------
usb-modeswitch (2.1.1+repack0-1ubuntu1) trusty; urgency=medium

  * Merge with Debian unstable; remaining changes: (LP: #1280546)
    - patch to rewrite dispatcher to C.
    - debian/patches/redirect_dispatcher_output.patch: redirect all dispatcher
      output when called from udev to /dev/null.
    - Replace libjim depends with libpipeline-dev, libudev-dev.
  * Fixed some bugs in dispatcher rewrite. (LP: #1155975)
 -- Mathieu Trudel-Lapierre <email address hidden> Mon, 07 Apr 2014 11:39:41 -0400

Changed in usb-modeswitch (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers