Maverick images burned to usb key on lucid fail to boot - different syslinux version

Bug #608382 reported by Francesco Brozzu
442
This bug affects 88 people
Affects Status Importance Assigned to Milestone
syslinux (Ubuntu)
Low
Unassigned
Hardy
Undecided
Unassigned
Karmic
Undecided
Unassigned
Lucid
Low
Unassigned
usb-creator (Ubuntu)
High
Evan
Hardy
High
Unassigned
Karmic
High
Unassigned
Lucid
High
Unassigned

Bug Description

Impact: Users attempting to burn a Maverick (Ubuntu 10.10) or newer Ubuntu version that uses an updated version of syslinux is successful, however it fails to boot.

Addressing: The fix is committed to usb-creator trunk
Instructions to Reproduce: Attempt to burn a 10.10 image from a 10.04 box to a USB stick. Boot off this USB stick.
Regression Potential: This codepath is only ran if the Ubuntu version being burned differs from the version of Ubuntu on the box.

Alberto Russo (valix)
tags: added: iso-testing maverick
Revision history for this message
Francesco Brozzu (francescobrozzu) wrote :
description: updated
Revision history for this message
Mario Limonciello (superm1) wrote :

Just to be clear, this image was burned to the USB key using an older version of usb-creator and syslinux than that in Maverick, correct? Can you please specify the details of those versions?

Revision history for this message
Francesco Brozzu (francescobrozzu) wrote :

Ok here there are the versions

usb-creator-gtk (on my computer) : 0.2.22
syslinux(on the release and on my computer): 3.63

Revision history for this message
Alberto Russo (valix) wrote :

I confirm this bug in xubuntu daily-live build (20100721).

Revision history for this message
Daniel Che (danielche9) wrote :

I confirm this bug.
The problem is in the file /isolinux/isolinux.cfg of the iso image, "ui" is the unknown keyword, which does not exists in /isolinux/. When a bootable usb is created, the file /syslinux/syslinux.cfg has the same problem.

I edited the file /syslinux/syslinux.cfg removing the "ui" keyword, i tried boot up again the bootable usb, and now it boots up successfully.
Try do this! worked fine for me.

Can someone fix this in the source please!

Thanks.

Revision history for this message
Riccardo Angelino (riccardoangelino) wrote :

Also I have this problem

Revision history for this message
Fabio Marconi (fabiomarconi) wrote :

I confirm the issue and the workaround (remove UI in syslinux.cfg).
I change status to Confirmed

Changed in syslinux (Ubuntu):
status: New → Confirmed
Revision history for this message
Fabio Marconi (fabiomarconi) wrote :

I confirm this bug and the workaround.

Workaround: delete UI in syslinux.cfg

Also afflict Lucid's package

tags: added: apport-collected
Revision history for this message
Fabio Marconi (fabiomarconi) wrote : apport information

Architecture: amd64
CheckboxSubmission: 24bfda22985f9f37974801ac35af0af3
CheckboxSystem: 4ed15c40009aa6f7770f606350a390a2
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
Package: syslinux 2:3.63+dfsg-2ubuntu3
PackageArchitecture: amd64
ProcEnviron:
 LANG=it_IT.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-23.37-generic 2.6.32.15+drm33.5
Tags: lucid
Uname: Linux 2.6.32-23-generic x86_64
UserGroups: adm admin cdrom dialout disk libvirtd lpadmin plugdev sambashare

Revision history for this message
Fabio Marconi (fabiomarconi) wrote : Dependencies.txt

apport information

Revision history for this message
Fabio Marconi (fabiomarconi) wrote : apport information

Architecture: amd64
CheckboxSubmission: 24bfda22985f9f37974801ac35af0af3
CheckboxSystem: 4ed15c40009aa6f7770f606350a390a2
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
Package: usb-creator (not installed)
ProcEnviron:
 LANG=it_IT.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-23.37-generic 2.6.32.15+drm33.5
Tags: lucid
Uname: Linux 2.6.32-23-generic x86_64
UserGroups: adm admin cdrom dialout disk libvirtd lpadmin plugdev sambashare

Revision history for this message
Fabio Marconi (fabiomarconi) wrote : UsbCreatorLog.txt

apport information

Revision history for this message
Fabio Marconi (fabiomarconi) wrote : UsbDevices.txt

apport information

Revision history for this message
Riccardo Angelino (riccardoangelino) wrote : Re: Error: Unkown keyword in configuration file

I confirm this bug also in Kubuntu daily-live (20100725)

tags: added: tool
removed: maverick
Revision history for this message
Riccardo Angelino (riccardoangelino) wrote :

Yes, also I confirm the removal "UI" in syslinux.cfg

Revision history for this message
Fabio Marconi (fabiomarconi) wrote :

This problem is fixed in the new maverick's packages (syslinux syslinux-common) 2:4.01+dfsg-3ubuntu1.

Revision history for this message
Fabio Marconi (fabiomarconi) wrote :

This bug still present in Lucid

Changed in syslinux (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Revision history for this message
Andy Whitcroft (apw) wrote :

It is looking like this is an issue triggered by usb-creator. It seems to be supplying the syslinux version from the host onto the stick instead of using the one in the image. Confirmed that making real maverick CDs on a lucid system boot correctly. The image has version 4.01 in it.

summary: - Error: Unkown keyword in configuration file
+ USB images of Maverick CDs fail to boot with -- Error: Unkown keyword in
+ configuration file
Andy Whitcroft (apw)
Changed in usb-creator (Ubuntu):
importance: Undecided → High
Revision history for this message
Andy Whitcroft (apw) wrote : Re: USB images of Maverick CDs fail to boot with -- Error: Unkown keyword in configuration file

Ok the underlying reason here is that we need to execute the syslinux binary on local machine in order to install it, that mandates we use one we can execute. If that is not compatible with the configuration as specified on the CD for the version it uses ... breakage.

Revision history for this message
Andy Whitcroft (apw) wrote :

It seems that we can work arround this specific incompatibility between 3.63 and 4.01 vi running the following bodge over the completed image:

    sed -i -e 's/ui gfxboot/gfxboot/' /media/USBSTICK/syslinux/syslinux.cfg

Revision history for this message
Fabio Marconi (fabiomarconi) wrote :

@Andy
This seems related
https://bugs.launchpad.net/ubuntu/+source/syslinux/+bug/609786
Take a look only at the screenshot, because i run accidentally apport-collect under lucid instead of Maverick, but everythings are referred to Maverick.

Revision history for this message
Francesco Ruvolo (ruvolof) wrote :

This bug affects me, too. The workaround saved my testing session. :)

Revision history for this message
Martin Pitt (pitti) wrote :

Would it be possible for usb-creator to first extract syslinux from the target .iso, and only fall back to the local system one's if that doesn't exist?

Changed in usb-creator (Ubuntu):
status: New → Triaged
summary: - USB images of Maverick CDs fail to boot with -- Error: Unkown keyword in
- configuration file
+ Maverick images build on lucid fail to boot - different syslinux version
Changed in usb-creator (Ubuntu):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in usb-creator (Ubuntu):
assignee: Canonical Foundations Team (canonical-foundations) → Evan Dandrea (ev)
Revision history for this message
Evan (ev) wrote : Re: Maverick images build on lucid fail to boot - different syslinux version

Extracting it from the ISO wont work because we'd then have to deal with mounting squashfs on differing kernels. As Mario suggested on IRC, try mounting a Maverick squashfs on a Hardy kernel.

I talked this over with Colin yesterday and the best course of action for now is to check for maverick vs lucid and write an appropriate configuration file. Do note that the eventual switch to grub2 for the CDs (or isohybrid, for that matter) will fix this.

Revision history for this message
Andrew Sam (mailandrewsam) wrote :

After this workaround, i keep getting the "boot error".. nothing else on my desktop. but in my laptop, it boots without any trouble. any suggestions why that might be the case. I've tried erasing the disc several times, but I come to the same thing.

Revision history for this message
Adal Alom Rodríguez (arpia49) wrote :

Same as #25

My laptop is running maverick and my desktop lucid. I don't think that could be a reason but who knows...

Revision history for this message
zob (zob) wrote :

I can verify this bug. I've tried the usb-creator in lucid and unetbootin 408-1ubuntu0.10.04.1. None of them works for me though with the usb-stick made with unetbootin I do get at litlle further. I takes me into busybox.

Revision history for this message
Sam Liddicott (sam-liddicott) wrote :

I think the problem would go away if usbcreator booted from a loop-back ISO image on the memory stick.

isolinux and syslinux are pretty well merged; syslinux it ought to be able to boot an iso image - as long as the initrd could continue and mount the iso-image...

Revision history for this message
Fabián Rodríguez (magicfab) wrote :

I had the same issue today, testing a Maverick 64bit Desktop edition ISO. The workaround in #20 worked for me.

Revision history for this message
Matt Spiers (mylogic) wrote :

There is a very simple work-around for this.

When you are prompted with "boot:" simply type "help" and press enter. Once the help options come up, simple hit enter and the install should begin.

Revision history for this message
Jeff Stone (stone1343) wrote :

technically, you don't even need to hit enter the second time (when the help options come up)

Revision history for this message
Mario Limonciello (superm1) wrote :

Here's a potential patch that will apply on both Maverick and Lucid usb-creator's. It unfortunately only fixes one manifestation of the problem (burning 10.10 or newer images on 10.04).

Burning 10.04 images on 10.10 still will not work with it.

summary: - Maverick images build on lucid fail to boot - different syslinux version
+ Maverick images burned to usb key on lucid fail to boot - different
+ syslinux version
Changed in syslinux (Ubuntu Lucid):
status: New → Triaged
importance: Undecided → Low
Changed in usb-creator (Ubuntu Lucid):
importance: Undecided → High
status: New → Triaged
Revision history for this message
Scott Kitterman (kitterman) wrote :

I built an updated usb-creator for Lucid in my PPA with Mario's patch added. I can confirm I can now make a working usb image and I could not before.

Revision history for this message
Mario Limonciello (superm1) wrote :

Evan committed this to trunk for maverick and i'm assuming will be uploaded after beta. I've also uploaded it to lucid-proposed and subscribed ubuntu-sru.

Changed in syslinux (Ubuntu):
status: Triaged → Won't Fix
Changed in usb-creator (Ubuntu Lucid):
status: Triaged → Fix Committed
Changed in syslinux (Ubuntu Lucid):
status: Triaged → Won't Fix
Changed in usb-creator (Ubuntu):
status: Triaged → New
status: New → Fix Committed
Changed in usb-creator (Ubuntu Lucid):
status: Fix Committed → New
description: updated
Revision history for this message
Colin Watson (cjwatson) wrote : Please test proposed package

Accepted usb-creator into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in usb-creator (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Revision history for this message
Luca Ferretti (elle.uca) wrote :

Created a usb live using package in proposed and maverick daily (30/09). It works now.

tags: added: verification-done
removed: verification-needed
Revision history for this message
Scott Kitterman (kitterman) wrote :

Installed the updated packages from proposed and successfully burned a live 10.10 beta candidate ISO to usb.

Revision history for this message
Paolo Sammicheli (xdatap1) wrote :

Package from proposed worked well with 10.10 Beta candidate

x@bwing:~$ apt-cache policy usb-creator
usb-creator:
  Installato: 0.2.22.1
  Candidato: 0.2.22.1
  Tabella versione:
 *** 0.2.22.1 0
        500 http://it.archive.ubuntu.com/ubuntu/ lucid-proposed/universe Packages
        100 /var/lib/dpkg/status
     0.2.22 0
        500 http://it.archive.ubuntu.com/ubuntu/ lucid/universe Packages

Revision history for this message
Alan Bell (alanbell) wrote :

with the proposed package can you still burn 10.04 from 10.04? I will test later unless someone already has.

Revision history for this message
Vish (vish) wrote :

@Alan Bell: With usb-creator 0.2.22.1 from -proposed, i was able to create the 10.04 live usb as well.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usb-creator - 0.2.22.1

---------------
usb-creator (0.2.22.1) lucid-proposed; urgency=low

  * Mangle whether the 'ui' keyword is in syslinux.cfg based on the OS version.
    (LP: #608382)
 -- Mario Limonciello <email address hidden> Tue, 31 Aug 2010 13:51:21 -0500

Changed in usb-creator (Ubuntu Lucid):
status: Fix Committed → Fix Released
Revision history for this message
Colin Watson (cjwatson) wrote :

I'm waiving the normal seven-day aging period on this bug so that we can have a working usb-creator in Lucid in time for Maverick beta.

Revision history for this message
Nathanel Titane (nathanel.titane) wrote :

I am posting as to let you guys know that i'm running on Lucid amd64 fully updated and all my download attempts to Maverick daily and beta fail to boot when burnt on cd/dvd, and won't even be recognized bu usb-creator gtk to be loaded onto a flash/usb drive.

boot skips directly to plymouth splash after wandering around into cd/dvd/usb content without result!

HELP!!

Peng (pengwg)
Changed in usb-creator (Ubuntu Lucid):
status: Fix Released → Confirmed
status: Confirmed → Fix Released
Revision history for this message
pinzia (pinzia) wrote :

I have similar a problem on maverick 32bit.
When i create a usb-drive of maverick beta (32bit) on maverick alpha3 updated (32bit), i can't boot the system... THE SAME SYSTEM!!

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usb-creator - 0.2.24

---------------
usb-creator (0.2.24) maverick; urgency=low

  [ Mario Limonciello ]
  * Mangle whether the 'ui' keyword is in syslinux.cfg based on the OS version.
    (LP: #608382)

  [ Colin Watson ]
  * GTK frontend: don't grey out "Make Startup Disk" when the source is a
    physical CD.
  * Use python-debian for Ubuntu release version comparison.
  * Add an --allow-system-internal option (Unix only) to allow installation
    to system-internal devices such as hard disks. This is useful when
    preparing test USB images in KVM.
 -- Colin Watson <email address hidden> Tue, 07 Sep 2010 10:40:37 +0100

Changed in usb-creator (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Xvani (fredrile+launchpad) wrote :

FYI, this happens with the Windows universal USB creator too.

Revision history for this message
Alex Mayorga (alex-mayorga) wrote :

"Unkown keyword in configuration file" error also happens on Karmic.

alex-mayorga@inspiron-1501:~$ more /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=9.10
DISTRIB_CODENAME=karmic
DISTRIB_DESCRIPTION="Ubuntu 9.10"
alex-mayorga@inspiron-1501:~$ aptitude show usb-creator
Package: usb-creator
State: installed
Automatically installed: no
Version: 0.2.12
Priority: optional
Section: admin
Maintainer: Ubuntu Installer Team <email address hidden>
Uncompressed Size: 41.0k

Revision history for this message
Mikko Ohtamaa (mikko-red-innovation) wrote :

Tested maverick netbook daily (yesterday) build with Karmic and had this error. Now trying with workaround on comment #20.

Revision history for this message
mohi (mohanchml) wrote :

FYI, I am running Lucid Lynx with i386. I have the issue listing Boot Error At startup, when I assign USB as first bootable.

Revision history for this message
Jason Mitchell (jvonmitchell) wrote :

Also has a similar problem in Jaunty.

Revision history for this message
psarhjinian (psarhjinian) wrote :

Confirmed that USB drives created using the Windows "pendrive" USB creator also fail, but in a different manner: the boot process hangs at the SYSLINUX line and goes no further.

This should be fixed before release as creating a bootable USB drive will be important for getting new (Windows) users onto the platform, especially for netbook users.

Revision history for this message
Rohan Dhruva (rohandhruva) wrote :

There is a similar problem with Ubuntu 8.04. IMO as an LTS release, this problem should be fixed in 8.04 too.

Revision history for this message
Michael Wolverton (wolvee123) wrote :

I am new to Ubuntu, installed it on my Desktop and thought I would upgrade from 10.04 on my Asus 1000H. There was an error during install in which my netbook froze. After a while I was able to restart and get a menu that somehow fixed the error. I am now given several versions of 10.04, 10.10 & Xp to choose from during boot. XP will also no longer boot. I am trying to do a fresh install with a thumb-drive using 10.04 and I am getting "vesamenu.c32 not a COM32R image" when I boot.

Revision history for this message
FND (fnd) wrote :

I've tried #20's workaround (with the Maverick build from Oct 7, created on a Windows XP machine), but syslinux reported "unknown keyword in configuration file: gfxboot".

Colin Watson (cjwatson)
Changed in syslinux (Ubuntu Karmic):
status: New → Won't Fix
Changed in usb-creator (Ubuntu Karmic):
status: New → Triaged
importance: Undecided → High
Changed in syslinux (Ubuntu Hardy):
status: New → Won't Fix
Changed in usb-creator (Ubuntu Hardy):
status: New → Triaged
importance: Undecided → High
Revision history for this message
Ricardo Sansores Aguilar (rsansores) wrote :

I created an image of maverik desktop 10.10 i386 in a maverik desktop amd64 installation. When booting I got an error message unknown keyword not COM32RIMAGE. I tried to create the same 10.10 image but in a karmic i386 desktop installation with the same result. Is there a workaround to create this image correctly? I thought the problem was creating a 10.04 image from 10.10 but it seems that you can't create a 10.10 from 10.10 :(

Revision history for this message
alex.marcev@gmail.com (alex-marcev) wrote :

Same here....

I use Ubuntu 10.10 and when creating Ubunutu 10.10 images with usb creator they doesnt boot at all.
Just showing the firstline with the syslinux installation. Then nothing goes on.

I tried different version of syslinux and usb-creator. Doenst work at all.

Revision history for this message
Melvin Garcia (virtualspectre8) wrote :

Have you tried typing "help"? It will give you a list of things, then press enter.

Revision history for this message
robindegen (robindegen) wrote :

I can also confirm typing help and then pressing enter works. I just finished installing 10.10 on my netbook without any problems after this workaround.

Revision history for this message
nick (nz) wrote :

I agree with psarhjinian & maybe <email address hidden>. Suggest it's different with usb-creator.exe. I built a USB stick from 10.10 with the included usb-creator.exe on XP & when booting on a Dell Inspiron 1545 it just sits at the "SYSLINUX 3.82 ... et al" line. Note that there is no boot prompt, just a flashing cursor & it doesn't respond to the k/b (except ctrl-alt-del). Also usb-creator didn't accept an ISO image, had to mount it in Windows first. Wanted to use it to fix a problem with Windows on the laptop. Tried Fedora 13 first but that fails in a different way. No steps forward, 2 steps back. Jeebus.

Revision history for this message
speedyx (speedyx) wrote :

Ubuntu Netbook 10.10
Unity is a wonderful desktop at the first look.
But I can't install it on my netbook.
I tried to create a usb stick with unetbootin from PartedMagic 5.6 and after from Sabayon and was successful, but the install process crash near the end. Testing the disk (usb) I obtain the result that there is a file error. I tried to download again, but I have the same error.
I create the startup usb stick with the Ubuntu utility, but at boot time it say "Unknown keyword in configuration file".
I have a Fujitsu-Siemens Amilo Mini Ui 3520.

Revision history for this message
ikukumalu (huynhtruclam) wrote :

i have 2 ways.
1:/ using the "create usb startup" in Ubuntu live cd to create usb => worked.
2:/ using usb creator in iso file of old Ubuntu version. tested with 10.10 => worked

Rolf Leggewie (r0lf)
Changed in usb-creator (Ubuntu Karmic):
status: Triaged → Won't Fix
Adolfo Jayme (fitojb)
Changed in usb-creator (Ubuntu Hardy):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers