org.freedesktop.Dbus error while trying to erase USB key with Startup disk creator

Bug #1048792 reported by Carla Sella on 2012-09-10
322
This bug affects 73 people
Affects Status Importance Assigned to Milestone
usb-creator (Ubuntu)
High
Unassigned

Bug Description

While trying to erase a USB key with Startup disk creator, I get an error message saying: "org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply..." see attached screenshot.
I closed Startup disk creator and tried to repeat the action but I get another error: "org.freedesktop.UDisks.Error.Busy: There is already a job running." see attached screenshot.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: usb-creator-gtk 0.2.40ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-14.15-generic 3.5.3
Uname: Linux 3.5.0-14-generic x86_64
ApportVersion: 2.5.1-0ubuntu7
Architecture: amd64
Date: Mon Sep 10 22:03:01 2012
ExecutablePath: /usr/bin/usb-creator-gtk
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120905.2)
InterpreterPath: /usr/bin/python2.7
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: usb-creator
UpgradeStatus: No upgrade log present (probably fresh install)

Carla Sella (carla-sella) wrote :
Carla Sella (carla-sella) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in usb-creator (Ubuntu):
status: New → Confirmed
Fjodor (sune-molgaard) wrote :

I noticed what appears to be symptoms of https://bugs.launchpad.net/udisks/+bug/689593 when this happened. This bug might depend on that...

Mikhail V. Golubev (mvgolubev) wrote :

In my case this error appears only when I try to erase USB HDD (80 GB) with Startup Disk Creator (in Ubuntu 12.10).
When I try to erase USB Flash sticks (1 GB or 2 GB) with Startup Disk Creator (in Ubuntu 12.10) it's OK, no errors.

Alden Davidson (davidsonalden) wrote :

Oh, and shortly after the first error, a second error pops up, even if you already closed the startup disk creator:
"Sorry, the program "udisks-daemon" closed unexpectedly

Your computer does not have enough free memory to automatically analyze the problem and send a report to the developers."

See attached screenshot.

Daniel Cooper (d4nc00per) wrote :

I'm having the exact same problems. Seems that all 8GB of my RAM was gobbled during the bug reporting so was unable to send it.

Mikael Bergqvist (mikaelb) wrote :

Feels like the same problem:
When trying to erase an USB-stick with usb-creator-kde the following happens:

udisks-helper-m 95% CPU
udisks-daemon 85% CPU

And the message: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. shows up in a pop-up window.

Killing the daemons, removing and inserting the USB-stick, followed by manually erasing the contents makes it possible to then create the bootable usb-drive with the usb-creator-kde tool.

Timo Aaltonen (tjaalton) on 2013-04-09
Changed in usb-creator (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Daniel Hollocher (chogydan) wrote :

I ran into this issue as well but through a specific route: I just tried to select the image while it was trying to erase the disk. That somehow canceled the erasing, according to startup-disk-creator, but left it in the inconsistent state described here.

Daniel Hollocher (chogydan) wrote :

I realize that the program let's me try to select an iso while it is in the middle of erasing is probably a different bug, but fixing this should take care of that indirectly.

Janne Savikko (jsavikko) wrote :

I stumbled upon this bug when erasing USB-key with Startup Disk Creator, and found out following:

These commands consume 100% CPU:
/usr/lib/udisks/udisks-daemon
udisks-helper-modify-partition /dev/sdb 1048576 7962886144 0x0c boot

When stracing processes of those commands, both are stuck printing couple of strings over and over again:
"Error: Can't have a partition outside the disk!\nnew_size=7962886144 but resulting size, 7961022464, smaller than requested\n"

I'll be happy to provide more information if needed.

Adam Niedling (krychek) wrote :

If I don't enter my password after clicking on Erase I get the following error message:
org.freedesktop.DBus.Python.dbus.exceptions.DBusException: com.ubuntu.USBCreator.Error.NotAuthorized

After that the Erase button remains disabled and the little circular thing keeps going around.
top does not show any udisk activity.

Maybe this should be reported as a different bug.

Janne Savikko (jsavikko) wrote :

I've tried with three different USB sticks, couple of different partition tables and several partition sizes. No luck, every time outcome is non-working boot media.

Matthew (mh00h) wrote :

still broken

Burhan Ali (burhan) on 2013-10-24
tags: added: saucy
deric (barton-tomas) wrote :

A workaround for this bug:

$ sudo dd if=/dev/zero of=/dev/sdb bs=1M count=1
$ sudo blockdev --rereadpt /dev/sdb

After zeroing out the first megabyte erasing of the usb disk works.

It is related to: https://bugs.launchpad.net/ubuntu/+source/usb-creator/+bug/458334

Adam Niedling (krychek) wrote :

I just tried to erase an USB stick with Ubuntu 14.04 and it was working fine. Can anyone confirm?

Endre Stølsvik (stolsvik) wrote :

Still present in 13.10, workaround quoted by @deric works.

<whine>
How on earth is it that something as simple as creating a damn USB disk can be made so grossly absurdly difficult? "Affects 66 people"? FOR REAL?? And the quoted bug affects 83 people?

These are people trying to install Ubuntu! And they are people which actually manages to complain here? How many are really affected by this, possibly giving up?
</whine>

Luxor (ranju-mathew) wrote :

I was able to get around this problem by executing usb-creator-gtk using the following command:

sudo usb-creator-gtk --allow-system-internal

Be careful that you choose the correct device to erase, but this should be a viable workaround until a fix is found.

jdc (joakim-almgren) wrote :

Endre Stølsvik (stolsvik) : So true

This is my error 2014-11-05

org.freedesktop.DBus.Python.AttributeError: Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/dbus/service.py", line 707, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/share/usb-creator/usb-creator-helper", line 218, in Format
    parent_dev = _get_parent_object(udisks, device)
  File "/usr/share/usb-creator/usb-creator-helper", line 49, in _get_parent_object
    parent = partition.get_cached_property('Table').get_string()
AttributeError: 'NoneType' object has no attribute 'get_cached_property'

It would be cool if an operating system could create a bootable usb-stick 2014

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers