upstart-local-bridge not handling all events sent to it

Bug #1234898 reported by Sergio Schvezov on 2013-10-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
upstart
Undecided
James Hunt
upstart (Ubuntu)
Undecided
James Hunt

Bug Description

I have this job: http://paste.ubuntu.com/6189473/

I'm running this script: http://paste.ubuntu.com/6189469/

And this is what I get: http://paste.ubuntu.com/6189493/

From it, the property says it's running, the android side (upstart-property-watcher) says it's running, the property says it's running, the upstart job though didn't seem to be triggered in all boots

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: upstart 1.10-0ubuntu1
Uname: Linux 3.4.0-4-manta armv7l
ApportVersion: 2.12.5-0ubuntu1
Architecture: armhf
Date: Thu Oct 3 18:53:23 2013
InstallationDate: Installed on 2013-10-03 (0 days ago)
InstallationMedia: Ubuntu Saucy Salamander (development branch) - armhf (20131003.1)
MarkForUpload: True
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
ProcKernelCmdline: vmalloc=512M debug_core.break_on_panic=0 debug_core.break_on_exception=0 no_console_suspend s3c2410-wdt.tmr_atboot=1 s3c2410-wdt.tmr_margin=30 s3cfb.bootloaderfb=0x60000000 androidboot.bootloader=MANTALJ12 androidboot.serialno=R32CB04SQ1J androidboot.wifimacaddr=BC:20:A4:7E:26:EC androidboot.btmacaddr=BC:20:A4:7E:26:EB
SourcePackage: upstart
UpgradeStatus: No upgrade log present (probably fresh install)
UpstartBugCategory: System
modified.conffile..etc.dbus.1.system.d.org.freedesktop.NetworkManager.conf: [modified]
mtime.conffile..etc.dbus.1.system.d.org.freedesktop.NetworkManager.conf: 2013-10-03T15:55:52
upstart.tty1.override: manual
upstart.tty2.override: manual
upstart.tty3.override: manual
upstart.tty4.override: manual
upstart.tty5.override: manual
upstart.tty6.override: manual

Related branches

Sergio Schvezov (sergiusens) wrote :
Ricardo Salveti (rsalveti) wrote :

One thing I did noticed when looking at the code is that the 'socket_reader' function seems to expect the input buffer to be one-line only, and not a block (buf could be a block when reading data from the socket).

As a result upstart_emit_event can emit 'buf' containing more than one event at the same time (including "\n"), which might cause issues later on.

As I'm not that familiar with the code, will let James to comment on the subject.

Ricardo Salveti (rsalveti) wrote :

Tried changing /etc/init/ofono.override to include a job dependency in there, but it failed because it seems upstart tried to start the job as soon the android-container event was available.

Changed /etc/init/ofono.override to:
"""
start on (started dbus and
          android-container init.svc.ril-daemon=running and
          file FILE=/dev/socket)
"""

Then checking syslog, after a reboot:
Oct 4 00:18:55 ubuntu-phablet kernel: [ 6.159072] init: ofono pre-start process (660) terminated with status 127

The issue is gone after I remove the android-container line.

I might be missing something as I'm not that familiar with the upstart syntax.

James Hunt (jamesodhunt) on 2013-10-04
Changed in upstart (Ubuntu):
assignee: nobody → James Hunt (jamesodhunt)
James Hunt (jamesodhunt) wrote :

Hi Sergio,

I believe I've fixed the issue. Please can you try the version here:

lp:~jamesodhunt/upstart/bug-1234898.

Changed in upstart (Ubuntu):
status: New → In Progress

On Fri, Oct 4, 2013 at 8:14 AM, James Hunt <email address hidden>wrote:

> Hi Sergio,
>
> I believe I've fixed the issue. Please can you try the version here:
>
> lp:~jamesodhunt/upstart/bug-1234898.
>

Power cycled 10+ times and worked fine.

Dimitri John Ledkov (xnox) wrote :

excellent.

James Hunt (jamesodhunt) on 2013-10-04
Changed in upstart:
assignee: nobody → James Hunt (jamesodhunt)
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package upstart - 1.10-0ubuntu4

---------------
upstart (1.10-0ubuntu4) saucy; urgency=low

  [ James Hunt ]
  * upstart-local-bridge: allow input to be set of pairs (LP: #1234898)

  [ Dmitrijs Ledkovs ]
  * upstart-file-bridge: start session bridge on started dbus. (LP:
    #1234841)
 -- Dmitrijs Ledkovs <email address hidden> Fri, 04 Oct 2013 15:25:21 +0100

Changed in upstart (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers