mouse battery not shown after upgrade

Bug #1448834 reported by Roger Binns on 2015-04-27
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
upower (Debian)
Fix Released
Unknown
upower (Ubuntu)
Medium
Unassigned

Bug Description

In Xubuntu 14.04 and 14.10 the power manager dropdown menu showed the battery level in my wireless logitech mouse. However after upgrading to 15.04 the mouse battery status is not shown.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: xfce4-power-manager 1.4.3-0ubuntu1
ProcVersionSignature: Ubuntu 3.19.0-15.15-generic 3.19.3
Uname: Linux 3.19.0-15-generic x86_64
ApportVersion: 2.17.2-0ubuntu1
Architecture: amd64
CurrentDesktop: XFCE
Date: Sun Apr 26 19:49:19 2015
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xfce4-power-manager
UpgradeStatus: Upgraded to vivid on 2015-04-23 (3 days ago)

Roger Binns (ubuntu-rogerbinns) wrote :
Simon Steinbeiß (ochosi) wrote :

In 15.04 you can add the "power manager plugin" to the panel. It displays your mouse's battery status in the menu (or at least it should). If it doesn't you can check whether it's the fault of the underlaying technology, which is UPower (the power manager only reads the device info it gets from UPower and then displays it). Simply run "upower -d" in the terminal and check whether your mouse shows up.

The reason I'm mentioning this as a potential culprit is because UPower underwent a rather big upgrade/transition with 15.04.

Roger Binns (ubuntu-rogerbinns) wrote :

The power manager plugin is greyed out so I can't add it - http://i.imgur.com/X5K3loz.png

$ upower -d
Device: /org/freedesktop/UPower/devices/DisplayDevice
  power supply: no
  updated: Fri 24 Apr 2015 02:38:01 PM PDT (1019180 seconds ago)
  has history: no
  has statistics: no
  unknown
    warning-level: none
    icon-name: ''

Daemon:
  daemon-version: 0.99.2
  on-battery: no
  lid-is-closed: no
  lid-is-present: no
  critical-action: HybridSleep

(This is a desktop system so it doesn't have batteries, lids etc.)

Also note that I am running upstart and not systemd, because systemd outsmarts itself trying to mount filesystems. Martin Pitt changed the bug title to something incorrect which I can't fix - https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1447879

Simon Steinbeiß (ochosi) wrote :

Not sure that this is really upstart/systemd related, to be honest. However, the mouse doesn't show in the output you posted, so the power manager cannot know about it.

Roger Binns (ubuntu-rogerbinns) wrote :

I didn't know how much of this stuff had been folded in systemd, or is affected by udev/hotplug etc :-)

In any event, I just retested and plugging the mouse into a 14.10 machine has upower show the mouse, and plugging into two different 15.04 systems will not show it (one upstart, one systemd).

Can this be moved to upower or do I need to submit a new bug?

affects: xfce4-power-manager (Ubuntu) → upower (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-power-manager (Ubuntu):
status: New → Confirmed
Changed in upower (Ubuntu):
status: New → Confirmed
Changed in upower (Ubuntu):
importance: Undecided → Medium
Changed in gnome-power-manager (Ubuntu):
importance: Undecided → Medium
Peter Wu (lekensteyn) wrote :

As reported on several places, UPower fails to recognize Unifying devices after an update to kernel >= 3.19. This includes Vivid.

Please try the attached patch on /lib/udev/rules.d/95-upower-csr.rules (commit f8104a112eb967cd4c2aaf57b5a59aafe7c4738f upstream).

The attachment "[PATCH] rules: support Logitech Unifying in Linux 3.19" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Chris Cheney (ccheney) wrote :

I have the same problem as the original submitter. The patch appears to correct the problem for the logitech keyboard but not the mouse. I have a MK700 keyboard and M705 mouse both of which used to show up via upower -d.

$ upower -d
Device: /org/freedesktop/UPower/devices/keyboard_0003o046Do2008x0005
  native-path: /sys/devices/pci0000:00/0000:00:14.0/usb1/1-10/1-10.3/1-10.3:1.2/0003:046D:C52B.0003/0003:046D:2008.0005
  vendor: Logitech, Inc.
  model: MK700
  serial: 9086B70C
  power supply: no
  updated: Fri 15 May 2015 11:43:06 AM CDT (19 seconds ago)
  has history: yes
  has statistics: no
  keyboard
    present: yes
    rechargeable: yes
    state: discharging
    warning-level: none
    percentage: 55%
    icon-name: 'battery-good-symbolic'
  History (charge):
    1431708186 0.000 unknown
  History (rate):
    1431708186 0.000 unknown

Device: /org/freedesktop/UPower/devices/DisplayDevice
  power supply: no
  updated: Fri 15 May 2015 11:43:06 AM CDT (19 seconds ago)
  has history: no
  has statistics: no
  unknown
    warning-level: none
    icon-name: ''

Daemon:
  daemon-version: 0.99.2
  on-battery: no
  lid-is-closed: no
  lid-is-present: no
  critical-action: HybridSleep

Chris Cheney (ccheney) wrote :

After rereading the original bug description my issue is slightly different. I could not see my keyboard or mouse until I applied the patch in #8. The patch only made the keyboard show up for me though.

Martin Pitt (pitti) wrote :

This was applied upstream a while ago: http://cgit.freedesktop.org/upower/commit/?id=f8104a112eb

no longer affects: gnome-power-manager (Ubuntu)
Changed in upower (Ubuntu):
status: Confirmed → Fix Committed
Changed in upower (Debian):
status: Unknown → New
Changed in upower (Debian):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package upower - 0.99.3-1

---------------
upower (0.99.3-1) unstable; urgency=medium

  * New upstream release:
    - Support Logitech Unifying in Linux 3.19+ (Closes: #785725, LP: #1448834)
    - Fix Bluetooth HID batteries with recent kernels (Closes: #772095,
      LP: #772095)
  * Drop git_init_variants.patch, included in this release.

 -- Martin Pitt <email address hidden> Fri, 29 May 2015 10:19:59 +0200

Changed in upower (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.