upower showing keyboard at 0% charge

Bug #1245287 reported by Kevin Krafthefer on 2013-10-27
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Upower
Fix Released
Medium
upower (Ubuntu)
Undecided
Unassigned

Bug Description

This bug is new upon upgrading to 13.10; bug did not exist on 13.04, 12.10 or 12.04.

I'm using an apple wireless keyboard. I have replaced the batteries and confirmed they are fully charged with voltmeter.

Keyboard is working fine but indicator says it's 0% and is red indicating some problem. Also upower says "keyboard not present"; bluetooth shows keyboards.

Kevin Krafthefer (krafthefer) wrote :
X-Stranger (xstranger) wrote :

I have 13.04 and have power indicator reporting 0% per Apple Wireless Keyboard.
Upower daemon said "no valid voltage value found for device".
Is there any chance to ask upower to ignore keyboard or detect voltage correctly?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in upower (Ubuntu):
status: New → Confirmed
X-Stranger (xstranger) wrote :

Looks like nobody is interested, so I did a dirty hack to make upower ignoring Apple Wireless Keyboard. The patch is attached.

X-Stranger (xstranger) wrote :

Posting the pre-compiled package for patch testing and for everybody else interested.

The attachment "upower.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, could you report the issue upstream to https://bugs.freedesktop.org/enter_bug.cgi?product=upower ?

Jean-Pierre Rupp (xenog) wrote :

I have added information to the upstream package, and modified the patch slightly in my system to ignore Logitech K810 keyboard, which displays the same behaviour.

This was originally reported downstream, in Ubuntu 13.10: https://bugs.launchpad.net/ubuntu/+source/upower/+bug/1245287

I am not the downstream reporter. I have experienced this bug in Ubuntu 14.10 and 15.04.

$ upower -d
[snip]
Device: /org/freedesktop/UPower/devices/battery_hid_e8o06o88o43o52od2_battery
  native-path: hid-e8:06:88:43:52:d2-battery
  model: Apple Wireless Keyboard
  power supply: no
  updated: Sun 07 Jun 2015 11:05:22 AM EDT (27 seconds ago)
  has history: yes
  has statistics: yes
  battery
    present: yes
    rechargeable: yes
    state: discharging
    warning-level: action
    energy: 0 Wh
    energy-empty: 0 Wh
    energy-full: 0 Wh
    energy-full-design: 0 Wh
    energy-rate: 0 W
    percentage: 0%
    capacity: 100%
    icon-name: 'battery-caution-symbolic'
[snip]

Here's what I see in syslog:
upowerd[7898]: (upowerd:7898): UPower-Linux-WARNING **: no valid voltage value found for device /sys/devices/pci0000:00/0000:00:14.0/usb1/1-8/1-8:1.0/bluetooth/hci0/hci0:256/0005:05AC:0239.001B/power_supply/hid-e8:06:88:43:52:d2-battery, assuming 10V

Changed in upower:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in upower:
status: Confirmed → Incomplete
Changed in upower:
status: Incomplete → Fix Released
Rick Ucker (rick-ucker) on 2017-09-17
Changed in upower (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.