package mangement system broken apt-get install -f wont fix

Bug #1822359 reported by Galen Thurber on 2019-03-29
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-notifier (Ubuntu)
Medium
Unassigned

Bug Description

The following packages have unmet dependencies:

uhd-host: Depends: libuhd3.14.0 (= 3.14.0.0-0ubuntu1~xenial1) but it is not installed
          Depends: libgcc1 (>= 1:4.0) but 1:6.0.1-0ubuntu1 is installed
          Depends: libncurses5 (>= 6) but 6.0+20160213-1ubuntu1 is installed
          Depends: libstdc++6 (>= 5.2) but 5.4.0-6ubuntu1~16.04.11 is installed
          Depends: libtinfo5 (>= 6) but 6.0+20160213-1ubuntu1 is installed

uhd reports broken pipe.
plenty of disk space

ProblemType: Crash
DistroRelease: Ubuntu 16.04
Package: update-notifier-common 3.168.10
ProcVersionSignature: Ubuntu 4.4.0-116.140-lowlatency 4.4.98
Uname: Linux 4.4.0-116-lowlatency x86_64
ApportVersion: 2.20.1-0ubuntu2.18
Architecture: amd64
CrashCounter: 1
CurrentDesktop: XFCE
Date: Fri Mar 29 15:14:49 2019
ExecutablePath: /usr/lib/update-notifier/backend_helper.py
InstallationDate: Installed on 2016-07-26 (975 days ago)
InstallationMedia: Xubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
InterpreterPath: /usr/bin/python3.5
PackageArchitecture: all
ProcCmdline: /usr/bin/python3 /usr/lib/update-notifier/backend_helper.py install_all_updates
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/lib/update-notifier/backend_helper.py', 'install_all_updates']
SourcePackage: update-notifier
Title: backend_helper.py crashed with Depends in _run(): libtinfo5 (>= 6) but 6.0+20160213-1ubuntu1 is installed
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dialout dip lpadmin plugdev sambashare sudo
modified.conffile..etc.apt.apt.conf.d.10periodic:
 APT::Periodic::Update-Package-Lists "2";
 APT::Periodic::Download-Upgradeable-Packages "0";
 APT::Periodic::AutocleanInterval "0";
 APT::Periodic::Unattended-Upgrade "1";
mtime.conffile..etc.apt.apt.conf.d.10periodic: 2018-03-22T07:51:36.042083

Galen Thurber (godfree2) wrote :

Thank you for taking the time to report this crash and helping to make this software better. This particular crash has already been reported and is a duplicate of bug #1208419, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

tags: removed: need-duplicate-check
Changed in update-notifier (Ubuntu):
importance: Undecided → Medium
information type: Private → Public
Galen Thurber (godfree2) wrote :

bug #1208419 not found

mart (bergman-martin) wrote :

I had the exact same problem and error reports (as the OP above) a couple of weeks ago.

Running sudo dpkg -i --force-overwrite /var/cache/apt/archives/libuhd3.14.0_3.14.0.0-0ubuntu1~xenial1_amd64.deb seems to have fixed it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers