Activity log for bug #1820259

Date Who What changed Old value New value Message
2019-03-15 11:41:35 Andrea Azzarone bug added bug
2019-03-15 11:41:41 Andrea Azzarone update-notifier (Ubuntu): assignee Andrea Azzarone (azzar1)
2019-03-15 11:41:43 Andrea Azzarone update-notifier (Ubuntu): importance Undecided Medium
2019-03-15 11:42:09 Andrea Azzarone bug added subscriber Ubuntu Release Team
2019-03-15 11:43:27 Andrea Azzarone branch linked lp:~azzar1/update-notifier/livepatch-indicator
2019-03-15 16:40:38 Sebastien Bacher update-notifier (Ubuntu): status New In Progress
2019-03-19 10:25:26 Łukasz Zemczak update-notifier (Ubuntu): status In Progress Triaged
2019-03-19 10:27:15 Launchpad Janitor branch linked lp:update-notifier
2019-03-19 10:27:39 Sebastien Bacher update-notifier (Ubuntu): status Triaged Fix Committed
2019-04-05 14:21:18 Andrea Azzarone tags rls-bb-incoming
2019-04-05 14:33:04 Andrea Azzarone branch linked lp:~azzar1/update-notifier/ubuntu-bionic-livepatch
2019-04-11 12:11:55 Sebastien Bacher update-notifier (Ubuntu): status Fix Committed Fix Released
2019-04-11 18:56:23 Sebastien Bacher description As per https://wiki.ubuntu.com/SoftwareUpdates#livepatch there should a indicator in the top bar to show the status of Livepatch. The indicator will not be shown in Disco because Livepatch only supports LTS releases. We need to ship the indicator anyway in order to SRU it to Bionic. The risk of regressions is low because all the introduced code is not run if Livepatch is not supported. * Impact The livepatch graphical interfaces are currently limited in bionic, there is no easy way to know the current status and the details of the changes applied. The new design improves the user experience and we want that to benefit the LTS users * Test case As per https://wiki.ubuntu.com/SoftwareUpdates#livepatch there should a indicator in the top bar to show the status of Livepatch. * Regression potential The indicator is new code/a new UI so the regression potential is low. Note that the changes include some new strings. Those are translated in disco and Launchpad shares translations between series so we should get those translations included in the next bionic langpacks export.
2019-04-25 16:58:50 Łukasz Zemczak update-notifier (Ubuntu Bionic): status New Fix Committed
2019-04-25 16:58:51 Łukasz Zemczak bug added subscriber Ubuntu Stable Release Updates Team
2019-04-25 16:58:52 Łukasz Zemczak bug added subscriber SRU Verification
2019-04-25 16:58:55 Łukasz Zemczak tags rls-bb-incoming rls-bb-incoming verification-needed verification-needed-bionic
2019-05-07 19:46:29 Will Cooke tags rls-bb-incoming verification-needed verification-needed-bionic rls-bb-incoming verification-failed-bionic verification-needed
2019-05-07 19:46:44 Will Cooke tags rls-bb-incoming verification-failed-bionic verification-needed rls-bb-incoming verification-failed verification-needed-bionic
2019-05-08 07:52:27 Will Cooke update-notifier (Ubuntu): assignee Andrea Azzarone (azzar1)
2019-05-08 09:26:06 Will Cooke bug added subscriber Will Cooke
2019-05-08 09:31:04 Iain Lane attachment added livepatch-indicator.png https://bugs.launchpad.net/ubuntu/+source/update-notifier/+bug/1820259/+attachment/5262292/+files/livepatch-indicator.png
2019-05-17 20:08:56 Brian Murray tags rls-bb-incoming verification-failed verification-needed-bionic verification-failed verification-needed-bionic