local-avahi-notification doesn't show its message localized

Bug #1493208 reported by Gabor Kelemen on 2015-09-08
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
update-notifier (Ubuntu)
Medium
Unassigned

Bug Description

This is a followup to bug #1478249 and this side effect commit: http://bazaar.launchpad.net/~ubuntu-core-dev/update-notifier/ubuntu/revision/863

So in there the domain name used for localization is fixed.
But that's not enough, the message local-avahi-notification displays is still not localized in a fresh build.
The reason is that the locale is not specified. In other binaries of update-notifier there is a call to gtk_init() which does that. This one has no gtk_init(), so we need to manually call setlocale(). After that the message appears just fine for me.

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-notifier (Ubuntu):
status: New → Confirmed
Changed in update-notifier (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-notifier - 3.163

---------------
update-notifier (3.163) wily; urgency=medium

  * Call setlocale(LC_ALL, "") in avahi.c, so that the message there is
    translated. Thanks Gabor Kelemen. (LP: #1493208)

 -- Iain Lane <email address hidden> Thu, 17 Sep 2015 14:04:23 +0100

Changed in update-notifier (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers