update-notifier crashed with SIGSEGV

Bug #1189777 reported by Matthias Gehre on 2013-06-11
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-notifier (Ubuntu)
Undecided
Unassigned

Bug Description

On every reboot, I get this message ("update-notifier crashed") after login into the unity session.
I don't see any other symptoms.

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: update-notifier 0.134
ProcVersionSignature: Ubuntu 3.8.0-23.34-generic 3.8.11
Uname: Linux 3.8.0-23-generic x86_64
ApportVersion: 2.9.2-0ubuntu8.1
Architecture: amd64
CrashCounter: 1
Date: Mon Jun 10 11:48:59 2013
Disassembly: => 0x7fce506521b1: Cannot access memory at address 0x7fce506521b1
ExecutablePath: /usr/bin/update-notifier
InstallationDate: Installed on 2013-02-26 (105 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MarkForUpload: True
ProcCmdline: update-notifier
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/zsh
SegvAnalysis:
 Segfault happened at: 0x7fce506521b1: Cannot access memory at address 0x7fce506521b1
 PC (0x7fce506521b1) ok
 SP (0x7fff4ec45930) ok
 Reason could not be automatically determined.
Signal: 11
SourcePackage: update-notifier
Stacktrace:
 #0 0x00007fce506521b1 in ?? ()
 No symbol table info available.
 #1 0x0000000000000000 in ?? ()
 No symbol table info available.
StacktraceTop:
 ?? ()
 ?? ()
Title: update-notifier crashed with SIGSEGV
UpgradeStatus: Upgraded to raring on 2013-04-19 (52 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sbuild sudo

Matthias Gehre (m-gehre) wrote :
information type: Private → Public

Stacktrace:
 #0 0x00007fce506521b1 in ?? ()
 No symbol table info available.
 #1 0x0000000000000000 in ?? ()
 No symbol table info available.
StacktraceTop:
 ?? ()
 ?? ()

Changed in update-notifier (Ubuntu):
status: New → Invalid

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate a useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

outdated debug symbol package for libudev1: package version 198-0ubuntu11.1 dbgsym version 198-0ubuntu11

Please upgrade your system to the latest package versions. If you still
encounter the crash, please file a new report.

Thank you for your understanding, and sorry for the inconvenience!

tags: removed: need-amd64-retrace
Matthias Gehre (m-gehre) wrote :

I don't understand the reason for this being marked "invalid".
I have libudev1 of current version. 'dpkg -l libudev1' shows:

ii libudev1:amd64 198-0ubuntu11.1 amd64 libudev shared library

And I do not have any dbgsym packages installed.

Why am I unable to report this bug? What can I do to fix this?

Changed in update-notifier (Ubuntu):
status: Invalid → New
Steve Langasek (vorlon) wrote :

For whatever reason, the retracer server did not have access to the dbgsym package for libudev1 198-0ubuntu11.1. While it's theoretically possible to get those symbols and retrace the crash, it will be a low priority to do this manually. And without a valid stack retrace, this bug will not be actionable.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers