update-manager crashed with SIGABRT in __assert_fail_base(): Assertion !xcb_xlib_unknown_req_in_deq failed in dequeue_pending_request

Bug #930839 reported by cokekid on 2012-02-12
508
This bug affects 67 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
High
Unassigned
update-manager (Ubuntu)
Medium
Michael Vogt

Bug Description

[xcb] Unknown request in queue while dequeuing
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
python: ../../src/xcb_io.c:178: dequeue_pending_request: Assertion `!xcb_xlib_unknown_req_in_deq' failed.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: update-manager 1:0.156.4
ProcVersionSignature: Ubuntu 3.2.0-15.24-generic 3.2.5
Uname: Linux 3.2.0-15-generic i686
ApportVersion: 1.91-0ubuntu1
Architecture: i386
Date: Sat Feb 11 21:33:21 2012
ExecutablePath: /usr/bin/update-manager
GsettingsChanges:

InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/update-manager --dist-upgrade
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 6
SourcePackage: update-manager
StacktraceTop:
 raise () from /lib/i386-linux-gnu/libc.so.6
 abort () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /lib/i386-linux-gnu/libc.so.6
 __assert_fail () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /usr/lib/i386-linux-gnu/libX11.so.6
Title: update-manager crashed with SIGABRT in raise()
UpgradeStatus: Upgraded to precise on 2012-02-12 (0 days ago)
UserGroups:

cokekid (cokekid) wrote :
cokekid (cokekid) wrote :

have no clue

StacktraceTop:
 __assert_fail_base (fmt=0x56c438 "%s%s%s:%u: %s%sAssertion `%s' failed.\n%n", assertion=0xc97cbd "!xcb_xlib_unknown_req_in_deq", file=0xc97caa "../../src/xcb_io.c", line=178, function=0xc97d80 "dequeue_pending_request") at assert.c:94
 __GI___assert_fail (assertion=0xc97cbd "!xcb_xlib_unknown_req_in_deq", file=0xc97caa "../../src/xcb_io.c", line=178, function=0xc97d80 "dequeue_pending_request") at assert.c:103
 dequeue_pending_request (dpy=<optimized out>, req=<optimized out>) at ../../src/xcb_io.c:184
 poll_for_response (dpy=0xa1f9ca0) at ../../src/xcb_io.c:302
 _XReadEvents (dpy=0xa1f9ca0) at ../../src/xcb_io.c:423

Changed in update-manager (Ubuntu):
importance: Undecided → Medium
summary: - update-manager crashed with SIGABRT in raise()
+ update-manager crashed with SIGABRT in __assert_fail_base()
tags: removed: need-i386-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-manager (Ubuntu):
status: New → Confirmed
visibility: private → public
summary: - update-manager crashed with SIGABRT in __assert_fail_base()
+ update-manager crashed with SIGABRT in __assert_fail_base(): Assertion
+ !xcb_xlib_unknown_req_in_deq failed in dequeue_pending_request
tags: added: bugpattern-needed
Brian Murray (brian-murray) wrote :

This bug and all of its duplicates seem to have happened during a distribution upgrade:

LP: #930839 has a total of 12 duplicates
UpgradeStatusLP: #930839 has a total of 12 duplicates
UpgradeStatus
  [3] Upgraded to precise on 2012-02-11 (0 days ago): 930558, 930661, 930923
  [2] Upgraded to precise on 2012-02-10 (0 days ago): 930163, 930356
  [1] Upgraded to precise on 2012-02-17 (0 days ago): 934340
  [3] Upgraded to precise on 2012-02-13 (0 days ago): 931198, 931616, 931671
  [1] Upgraded to precise on 2012-02-14 (0 days ago): 932015
  [1] Upgraded to precise on 2012-02-12 (1 days ago): 931292
  [1] Upgraded to precise on 2012-02-12 (0 days ago): 931011
  [3] Upgraded to precise on 2012-02-11 (0 days ago): 930558, 930661, 930923
  [2] Upgraded to precise on 2012-02-10 (0 days ago): 930163, 930356
  [1] Upgraded to precise on 2012-02-17 (0 days ago): 934340
  [3] Upgraded to precise on 2012-02-13 (0 days ago): 931198, 931616, 931671
  [1] Upgraded to precise on 2012-02-14 (0 days ago): 932015
  [1] Upgraded to precise on 2012-02-12 (1 days ago): 931292
  [1] Upgraded to precise on 2012-02-12 (0 days ago): 931011

Bryce Harrington (bryce) on 2012-02-24
description: updated
Bryce Harrington (bryce) wrote :

The error message "Unknown sequence number while processing queue" occurs in a chunk of text that has this big fat warning in front of it, about threading safety in client code:

/* Thread-safety rules:
 *
 * At most one thread can be reading from XCB's event queue at a time.
 * If you are not the current event-reading thread and you need to find
 * out if an event is available, you must wait.
 *
 * The same rule applies for reading replies.
 *
 * A single thread cannot be both the the event-reading and the
 * reply-reading thread at the same time.
 *
 * We always look at both the current event and the first pending reply
 * to decide which to process next.
 *
 * We always process all responses in sequence-number order, which may
 * mean waiting for another thread (either the event_waiter or the
 * reply_waiter) to handle an earlier response before we can process or
 * return a later one. If so, we wait on the corresponding condition
 * variable for that thread to process the response and wake us up.
 */

This seems to suggest perhaps this client application could have some faulty logic in its thread handling as relating to the xcb calls?

Brian Murray (brian-murray) wrote :

Several of the bugs have the following in the VarLogDistupgradeAptlog.txt:

MarkUpgrade() called on a non-upgrable pkg: 'brasero'
ERROR:root:Upgrading 'brasero' failed
[xcb] Unknown request in queue while dequeuing
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
python: ../../src/xcb_io.c:178: dequeue_pending_request: asserzione "! xcb_xlib_unknown_req_in_deq" non riuscita.

This is similar to the message in bug 930004.

Bryce Harrington (bryce) wrote :

Sorry, above paste was meant for bug 930004, not this one.

description: updated
Bryce Harrington (bryce) wrote :

This error is also an assertion being hit in libxcb, rather than a segfault, so it doesn't imply a bug in the library but rather that the library is catching a bug from higher up in the stack. The error message is suggesting it could be an issue in how threading is done; making XCB calls from multiple threads can trigger such problems for instance. This may have the same root cause as bug #930004.

Bryce Harrington (bryce) wrote :

Btw, xtrace may be useful for helping diagnose what the client is doing exactly.

Changed in update-manager (Ubuntu):
status: Confirmed → Triaged
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Brian Murray (brian-murray) wrote :

Bug 845148 (banshee) and bug 934001 (openjdk-6) have similar assertion messages.

Changed in update-manager (Ubuntu):
assignee: Canonical Foundations Team (canonical-foundations) → Canonical Desktop Team (canonical-desktop-team)
Martin Pitt (pitti) on 2012-02-27
Changed in update-manager (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → Michael Vogt (mvo)
omarly666 (omarly666) wrote :

a double bug after a partial upgrade

tags: added: rls-mgr-p-tracking
Brian Murray (brian-murray) wrote :

This also affect ubuntu-release-upgrader in Quantal with the split of the update-manager code.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
Changed in ubuntu-release-upgrader (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
tags: added: quantal
Brian Murray (brian-murray) wrote :

Due to the lack of specificity of the stacktrace when the bug is initially filed a bugpattern for this bug report would probably find bugs that are not this bug. So a bugpattern is inappropriate here.

description: updated
sindhu (sindhu-h) on 2013-11-09
Changed in ubuntu-release-upgrader (Ubuntu):
status: Triaged → Fix Released
Changed in update-manager (Ubuntu):
status: Triaged → Fix Released

Sindhu, without any comment given -- why was this marked as fixed?

I don't know for sure what the status of the bug should be, but I think that's a spurious 'Fix Released'. Unfortunately, LP doesn't let me undo that.

Changed in ubuntu-release-upgrader (Ubuntu):
status: Fix Released → Triaged
Changed in update-manager (Ubuntu):
status: Fix Released → Triaged
Thomas (thomasmanchadi-k) wrote :

Whenever I start Ubuntu,there appears to be "system error" notification.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers