Refers to "Administration" menu that doesn't exist in Unity

Bug #727069 reported by Luca Ferretti on 2011-03-01
48
This bug affects 6 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Robert Roth
update-manager (Ubuntu)
Low
Robert Roth

Bug Description

When there are updates, Update Manager window says "If you don't want to install them now, choose 'Update Manager' from the Administration menu later."

In Unity there is no "Administration" menu, so that message is wrong.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: update-manager 1:0.146
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Tue Mar 1 11:06:55 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=it_IT:en_US:en
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
SourcePackage: update-manager
UpgradeStatus: Upgraded to natty on 2011-02-24 (5 days ago)

Related branches

Luca Ferretti (elle.uca) wrote :
RedSingularity (redsingularity) wrote :

Thanks for reporting this issue. Just to clarify, where is the "heading tooltip" on the update-manager?

Changed in update-manager (Ubuntu):
status: New → Incomplete
Luca Ferretti (elle.uca) wrote :

hmmmm... did you ever used update-manager? :D
Of course technically speaking that label is not a GtkTooltip, but I haven't found a better way to indicate it.

See this screenshot: http://en.wikipedia.org/wiki/File:Update_Manager_in_Ubuntu_10.10.JPG

RedSingularity (redsingularity) wrote :

Oh ok, thanks for clarifying. I have never heard of it referred to as a "tooltip" before. Anyway, I am taking a look at it on my test system now.

RedSingularity (redsingularity) wrote :

I have confirmed this. Update-manager is now under "Applications" as there is no "Administration" in Unity desktop.

Changed in update-manager (Ubuntu):
status: Incomplete → Confirmed
description: updated
summary: - No Administration menu in Unity
+ Refers to "Administration" menu that doesn't exist in Unity
Draycen DeCator (ddecator) wrote :

Thanks again for reporting this issue to Ubuntu. Since this report has enough information for the developers to address the issue, I am marking this report as Triaged. I am also assigning a Low importance (as per the request of RedSingularity) since the functionality of the update manager is not impacted, it just provides incorrect information to the user.

Please continue to report any problems that you encounter!

Changed in update-manager (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Robert Roth (evfool) wrote :

Would the proper fix for this be changing Administration Menu to Applications Place?

Changed in update-manager (Ubuntu):
assignee: nobody → Robert Roth (evfool)
status: Triaged → In Progress
Matthew Paul Thomas (mpt) wrote :

Robert, thanks for working on this. I suggest, if Unity is running:
If you don't want to install them now, choose “Update Manager” from Applications later.

Remco (remco47) wrote :

Are the System Settings items going to stay visible in the Applications place? It might be better to direct the user to the System Settings in the System menu.

Robert Roth (evfool) wrote :

The last comments bring up another question: should the text displayed on the running desktop session? I mean like "Administration Menu" for the Classic desktop and "Applications" for Unity? That is not the best idea IMO, that's why I like the System Settings approach, because that item will be consistently in the indicator menus for both Classic desktop and Unity.

Vish (vish) on 2011-03-31
Changed in hundredpapercuts:
assignee: nobody → Robert Roth (evfool)
importance: Undecided → Low
milestone: none → nt7-potpourri
status: New → In Progress
Matthew Paul Thomas (mpt) wrote :

Update Manager is not part of System Settings -- or if it is, that's a bug.

Ubuntu Software Center contains code to show one thing when gnome-panel is running, and a different thing if Unity is running. You could find the necessary code there, or ask any of the Unity developers.

Barry Warsaw (barry) wrote :

My comment from the merge proposal review:

Thanks for your contribution Robert. I have some concerns about this patch.

When looking at a classic desktop under Natty (which I sadly have too many of at the moment ;), There is no "Applications Place". Setting aside whether I know that there is a Places menu item under the Ubuntu menu, even under Places there is no entry for Applications. AFAICT, you still have to go to System->Administration to get Update Manager.

Under my one Unity desktop, there is an Applications box, which I guess is the "Applications Place" you're talking about. However, clicking on that doesn't really help, since Update Manager is no where to be found. I need to select the 52 other installed application, then scroll all the way down to actually find Update Manager.

I don't really know what the best way to word all these multiple locations and options are, and I agree that on Unity, "Administration Menu" is meaningless (though still appropriate on classic desktop). But still, I think the patch needs some work before it could be accepted.

I'll paste the above into the bug report so MPT has a chance to weigh in.

Robert Roth (evfool) on 2011-04-06
Changed in update-manager (Ubuntu):
status: In Progress → Fix Committed
Changed in hundredpapercuts:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.147.3

---------------
update-manager (1:0.147.3) natty; urgency=low

  * merged lp:~evfool/update-manager/fix665173 (LP: #665173),
    many thanks to Robert Roth (update the test a bit)
  * merged lp:~evfool/update-manager/fix150677 (LP: #150677),
    many thanks to Robert Roth
  * merged lp:~evfool/update-manager/fix727069 (LP: #727069),
    many thanks to Robert Roth
 -- Michael Vogt <email address hidden> Wed, 06 Apr 2011 17:32:35 +0200

Changed in update-manager (Ubuntu):
status: Fix Committed → Fix Released
Vish (vish) on 2011-05-15
Changed in hundredpapercuts:
status: Fix Committed → Fix Released

I'm out of the office until 1st August.

On 15 May 2011, at 09:33, Vish <email address hidden> wrote:

> ** Changed in: hundredpapercuts
>       Status: Fix Committed => Fix Released
>
> --
> You received this bug notification because you are a member of
> Papercutters, which is subscribed to One Hundred Paper Cuts.
> https://bugs.launchpad.net/bugs/727069
>
> Title:
>  Refers to "Administration" menu that doesn't exist in Unity
>
> Status in One Hundred Paper Cuts:
>  Fix Released
> Status in “update-manager” package in Ubuntu:
>  Fix Released
>
> Bug description:
>  When there are updates, Update Manager window says "If you don't want
>  to install them now, choose 'Update Manager' from the Administration
>  menu later."
>
>  In Unity there is no "Administration" menu, so that message is wrong.
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 11.04
>  Package: update-manager 1:0.146
>  ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
>  Uname: Linux 2.6.38-5-generic i686
>  NonfreeKernelModules: wl
>  Architecture: i386
>  Date: Tue Mar  1 11:06:55 2011
>  EcryptfsInUse: Yes
>  InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386
> (20110202)
>  PackageArchitecture: all
>  ProcEnviron:
>   LANGUAGE=it_IT:en_US:en
>   LANG=it_IT.UTF-8
>   SHELL=/bin/bash
>  SourcePackage: update-manager
>  UpgradeStatus: Upgraded to natty on 2011-02-24 (5 days ago)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers