Ubuntu

update-manager crashed with TypeError in _get_last_apt_get_update_text(): unsupported operand type(s) for /: 'NoneType' and 'int'

Reported by Jean-Baptiste Lallement on 2011-02-03
92
This bug affects 19 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Michael Vogt
Natty
Medium
Michael Vogt

Bug Description

Binary package hint: update-manager

ISO Testing Xubuntu Alternate AMD64 20110201.1
ISO Testing Ubuntu Alternate i386 20110201.1

I installed Xubuntu from the Alternate ISO.
After login, I clicked on the update-notifier icon on the notification area.
There was 11 updates, and installed them all.
This crash report triggered after the update.

This is reproducible when I do a new installation.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: update-manager 1:0.145.13
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic x86_64
Architecture: amd64
Date: Thu Feb 3 10:56:42 2011
ExecutablePath: /usr/bin/update-manager
InstallationMedia: Xubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110201.1)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python2.7 /usr/bin/update-manager
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.utf8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/update-manager']
SourcePackage: update-manager
Title: update-manager crashed with TypeError in _get_last_apt_get_update_text(): unsupported operand type(s) for /: 'NoneType' and 'int'
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Jean-Baptiste Lallement (jibel) wrote :
tags: removed: need-duplicate-check
tags: added: iso-testing
description: updated

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

visibility: private → public
Changed in update-manager (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
tags: added: xubuntu
alex (webalex) wrote :

Traceback (most recent call last):
  File "/usr/bin/update-manager", line 108, in <module>
    app.main(options)
  File "/usr/lib/python2.7/dist-packages/UpdateManager/UpdateManager.py", line 1142, in main
    self.fillstore()
  File "/usr/lib/python2.7/dist-packages/UpdateManager/UpdateManager.py", line 997, in fillstore
    self.update_count()
  File "/usr/lib/python2.7/dist-packages/UpdateManager/UpdateManager.py", line 636, in update_count
    if self._get_last_apt_get_update_text() is not None:
  File "/usr/lib/python2.7/dist-packages/UpdateManager/UpdateManager.py", line 586, in _get_last_apt_get_update_text
    ago_days = int( ago_hours / 24 )
TypeError: unsupported operand type(s) for /: 'NoneType' and 'int'

Martin Pitt (pitti) on 2011-03-02
Changed in update-manager (Ubuntu):
assignee: nobody → Michael Vogt (mvo)

If the system is completely shutdown and restarted before running the update manager, this issue does not occur.

Michael Vogt (mvo) on 2011-03-03
Changed in update-manager (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.146.2

---------------
update-manager (1:0.146.2) natty; urgency=low

  [ Michael Vogt ]
  * data/glade/UpdateManager.ui, UpdateManager/UpdateManager.py:
    - improve wording of roaming warning, thanks to Alex Chiang
    - make the roaming warning label wrap
  * UpdateManager/UpdateManager.py:
    - fix crash in _get_last_apt_get_update_text (LP: #712346)
    - do not try to download changelogs if NM reports we are
      disconnected (LP: #19372)

  [ Julian Taylor ]
  * use dh_installman to install manpages
  * move do-release-upgrade manpage to update-manager-core (LP: #695186)

  [ Martin Pitt ]
  * debian/control: Update Breaks:/Conflicts: for the moved manpage.
 -- Michael Vogt <email address hidden> Wed, 09 Mar 2011 10:25:11 +0100

Changed in update-manager (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers