update-manager shows no changelog for various packages

Bug #523714 reported by Mitch Towner on 2010-02-18
118
This bug affects 12 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: update-manager

Certain packages never show changelog items in update-manager. These packages also do not show changelogs on changelogs.ubuntu.com although the changelogs are on Launchpad (e.g. https://edge.launchpad.net/ubuntu/+source/dpkg/1.15.5.6ubuntu1/+changelog)

[TEST CASE]
=============
1. Install lucid
2. Open update-manager and verify that no changelogs are displayed for the affected packages (see list in "Notes" section below
3. Open changelogs.ubuntu.com & verify that the changelogs are not displayed for the version in lucid (e.g http://changelogs.ubuntu.com/changelogs/pool/main/d/dpkg/dpkg_1.15.5.6ubuntu1/)
4. Verify that the changelogs are on Launchpad (e.g https://edge.launchpad.net/ubuntu/+source/dpkg/1.15.5.6ubuntu1/+changelog)

[Current Result]
=============
There are no changelogs for the latest versions of the affected packages on changelogs.ubuntu.com
Update Manager displays "The list of changes is not available yet. Please try again later."

[Expected Result]
=============
Changelogs for the latest versions of the affected packages should appear on changelogs.ubuntu.com
The "changes" tab in Update Manager should display a changelog of changes for the latest versions of the affected packages

[Work Around]
=============
View the changelogs in Launchpad by navigating to the project's main Launchpad page (e.g. https://edge.launchpad.net/ubuntu/+source/dpkg/) & clicking the "view full changelog" link.

[Notes]
=============
This appears to only affect lucid packages.

$ uname -a
Linux ubuntu 2.6.32-13-generic #18-Ubuntu SMP Wed Feb 10 21:24:20 UTC 2010 i686 GNU/Linux

$ sudo apt-cache policy update-manager
update-manager:
  Installed: 1:0.132
  Candidate: 1:0.132
  Version table:
 *** 1:0.132 0
        500 http://us.archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status

The following packages are affected:
dpkg
samba
quilt
kaffeine
kde-style-qtcurve
geoip
ntp
k3b

This is only a preliminary list. There may be more packages affected by this.

Mitch Towner (kermiac) on 2010-02-18
description: updated
Mitch Towner (kermiac) on 2010-02-18
tags: added: metabug
Mitch Towner (kermiac) on 2010-02-18
description: updated
Changed in update-manager (Ubuntu):
status: New → Confirmed
Markus Korn (thekorn) wrote :

The user who reported the duplicates has published a list of more affected packages on https://answers.edge.launchpad.net/ubuntu-website/+question/96541 - and `promised` to report bugs against all affected packages.

Changed in update-manager (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Markus Korn (thekorn) wrote :

changed status/importance as of Mitch's request

zigi (ziegleka) wrote :

Thanks for your work on this bug.

Similar bug: https://bugs.launchpad.net/ubuntu/+source/aptitude/+bug/362443

zigi (ziegleka) wrote :

@Markus Korn ... yes, that was me and I was waiting for some time, if something happen ... now in aptitude I have 65 packages with missing changelog ... so I started reporting promised bug reports

zigi (ziegleka) wrote :
Download full text (16.5 KiB)

Packages with missing changelog (taken from aptitude):

--\ Packages being automatically held in their current state (11)
i A aspell 0.60.6-2 0.60.6-3
i A knm-runtime 0.9~svn106 0.9~svn107
i A ktorrent-data 3.3.2+dfsg 3.3.3+dfsg
i A libattica0 0.1.1-2bui 0.1.2-0ubu
i A libdc1394-22 2.1.2-1 2.1.2-2
i A libkwebkit1 0.9~svn106 0.9~svn108
i A libqscintilla2-5 2.4.2-0ubu 2.4.2-3ubu
i A python-cairo 1.8.6-1ubu 1.8.8-1
i A python-launchpadlib 1.5.4-1ubu 1.5.5-1
i A python-lazr.restfulclient 0.9.10-1 0.9.11-1
i A wireshark-common 1.2.4-3 1.2.6-1

--\ Packages being held back (53)
i acl ...

zigi (ziegleka) wrote :

Another problematic packages:
i libcairo2 1.8.8-2ubu 1.8.10-2ub
i A libdbusmenu-qt1 0.2.1-0ubu 0.2.2-0ubu
i libfribidi0 0.10.9-1bu 0.19.2-1
i A libpolkit-qt-1-0 0.95.1-0ub 0.95.1-1fa
i libslang2 2.1.4-3 2.2.2-2ubu
i libxine1 1.1.16.3-1 1.1.17-1ub
i libxine1-bin 1.1.16.3-1 1.1.17-1ub
i libxine1-console 1.1.16.3-1 1.1.17-1ub
i libxine1-ffmpeg 1.1.16.3-1 1.1.17-1ub
i libxine1-misc-plugins 1.1.16.3-1 1.1.17-1ub
i libxine1-x 1.1.16.3-1 1.1.17-1ub
i openssh-client 1:5.3p1-1u 1:5.3p1-3u

Michael Vogt (mvo) wrote :

Its the new dpkg-source format that is not understood by the dpkg that runs on changelogs.ubuntu.com. A excerpt from the log:
...
dpkg-source: error: Unsupported format of .dsc file (3.0 (quilt))
...
I filed asking for a newer version.

Thanks,
 Michael

zigi (ziegleka) wrote :
Download full text (21.6 KiB)

@Michael Vogt ... did someone update the dpkg / quilt on changelogs server? I ask, because some previously problematic packages now have avaliable their changelogs.

Actual list of packages without changelogs (their changelogs need reupload):

--\ Packages being automatically held in their current state (20)
i A aspell 0.60.6-2 0.60.6-3ub
i A binfmt-support 1.2.17 1.2.18
i A ktorrent-data 3.3.2+dfsg 3.3.4+dfsg
i A libdbusmenu-qt2 0.3.0-0ubu 0.3.2-0ubu
i A libdc1394-22 2.1.2-1 2.1.2-2
i A libkwebkit1 0.9~svn106 0.9~svn108
i A libpolkit-qt-1-0 0.95.1-0ub 0.95.1-1fa
i A libqscintilla2-5 2.4.2-0ubu 2.4.3-0ubu
i A libssh-4 0.4.0-1ubu 0.4.2-1ubu
i A libusbmuxd1 1.0.0-2 1.0.2-1ubu
i A polkit-kde-1 ...

description: updated
tags: added: lucid
zigi (ziegleka) wrote :

ksshaskpass and probably other packages which I haven't installed

summary: - [lucid] update-manager shows no changelog for various packages
+ update-manager shows no changelog for various packages
zigi (ziegleka) wrote :

Hi,

    A few days ago the server was unavailable changelogs.ubuntu.com. Since this time no changelogs are available again for new versions of packages. This problem affects at least the development version of Ubuntu - Oneiric.

zigi (ziegleka) wrote :

Hi,

  again for Quantal, see attached list.

tags: added: changelog oneiric precise quantal
Simeon (simeon5) wrote :

I had this problem with precise since ~ a month but now it is better. I dont know why though.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers