Upgrade problem to karmic - "could not calculate the upgrade" with konquorer and dpkg

Bug #465913 reported by Powerfield on 2009-10-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

Could not upgrade - attaching files as requested

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: fglrx
Package: update-manager 1:0.111.9
PackageArchitecture: all
ProcEnviron:
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: update-manager
Uname: Linux 2.6.28-16-generic i686

Powerfield (powerfield) wrote :
Michael Vogt (mvo) wrote :

Here is the error:

2009-10-31 09:02:46,384 ERROR Dist-upgrade failed: 'E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.'

And then:
Investigating dpkg
Package dpkg has broken dep on konqueror
  Considering konqueror 0 as a solution to dpkg 5501
  Upgrading konqueror due to Breaks field in dpkg

It appears for some reason that konqueror is making trouble, could you please try to remove it before the ugprade and see if that helps? If it does, please attach the upgrade log so that we can add a fix for the issues.

Michael Vogt (mvo) on 2009-10-31
Changed in update-manager (Ubuntu):
status: New → Incomplete
Powerfield (powerfield) wrote :

That worked brilliantly, at least after I fixed another problem - damned ATI Radeon HD 2400 and their incompatibilities with fglrx :-)

Here's the upgrade logs as an attachment.?field.comment=That worked brilliantly, at least after I fixed another problem - damned ATI Radeon HD 2400 and their incompatibilities with fglrx :-)

Here's the upgrade logs as an attachment.

Powerfield (powerfield) wrote :

Oops, apologies for that last comment, it appears to have gotten some rubbish in it. I meant:

That worked brilliantly, at least after I fixed another problem - damned ATI Radeon HD 2400 and their incompatibilities with fglrx :-)

This can be closed at your leisure. As far as I'm concerned, it's fixed (not sure even why konqueror was installed, I'm a Gnome man). But if you need any further information to fix the root cause of the problem, let me know.

Cheers,
Al (a new and very happy Karmic user).

Powerfield (powerfield) on 2009-11-02
Changed in update-manager (Ubuntu):
status: Incomplete → New
Michael Vogt (mvo) wrote :

Thanks! I leave it open for now, I'm trying to reproduce the failure currently. What exactly is the problem with fglrx? Is that something that the user should be warned about? Did ati drop support for your card?

summary: - Upgrade problem to karmic - "could not calculate the upgrade"
+ Upgrade problem to karmic - "could not calculate the upgrade" with
+ konquorer and dpkg
Changed in update-manager (Ubuntu):
status: New → Confirmed

I'm pretty certain it was dropped support . When X kicked up, all I got
was corrupted graphics. It was working okay in the background since one
of the you could see movement when the mouse moved.

Changing the X device in xorg.conf from fglrx to radeon, uninstalling
the fglrx drivers and installing the radeon ones, fixed the problem.

There's quite a few messages floating around the net re ATI dropping
support for their earlier cards.

Cheers,
Al.

On Tue, 2009-11-03 at 17:23 +0000, Michael Vogt wrote:
> Thanks! I leave it open for now, I'm trying to reproduce the failure
> currently. What exactly is the problem with fglrx? Is that something
> that the user should be warned about? Did ati drop support for your
> card?
>
> ** Summary changed:
>
> - Upgrade problem to karmic - "could not calculate the upgrade"
> + Upgrade problem to karmic - "could not calculate the upgrade" with konquorer and dpkg
>
> ** Changed in: update-manager (Ubuntu)
> Status: New => Confirmed
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers