Comment 2 for bug 465913

Here is the error:

2009-10-31 09:02:46,384 ERROR Dist-upgrade failed: 'E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.'

And then:
Investigating dpkg
Package dpkg has broken dep on konqueror
  Considering konqueror 0 as a solution to dpkg 5501
  Upgrading konqueror due to Breaks field in dpkg

It appears for some reason that konqueror is making trouble, could you please try to remove it before the ugprade and see if that helps? If it does, please attach the upgrade log so that we can add a fix for the issues.