update-manager should guest an estimative of upgrade size to prevent running out of free disk

Bug #273049 reported by Fernando Miguel on 2008-09-22
38
This bug affects 4 people
Affects Status Importance Assigned to Milestone
apt (Ubuntu)
Undecided
Unassigned
update-manager (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: update-manager

This is a wishbug!
When users upgrade to the development version using update-manager -d or do-release-upgrade -d stats should be collected and sent to some kind of archive (after user allows them to) so that a approximated size necessary can be calculated in order to prevent running out of free disk on future dist upgrades by users (either still on development versions or Stable releases).

A rough number can be the size of the packages plus the necessary amount unpack.
We could tie the old kernel clean up (last good kernel [1]) with update-manager so more disk can be freed up in case there ain't enough free disk.

This ticket groups from #106804, #221855 and "595473
Related blueprint: cleanup-cruft [2]

[1] https://wiki.ubuntu.com/KernelTeam/removing-old-kernels
[2] https://blueprints.edge.launchpad.net/ubuntu/+spec/cleanup-cruft

This of course also affects any apt-get install, on a smaller scale.
So apt-get should also try to calculate/estimate necessary disk before installing/upgrading any package.

description: updated
danesh (daneshmirza) wrote :

ubuntu

Changed in update-manager:
assignee: nobody → daneshmirza

Danesh did u really meant to assign yourself this bug?
Because if you dont, then this bug will come out of the radar of other devs, and wont get fixed.

Changed in update-manager:
assignee: daneshmirza → nobody
davide (davide-del-vento) wrote :

This is really painful problem, which of course affect only space-limited systems, like USB-key casper installations, and makes them useless :-(
It should possible to easily select/sort packages from their "status" (recommended or security) and size (after install, not just download).

Julian Andres Klode (juliank) wrote :

APT shows size requirements, as stated in the package.

Changed in apt (Ubuntu):
status: New → Invalid
davide (davide-del-vento) wrote :

Julian,
we all know that size requirements are shown. This is not about showing. It is about using that information (either manually by the user or automatically by the program) to prevent to fill up the disk and made the system unstable and/or unusable.
This is VERY relevant for USB-key casper installations, since at present they are completely useless just because of this problem. Have you ever tried them, and I mean not just installation, but actual use for a few weeks (until several updates accumulate)?
Feel free to close this bug if you don't think it will be fixed, but please try to understand it before doing so.

Changed in apt (Ubuntu):
status: Invalid → New
Julian Andres Klode (juliank) wrote :

We do use this information and we do not continue if we do not have enough free space available for downloading. We can't check whether there is enough free space for installing, as we do not know where the files will land, and they may be on different mount points.

Changed in apt (Ubuntu):
status: New → Invalid
Changed in update-manager (Ubuntu):
status: New → Invalid
davide (davide-del-vento) wrote :

Clearly you are not reading what I wrote in the first place. I understand that you might be busy and you might have things more important than this bug, but in such a case please leave it alone, and please don't try to guess what people mean without carefully reading what they wrote.

I wrote:
> It should possible to easily select/sort packages from
> their "status" (recommended or security) and size
> (after install, not just download).

At present users are supposed to do this by themselves, which is fine on a fully-fledged disk installation (just leave the default "all is selected" and confirm), but it is impossible to manage on a USB-key casper installations.

If the process cannot be automatic for the reasons you mentioned, then there must be at least an option to sort packages per various criteria (e.g. recommended, security, size) and let the user bulk-select and bulk-deselect them (e.g. with CTRL and SHIFT clicking). Individual package selection as it is now it's unacceptable for the scenario I'm describing, i.e. a USB-key casper installations.

Now, I'm fine if you say that you don't care about this problem and you don't WANT to fix it, and you close the bug with this statement.

However you cannot state that this bug is non-existent and that the system already takes care of this problem, because it does not. More than that! It does make it very hard for the users to take care of the problem themselves.

Changed in update-manager (Ubuntu):
status: Invalid → New
Julian Andres Klode (juliank) wrote :

That's a completely different thing than this bug was initially about. And I only care about the APT part, yes. And yes, it is impossible to know whether the disc gets full or not. Users must check this themselves

Robert Roth (evfool) on 2012-04-12
Changed in update-manager (Ubuntu):
importance: Undecided → Wishlist
Changed in update-manager (Ubuntu):
status: New → Fix Released
Matthew Paul Thomas (mpt) wrote :

(Undoing unexplained change by non-subscriber.)

Changed in update-manager (Ubuntu):
status: Fix Released → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-manager (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers