Error during update-Power Pc (Hardy>Intrepid)

Bug #271969 reported by FiremanEd on 2008-09-19
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

In the distribution upgrade Hardy>Intrepid, error message: W:Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/intrepid/Release Unable to find expected entry partner/binary-powerpc/Packages in Meta-index file (malformed Release file?), E:Some index files failed to download, they have been ignored, or old ones used instead.

No network issues on the client side indicated.

Colin Watson (cjwatson) wrote :

The partner archive lives on archive.canonical.com, not ports.ubuntu.com; sounds like perhaps update-manager is being a bit too enthusiastic about moving things to ports.ubuntu.com?

jacobwwood (jacobwwood) wrote :

I have the same problem. Is there any way to run the upgrade?

jeremylp (lp-jeremy) wrote :

Same problem here!

jeremylp (lp-jeremy) wrote :

upgrading with the terminal doesn't seem to work either.
(I used 'gedit' instead or 'nano', and 'aptitude' instead of 'apt-get')

I get the following unmet dependencies error:

---------------------------------------
The following packages have unmet dependencies:
  libgnomekbd2: Depends: libgnomekbd-common (= 2.22.0-1) but 2.24.0-0ubuntu2 is to be installed.
  xserver-xorg-video-all: Depends: xserver-xorg-video-ati but it is not installable
                          Depends: xserver-xorg-video-fbdev but it is not installable
                          Depends: xserver-xorg-video-mga but it is not installable
                          Depends: xserver-xorg-video-nv but it is not installable
                          Depends: xserver-xorg-video-s3 but it is not installable
                          Depends: xserver-xorg-video-s3virge but it is not installable
                          Depends: xserver-xorg-video-sis but it is not installable
                          Depends: xserver-xorg-video-tdfx but it is not installable
                          Depends: xserver-xorg-video-trident but it is not installable
                          Depends: xserver-xorg-video-v4l but it is not installable
  libperl5.8: Depends: perl-base (= 5.8.8-12) but 5.10.0-11.1ubuntu2 is to be installed.
  libgail-common: Depends: libgail18 (>= 1.9.1) but it is not installable
  libffi4: Depends: gcc-4.2-base (= 4.2.4-1ubuntu3) but 4.2.4-3ubuntu4 is to be installed.
Resolving dependencies...
The following actions will resolve these dependencies:

Remove the following packages:
libffi4
libgail-common
libgnomekbd2
libgnomekbdui2
libperl5.8
xserver-xorg-video-all

Keep the following packages at their current version:
jockey-common [0.3.3-0ubuntu8.1 (now)]
jockey-gtk [0.3.3-0ubuntu8.1 (now)]

Score is 604

Accept this solution? [Y/n/q/?]
------------------------------------------------------

My questions are :

1. is this corrolated to the same bug when trying to upgrade thru the software-update-manager?
    or is it just me?

2. would it be safe to continue anyway, answering 'yes'?
    or will it ruin my system?

here is an attachment of the whole terminal output if needed...

kernel-janitor (kernel-janitor) wrote :

Hi FiremanEd,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 271969

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
FiremanEd (firemaned) on 2009-10-16
Changed in linux (Ubuntu):
status: Incomplete → Fix Committed
Changed in update-manager (Ubuntu):
status: New → Fix Committed
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Changed in update-manager (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers