Release upgrade procedure "sucks" (from Gutsy to Hardy)

Bug #223542 reported by maxadamo on 2008-04-28
10
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Rolf Leggewie

Bug Description

Binary package hint: update-manager

I updated 3 computers from Ubuntu Gutsy to Ubuntu Hardy.

Using update-manager, within Gnome, as you "suggest" to do, it is an insane idea.

The first computers I did, I got everything crashing in Gnome crashes, everything was stuck, CPU was used new to 100%, and computer was very slow, since it definitively crashed the X session .... but that was obvious: it's like cutting the branch where you're sitting.
If you upgrade Gnome, running inside gnome it can't work (I imagine it would be the same with KDE)!

I think the concept behind this upgrade is completely wrong. You should force this kind of update outside gnome (for instance in the failsafe terminal session). you put a message: please logout, enter the failsafe session, and then type "sudo update-manager"

I updated the remaining 2 computers from fluxbox, and the upgrade proceeded smoothly! :o)

Even the idea of using pygtk is not the best one. If update-manager hangs, you can't restart it (at least before running: dpkg --configure -a, or before reinstalling python, depending where you update stopped).

I think you have to use some interface statically compiled, without any link to libraries.

cheers.

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Please attach the files in /var/log/dist-upgrade to this bugreport of the machine that crashed for you.

 Thanks Michael

Changed in update-manager:
status: New → Incomplete
maxadamo (massimilianoadamo) wrote :

SEE ATTACHED FILE>

Well, I also try to make you life easier :-)

As from the log file /var/log/dist-upgrade/term.log the upgrade procedure hanged here:
(sorry it's in italian)
Spacchetto il sostituto di kdebase-workspace-bin ...
Mi preparo a sostituire kdebase-workspace-data 4:4.0.0-0ubuntu1~gutsy1 (con .../kdebase-workspace-data_4%3a4.0.3-0ubuntu2_all.deb) ...
"term.log" [in sola lettura] 4420L, 271676C

I found the update procedure stuck, I have been waiting around 15 minutes, and since everything was stuck, and there was no activity on the disk, and since I don't think installing such packages requires so much time, I decided to reboot, and proceed the upgrade by hand.

As the update has been restarted, the file /var/log/dist-upgrade/apt-term.log contain several parts, appended when the update was restarted.
Having a look into this file it seem the the operation from the above file never started, because it was really started during the second upgrade (installing kdebase-workspace-data):

Mi preparo a sostituire kdebase-kde4 4:4.0.0-0ubuntu1~gutsy1 (con .../kdebase-kde4_4%3
Log started: 2008-04-26 12:21:15
(Lettura del database ... 191596 file e directory attualmente installati.)^M
Mi preparo a sostituire kdebase-workspace-data 4:4.0.0-0ubuntu1~gutsy1 (con .../kdebase-workspace-data_4%3a4.0.3-0ubuntu2_all.deb) ...^M

as you can see from the file:
the installation started at "Log started: 2008-04-26 07:56:03"
and it was hanging at: "Log started: 2008-04-26 12:21:15"

It think it's too many time .......

maxadamo (massimilianoadamo) wrote :

Heeellooooooo.... is anybody in?
The bug was updated one month ago and it's still stuck, and pending in status "incomplete".
Can anyone take action? Thanks

Jean-Baptiste Lallement (jibel) wrote :

This report is not a bug. From the main.log, dpkg was waiting for a confirmation from you. That's why the process hanged.

2008-04-26 08:21:26,312 DEBUG got a conffile-prompt from dpkg for file: '/etc/bash.bashrc'
2008-04-26 10:40:41,859 WARNING no activity on terminal for 240 seconds (Preparazione alla configurazione di bash in corso)

Hence, this bug report is being closed. Please reopen it if you think _it is a bug_ and you can provide more information.

Thank you again for taking the time to report this bug and helping to make Ubuntu better. Feel free to submit any future bugs you may find.

Changed in update-manager:
status: Incomplete → Invalid
maxadamo (massimilianoadamo) wrote :

noooooo :) Was this the answer after one month?

This is a warning, because I was not sitting in front of my computer.

If you check term.log, you can see that I answered to this prompt, and I answered "YES":
(sorry, it's in italian, but you can understand the answer at the end).

File di configurazione `/etc/bash.bashrc'
 ==> Modificato (da te o da uno script) dopo l'installazione.
 ==> Il distributore del pacchetto ha fornito una versione aggiornata.
   Cosa decidi di fare? Le tue opzioni sono:
    Y o I : per installare la versione del responsabile del pacchetto
    N o O : per mantenere la versione correntemente installata
      D : per mostrare le differenze tra le versioni
      Z : per sospendere questo processo ed esaminare la situazione
 L'azione di default è di mantenere la tua versione corrente.
*** bash.bashrc (Y/I/N/O/D/Z) [default=N] ? y
Installo la nuova versione del file di configurazione /etc/bash.bashrc ...

PLEASE reopen the bug.

Changed in update-manager:
status: Invalid → Confirmed

Hello Jean-Baptiste,

please see answer to your question in the bugtrack.

thanks
Massimiliano

Il giorno ven, 30/05/2008 alle 09.55 +0000, Jean-Baptiste Lallement ha
scritto:
> This report is not a bug. From the main.log, dpkg was waiting for a
> confirmation from you. That's why the process hanged.
>
> 2008-04-26 08:21:26,312 DEBUG got a conffile-prompt from dpkg for file: '/etc/bash.bashrc'
> 2008-04-26 10:40:41,859 WARNING no activity on terminal for 240 seconds (Preparazione alla configurazione di bash in corso)
>
> Hence, this bug report is being closed. Please reopen it if you think
> _it is a bug_ and you can provide more information.
>
> Thank you again for taking the time to report this bug and helping to
> make Ubuntu better. Feel free to submit any future bugs you may find.
>
> ** Changed in: update-manager (Ubuntu)
> Status: Incomplete => Invalid
>

Jean-Baptiste Lallement (jibel) wrote :

Hi Massimiliano,

I can't find any evidence of what happened from your log file and why it hangs. So, regarding your bugs, it lacks informations to identify and reproduce the bug. I don't know how we could go any further and I'm afraid it will lay here forever in this state.

Your suggestions to improve the upgrade process are welcomed, but this isn't really a bug and you may discuss it on an appropriate mailing list or forum. http://www.ubuntu.com/support/community/mailinglists might be a good start for determining which mailing list to use.

Finally, bug reports are handled by humans, the majority of whom are volunteers and the wording in the subject of your report may not inclined them to help quickly. Please bear this in mind.

Regards,

maxadamo (massimilianoadamo) wrote :

Hi Jean Baptiste,

first of all my sincere apologies for not polite wording.
Don't take it personally. The problem is not "you", or anybody else, but the way those bugs are dealt by the "team" involved.
I am very sorry to say that with other distributions, I have gotten immediate responses to bugs.
This is not to say that other distros are better than Ubuntu.
No, this is not the point, and it's not my thought.
The point is to demonstrate that another way is possible, because someone else do it better.
The other way is: respond to requests.

Going back to the issue:

If someone asks me some log file, and if one hour later i put those file, and if I don't receive any answer for one month, and if after one month the answer is "this is not a bug" I *must* be disappointed.

Right now it's impossible for me to gather other information, as we are talking about an operation performed about 2 months ago.
It quite clear that pygtk interface running within gnome (and upgrading gnome and python itself) is prone to crash.
Everyone who has run this kind of upgrade at least once in his life, has seen gnome-panel crashing, all icons in the desktop disappearing. the desktop not responding anymore.... and so on.

If I tell you that Gnome goes down, and everything start crashing, is this a bug or not?
Do you really need to look log files to state something that it's clearly happening?

Rolf Leggewie (r0lf) wrote :

I'm sorry to say, the gutsy -> hardy upgrade is no longer supported. I'll therefore close this ticket as invalid. Your report is appreciated and we hope you let us know of any problems you find in Ubuntu.

Changed in update-manager (Ubuntu):
assignee: nobody → Rolf Leggewie (r0lf)
status: Confirmed → Invalid
maxadamo (massimilianoadamo) wrote :

I agree the closure of this but (also because I don't like that I wrote the word "sucks" in the subject).
Anyway the problem is still there: the update-manager shouldn't have any bind to libraries that will be updated during the update process.
If - for any reason (*) - the update hangs, you won't be able to to restart it. It happened to me once.

(*) you can just unplug the power-cord, or accidentally close the window... or whatever else.

For instance, you can stop the update when python was no completely updated (and it easy to happen, because, as I remember packages are not installed one by one, but first, the apt configure all togheter and than install them ...)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers