Ubuntu

[kde] Distupgrade from Gutsy to Hardy (beta) fails

Reported by Kelly-Propelly on 2008-04-12
6
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: update-manager

I startet an Upgrade from Gutsy to Hardy (beta) by typing kdesu "adept_manager --dist-upgrade-devel" into the command box. The Upgrade was working well, until it tried to update Firefox. Terminal output reported:

dpkg: Status-Datenbank-Bereich ist von einem anderen Prozess gesperrt (see logs in Attachment)

The update process crashed and adviced me to do "dpkg --configure -a". It did some things, but didn't seem to solve the whole situation. So I tried a "sudo apt-get -f install", which reported that "language-support-en" is missing. After manually installing "language-support-en" I tried to do a "sudo apt-get upgrade". Most of the downloaded packages then where installed correctly.

Finally I did another kdesu "adept_manager --dist-upgrade-devel", which installed the newest kernel and about 60 other missing packages. The rest of the Upgrade Process went smoothly.

I remember, that i manually uninstalled the "language-support-en" for some reason I can't remember anymore. So if this really was the problem, maybe it should be a dependency, which the Uprade Process solves by itself.

But since I'm not a professional, I don't have any clue, if it was even related to "language-support-en". I hope the logs are of any help. I'm trying a reboot my PC now.

Daniel Hahler (blueyed) wrote :

This sounds like there was still some process running and locking the dpkg status database and therefore the rest of the upgrade failed.
It does not look like a missing language-support-en is related.

From term.log:
updateStatus: Zwischenspeicher wird gelesen
updateStatus: Paketverwaltung wird überprüft
updateStatus: Aktualisiere Informationen zu Paketdepots
updateStatus: Paketverwaltung wird überprüft
updateStatus: Calculating the changes
updateStatus: Fetching
updateStatus: Systemaktualisierung wird durchgeführt
'utf8' codec can't decode byte 0xc2 in position 254: unexpected end of data
'utf8' codec can't decode byte 0xab in position 0: unexpected code byte
'utf8' codec can't decode byte 0xc3 in position 254: unexpected end of data
'utf8' codec can't decode byte 0xbc in position 0: unexpected code byte
'utf8' codec can't decode byte 0xc3 in position 254: unexpected end of data
'utf8' codec can't decode byte 0xbc in position 0: unexpected code byte
'utf8' codec can't decode byte 0xc2 in position 254: unexpected end of data
'utf8' codec can't decode byte 0xab in position 0: unexpected code byte
'utf8' codec can't decode byte 0xc2 in position 254: unexpected end of data
'utf8' codec can't decode byte 0xab in positiondpkg: Status-Datenbank-Bereich ist von einem anderen Prozess gesperrt
dpkg: Status-Datenbank-Bereich ist von einem anderen Prozess gesperrt
[...message above repeated a lot of times...]
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 17: invalid constant used : legacy
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62
  Minor opcode: 0
  Resource id: 0x3017406
Xlib: sequence lost (0x360a32 > 0x350a32) in reply type 0x0!
X Error: BadImplementation (server does not implement operation) 17
  Major opcode: 20
  Minor opcode: 0
  Resource id: 0xb0e7e70
Xlib: sequence lost (0x3601ed > 0x352684) in reply type 0x1c!
Xlib: sequence lost (0x36000c > 0x352684) in reply type 0x6!
X Error: BadPixmap (invalid Pixmap parameter) 4
  Major opcode: 54
  Minor opcode: 0
  Resource id: 0x30173f0
X Error: BadPixmap (invalid Pixmap parameter) 4
  Major opcode: 54

Changed in update-manager:
importance: Undecided → Medium
Kelly-Propelly (kelly-propelly) wrote :

Yes, terminal output suggests that another process was locking the database. Strange thing is, that only the Updater/Adept was running, which installed about half of the new packages without any problem until it produced the above error while installing Firefox:

Wähle vormals abgewähltes Paket firefox-2.
Entpacke firefox-2 (aus .../firefox-2_2.0.0.13+1nobinonly-0ubuntu1_i386.deb) ...
dpkg - Warnung: Problem wird übergangen, weil --force angegeben ist:
... endless warnings from here on.

When I tried to install that Package manually (apt-get install firefox-2) it told me again, that another process is locking the database. Again, I can confirm that no other process able to lock the database was running. I tried "apt-get -f install" and it told me that language-support-en is missing. After installing it manually (apt-get install language-support-en) Firefox and all other packages installed smoothly. No more locking-errors.

So I think either Updater/Adept stumbled over it's own feet, or it was an unresolved dependency.

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

What version of adept-manager did you use for the upgrade?

Kelly-Propelly (kelly-propelly) wrote :

I don't know how to find out what version I was using before I upgraded to Hardy. But I did a full update (apt-get update -> apt-get upgrade) and started die Updater afterwards. So it must have been the most recent version available on the Ubuntu-Servers on Saturday, 04/12. But in case Adept is a Standard Component of KDE, there's a chance, that I had another Version installed. Because some weeks ago I added "http://ppa.launchpad.net/kubuntu-kde-3.5.9/ubuntu/" to my repository list.

Sorry, that I can't be more specific. Let me know if I can provide you with more data -- or how. Cheers!

Gabriel Ruiz (anakron) on 2008-08-10
Changed in update-manager:
status: New → Confirmed
Thomas Hotz (thotz) wrote :

Is this still an issue for you? Which Ubuntu version do you use? Thank you for telling us!

Changed in update-manager (Ubuntu):
status: Confirmed → Incomplete
Kelly-Propelly (kelly-propelly) wrote :

No, there were no more problems after the switch to Hardy. I guess after four years without activity it should be safe to close this one.

Thomas Hotz (thotz) on 2012-11-30
Changed in update-manager (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers