update-manager crashed with RuntimeError in <module>() : RuntimeError: could not open display.It should display a warning when $DISPLAY is not set.

Bug #197581 reported by Hoon Choi on 2008-03-02
214
This bug affects 17 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: update-manager

Random crash on start-up.

ProblemType: Crash
Architecture: i386
Date: Sun Mar 2 05:24:53 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/update-manager
InterpreterPath: /usr/bin/python2.5
NonfreeKernelModules: fglrx
Package: update-manager 1:0.87.10
PackageArchitecture: all
ProcCmdline: /usr/bin/python2.5 /usr/bin/update-manager
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/update-manager']
SourcePackage: update-manager
Title: update-manager crashed with RuntimeError in <module>()
Traceback:
 Traceback (most recent call last):
   File "/usr/bin/update-manager", line 43, in <module>
     gtk.init_check()
 RuntimeError: could not open display
Uname: Linux 2.6.24-10-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin plugdev video

Hoon Choi (bhchoi) wrote :
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

The crash indicates that update-manager can not connect to your display for some reason. How do you start update-manager? Is this reproducable in any way?

Changed in update-manager:
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

Closing this bug report as no further information has been provided. Please feel free to reopen this bug if you can provide the information asked for. Thanks!.

Changed in update-manager:
status: Incomplete → Invalid
description: updated
tdflanders (thomasdelbeke) wrote :

Reopening:

I am TDFlanders and I opened this bug.

I do not know hoon choi. Is this a launchpad error or was I hacked?

Cheers,

Thomas

Changed in update-manager:
status: Invalid → New
Kjell Braden (afflux) wrote :

No you did not open this bug. Go check the numbers. This is bug 197581, the one you opened is bug 261579, which has been marked as a duplicate of this. Please provide the information requested by Michael Vogt. Thanks.

Changed in update-manager:
status: New → Incomplete
description: updated
Jean-Baptiste Lallement (jibel) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in update-manager:
status: Incomplete → Invalid

This affects the beta of Karmic to.

Aadil H (aadilh) wrote :

I'm a new user, i had trouble upgrading to ubuntu 9.10 when KDE was set as default desktop, i was able to reset to gdm & upgrade proceeded however upon boot i had a black screen without any options.

Using recovery mode, i tried to reinstall xubuntu, kubuntu desktop & desktop managers separately & then eventually installed edubuntu & used the recovery to repair broken packages.

I was then able to boot gui with loads about 3/4 startup crashes.

miked (miked11) on 2010-01-22
Changed in update-manager (Ubuntu):
status: Invalid → New
miked (miked11) wrote :

root@ubuntu910:~# lsb_release -rd
Description: Ubuntu lucid (development branch)
Release: 10.04
root@ubuntu910:~#
trying to upgrade
update and dist-upgrade stuff.
I run update-manager -c -d from terminal and also through gdm.

Miked,

The crash file shows:
 Traceback (most recent call last):
   File "/usr/bin/update-manager", line 43, in <module>
     gtk.init_check()
 RuntimeError: could not open display

This indicates that update-manager can not connect to your display for some reason.
When you reproduce it, what is the output of the command:
$ echo $DISPLAY

If you're upgrading from a console use the command 'do-release-upgrade' instead.

summary: - update-manager crashed with RuntimeError in <module>()
+ update-manager crashed with RuntimeError in <module>() : RuntimeError:
+ could not open display
Changed in update-manager (Ubuntu):
status: New → Incomplete
miked (miked11) wrote :

On [F1] Terminal I get a blank.
root@ubuntu910:~# echo $DISPLAY
root@ubuntu910:~#
On [F7] Terminal I get:
root@ubuntu910:~# echo $DISPLAY
:0.0
root@ubuntu910:~#

Thanks for the new do-release-upgrade command.

Changed in update-manager (Ubuntu):
status: Incomplete → New
miked (miked11) wrote :

O.K. Here is what is happening.
I start my computer, Ubuntu loads up and auto-logs on and in. Since it loads up a user that probably doesn't have sudo rights. I open up another terminal to access root. [F7] Terminal to [Ctrl]+[Alt]+[F1]Terminal. Then I run commmands like: sudo apt-get update, sudo apt-get upgrade, sudo apt-get dist-upgrade, and sudo update-manager -c -d. I understand I could do that from a terminal window, I perfer to use this method for public access computers being upgraded real-time, while users continue to use the machines.
When I type the command: sudo update-manager -c -d from the console while a [F7] Terminal is open in the background, I get this error message, and a bug report is produced.
I expect to be able to open up multiple terminals with or with out gdm, startx, or whatever gui interface, on more that one terminal at a time.
Thanks, let me know if i'm expecting to much, or if there is a better option for upgrading real-time and sending it to background, so it doesn't bother no sudo users.

Thanks for your feedback. Because update-manager is a GUI application it needs an xserver and the environment variable DISPLAY determines how it should connect to that server. There is no DISPLAY set by default on a tty and update-manager is not intended to be launched from a tty unless you know what you are doing.
So I'm closing this report because it's not a bug in Ubuntu. Thanks.

Changed in update-manager (Ubuntu):
status: New → Invalid
miked (miked11) wrote :

Thanks,
So it may not be a bug, but it does make a bug report and give a unuseful error message to a user, so something might be changed to let a user know to run it from a gui and not from the tty. Why doesn't it open a new instance of gui or a display on that terminal ? I probably have the commands wrong I understand, and don't always know what I am doing, just a suggestion.

You're right miked, and it seems to hit many users. Changing the status accordingly.
Thanks.

summary: update-manager crashed with RuntimeError in <module>() : RuntimeError:
- could not open display
+ could not open display.It should display a warning when $DISPLAY is not
+ set.
Changed in update-manager (Ubuntu):
importance: Undecided → Low
status: Invalid → Triaged
tags: added: bugpattern-needed
Tim Smith (auxiliary.chipmunk) wrote :

i have this issue, is there a fix or can I help in any way?

chowder (dsfargeg1287) wrote :

I would like to point out that when I got this bug I was on Ubuntu 10.10 upgrading to 11.04. Ever since upgrading to 11.04 I have not been able to reproduce the bug.

This bug is stopping me from upgrading, how do you work around it?

Sent from my HTC

----- Reply message -----
From: "absolutezero1287" <email address hidden>
To: <email address hidden>
Subject: [Bug 197581] Re: update-manager crashed with RuntimeError in <module>() : RuntimeError: could not open display.It should display a warning when $DISPLAY is not set.
Date: Sat, Apr 23, 2011 01:37

I would like to point out that when I got this bug I was on Ubuntu 10.10
upgrading to 11.04. Ever since upgrading to 11.04 I have not been able
to reproduce the bug.

--
You received this bug notification because you are a direct subscriber
of the bug.
https://bugs.launchpad.net/bugs/197581

Title:
  update-manager crashed with RuntimeError in <module>() : RuntimeError:
  could not open display.It should display a warning when $DISPLAY is
  not set.

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/197581/+subscribe

sabbath (dawid-kasza) wrote :

Try switch to console: ctrl+alt+2 and then press "sudo apt-get dist-upgrade"
let me know if that works for you guys. Rdgs!
23-04-2011 10:00 użytkownik "Tim Smith" <email address hidden> napisał:
> This bug is stopping me from upgrading, how do you work around it?
>
> Sent from my HTC
>
> ----- Reply message -----
> From: "absolutezero1287" <email address hidden>
> To: <email address hidden>
> Subject: [Bug 197581] Re: update-manager crashed with RuntimeError in
<module>() : RuntimeError: could not open display.It should display a
warning when $DISPLAY is not set.
> Date: Sat, Apr 23, 2011 01:37
>
>
> I would like to point out that when I got this bug I was on Ubuntu 10.10
> upgrading to 11.04. Ever since upgrading to 11.04 I have not been able
> to reproduce the bug.
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/197581
>
> Title:
> update-manager crashed with RuntimeError in <module>() : RuntimeError:
> could not open display.It should display a warning when $DISPLAY is
> not set.
>
> To unsubscribe from this bug, go to:
>
https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/197581/+subscribe
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (517164).
> https://bugs.launchpad.net/bugs/197581
>
> Title:
> update-manager crashed with RuntimeError in <module>() : RuntimeError:
> could not open display.It should display a warning when $DISPLAY is
> not set.
>
> Status in "update-manager" package in Ubuntu:
> Triaged
>
> Bug description:
> Binary package hint: update-manager
>
> Random crash on start-up.
>
> ProblemType: Crash
> Architecture: i386
> Date: Sun Mar 2 05:24:53 2008
> DistroRelease: Ubuntu 8.04
> ExecutablePath: /usr/bin/update-manager
> InterpreterPath: /usr/bin/python2.5
> NonfreeKernelModules: fglrx
> Package: update-manager 1:0.87.10
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python2.5 /usr/bin/update-manager
> ProcEnviron:
>
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
> LANG=en_CA.UTF-8
> SHELL=/bin/bash
> PythonArgs: ['/usr/bin/update-manager']
> SourcePackage: update-manager
> Title: update-manager crashed with RuntimeError in <module>()
> Traceback:
> Traceback (most recent call last):
> File "/usr/bin/update-manager", line 43, in <module>
> gtk.init_check()
> RuntimeError: could not open display
> Uname: Linux 2.6.24-10-generic i686
> UserGroups: adm admin audio cdrom dialout dip floppy lpadmin plugdev video
>
> To unsubscribe from this bug, go to:
>
https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/197581/+subscribe

Tim Smith (auxiliary.chipmunk) wrote :

found solution, do not put the code below

: Sudo update-manager -d

just open a console session using terminal and with out getting root, just type "update-manager -d" (without the speachmarks).

Worked first time this way.

Tim

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers