Comment 4 for bug 193879

pokkets (pokkets1) wrote :

This comment is fairly 'verbose' and strays from the original bug report a fair bit, but the bug seems to have been self inflicted. I know there is the basic warning 'read the help files' , but I would rather learn, than be educated. I hope it can tie up some loose ends. When decided to go Linux, I also decided to get a new laptop, so it didn't matter if I ruined any part of it, even the hardware. Having since learned that is unlikely, if the original install disks are available. and some key programs are kept on a flash drive (an ndiswrapper that works with the particular Kernel and inf files, for example) I also thought while learning the 'hard way' can be very annoying, that fact usually made the lessons clearer. I've guessed wrong a lot, but usually the screw up has helped me find the place to look in the ubuntu community pages for the answer.
 I may also have come up with some conclusions now that are wrong, but I hope someone can point them out in case any new users consider them to be advice. The problem dawned on me this morning . I probably threw a spanner in the Kernel. Edubuntu probably upgraded the Kernel (backwards?) There had been an upgrade to ultimate 1.7 since it was installed. Still, by trial and error I learned a few things.
 1)Before any upgrade unmark any 3rd party sources. I had heard that before but was reminded when the Edubuntu upgrade disabled them automatically. However now I have Edubuntu in the session list, and the toolbar under system - 'about Edubuntu' (20071017?) and perhaps that is a sign I have a lot to learn.
 2) When adding a source disk, if the disk is inserted before the 'add' tab in software sources is clicked, or return is hit in terminal apt-cdrom add, the option to upgrade is offered. (If there is a different kernel on the disk?) There is also the option to open with package manager, but so far the other place I have tried to add with the most recent reinstallation was within synaptic, which may be the same thing. Press return, or add and then it asks for the disk to be inserted. I don't know if it can degrade the kernel, but kubuntu would also have tried to upgrade the kernel. Upgrade and add are two completely different programs.
It helps if the kernel is both more recent, and compatible with the system.
3) When all else fails backup home/settings with sbackup, and and start from scratch with a reinstall.
 It helps to get a root tar file from before trying something new and reinstall the system. etc, var, and usb local are in the defaults in sbackup, and I know the var apt cache has debian packages but games are in usr games and after a restore with srestore some of the titles were included as installed but the applications hadn't been restored. Add/remove programs couldn't find them to remove them but synaptic solved the problem after I removed them completely. and reinstalled. I may only have had to reinstall a lot of them. The restores seemed to hang, maybe I cut restore too early but after 12 hours I thought there may have been a problem. The tar backup.tgz in terminal is verbose, so it can be clear when the restore has finished Now I try and have a root back upon it's own partition, preferably on it's own disk - I have a few usb hard drives from 80-120GB one of the reasons I have had to learn to back up- trying to install a system on a usb drive.- using a 40GB Acer Extensa 2355XC laptop. So far I haven't been able to, but read somewhere that the ubuntu kernel had trouble loading and booting USB external hard drive systems, Will the Hardy kernel have any problem? could be something to do with the way partitions on USB can be assigned different disk names after a reboot, a cold boot, or an unmount/remount,i.e. a partition that was on disk-1, can end up on disk 6 I might see if I can find a bug report with this problem or make a new one. I found out how to make a kernel for a boot cd but have had trouble burning a CD R/W It could also be the hardware which is for a windows system. I might try a burn in windows. I took the advice of the tar backup restore page in ubuntu community excluding proc, mnt, sys, and I exclude media for the sake of the files on the usb including backup.tgz and files that won't fit on the laptop drive, and dev, because I am always editing the partitions so the uuid changes. After I reinstall the system I also sbackup grub, fstab, and mtab. to be restored after the system restore and before reboot. - but it can also be restored with an ultimate live cd, no doubt amongst others. I learned to do this before I learned enough about grub ,fstab, and mtab, to fix them with gksudo gedit, but it gave me the incentive to learn. Of course while I have been given reason to learn by trial and error, the advice and suggestions of both the ubuntu community advice/questions and forum advice questions has been invaluable. Most questions have been answered before I had to ask them. I hope this comment gives you some ideas, and can make a bit clearer what I did to incite the suggestion to file a bug report. If you would like to know anything else, or have ideas where I may have screwed the system without knowing it yet, I'll be open to any advice. It may have affected the ability to upgrade to the hardy kernel. Are there upgrades with the Alpha releases ? Well, I know April is getting closer. My next move is to get a laptop with a dual core. Onward into the unknown.