Ubuntu

update-manager 0.59.24 fails to upgrade to gutsy

Reported by Christopher Armstrong on 2007-09-19
36
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
High
Michael Vogt

Bug Description

Binary package hint: update-manager

It seems to be due to a couple of trivial Python NameErrors.

I ran the following command. I clicked "Upgrade" next to the prompt to upgrade to 7.10. I clicked "Upgrade" on the message box that popped up. A popup showed a progress bar for downloading the upgrade tool. Then the following error messages happened.

It seems there are two obvious problems here, both Python NameErrors. First is one that doesn't have a full traceback, but does show that there was a usage of "dbus" without an import. The second shows a usage of "os" without an import.

radix@naota ~% update-manager -c -d
extracting '/tmp/tmpquNzbk/gutsy.tar.gz'
authenticate '/tmp/tmpquNzbk/gutsy.tar.gz' against '/tmp/tmpquNzbk/gutsy.tar.gz.gpg'
could not send the dbus Inhibit signal: global name 'dbus' is not defined
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/UpdateManager/UpdateManager.py", line 914, in on_button_dist_upgrade_clicked
    fetcher.run()
  File "/usr/lib/python2.5/site-packages/UpdateManager/Core/DistUpgradeFetcherCore.py", line 178, in run
    self.runDistUpgrader()
  File "/usr/lib/python2.5/site-packages/UpdateManager/DistUpgradeFetcher.py", line 53, in runDistUpgrader
    if os.getuid() != 0:
NameError: global name 'os' is not defined

Michael Vogt (mvo) wrote :
Changed in update-manager:
assignee: nobody → mvo
importance: Undecided → High
status: New → In Progress
Christopher Armstrong (radix) wrote :

Is there a .deb with this patch in it anywhere I can test?

Brian Murray (brian-murray) wrote :

Not at this point in time however it is just a two-line change to DistUpgradeFetcher.py. You could make those changes yourself.

Martin Pitt (pitti) wrote :

Patch approved for feisty. However, please make sure to fix it in gutsy first, close the gutsy task, and create a proper feisty task.

Christopher Armstrong (radix) wrote :

fwiw manually applying the patch worked for me, but I then soon ran into bug #141341. Thanks mvo.

Martin Pitt (pitti) wrote :

Accepted into feisty-proposed. Please test.

Changed in update-manager:
status: In Progress → Fix Committed
Christopher Armstrong (radix) wrote :

Ok, I've tested the .deb in -proposed on another machine. works fine, thanks.

Lord_neo (lord-neo) wrote :

The bugfix works fine. I've updated to gutsy with no errors. Thanks so much.

Brian Murray (brian-murray) wrote :

Testing with update-manager version 1:0.59.23 I received error messages regarding dbus not being defined. I then updated to update-manager version 1:0.59.24 and was able to update to Gutsy without receiving any error messages.

Martin Pitt (pitti) wrote :

Copied to feisty-updates.

Changed in update-manager:
status: Fix Committed → Fix Released

Bug #140754 was marked as a duplicate of this one. Will it be fixed in gutsy?

Thanks a lot from México, the bugfix works fine, I've update to 7.10.

Best Regards

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers