Unity 8 does not hide indicators in drop-down when their root item is set not visible

Bug #1606463 reported by dinamic on 2016-07-26
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Undecided
Unassigned
unity8 (Ubuntu)
High
Unassigned

Bug Description

ubuntu 16.10 unity8 desktop
don't show battery and bluetooth indicators when hardware is not present, like on a desktop

i don't have bluetooth or a battery

dinamic (dinamic6661) wrote :
dinamic (dinamic6661) wrote :
Michał Sawicz (saviq) wrote :

I don't think unity8 should do anything here - the indicators should hide themselves. What I'm not sure of is whether unity8 supports something like that at the moment.

Changed in unity8 (Ubuntu):
status: New → Incomplete
summary: - don't show battery and bluetooth indicators when now hardware is
- pressent
+ Battery and Bluetooth indicators visible when the hardware is not
+ present

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-battery (Ubuntu):
status: New → Confirmed
Changed in indicator-bluetooth (Ubuntu):
status: New → Confirmed
Changed in indicator-battery (Ubuntu):
importance: Undecided → Low
Changed in indicator-bluetooth (Ubuntu):
importance: Undecided → Low
Changed in unity8 (Ubuntu):
status: Incomplete → Invalid
tags: added: unity8-desktop
Changed in canonical-devices-system-image:
status: New → Confirmed
dobey (dobey) wrote :

The indicators *do* hide themselves (they set the visibility of their root item to false). This works fine in unity7, and in unity8 it only works half-way.

In unity8, when an indicator sets its root item visibility to false, the icon disappears from the top panel in general, but when the drop-down for indicators is opened, the indicator is still shown anyway, and any visible children are also shown, though they shouldn't be.

Changed in unity8 (Ubuntu):
status: Invalid → Confirmed
Changed in indicator-battery (Ubuntu):
status: Confirmed → Invalid
Changed in indicator-bluetooth (Ubuntu):
status: Confirmed → Invalid
no longer affects: indicator-battery (Ubuntu)
no longer affects: indicator-bluetooth (Ubuntu)
Changed in unity8 (Ubuntu):
importance: Undecided → High
summary: - Battery and Bluetooth indicators visible when the hardware is not
- present
+ Unity 8 does not hide indicators in drop-down when their root item is
+ set not visible
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers