Clicking permissions dialog in untrusted app causes app to lose focus

Bug #1381292 reported by Josh Arenson on 2014-10-15
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Unassigned
unity8 (Ubuntu)
Undecided
Josh Arenson
unity8 (Ubuntu RTM)
Critical
Michael Zanetti

Bug Description

Steps to reproduce:

1. Start with a fresh flash of the device (or clear all permissions data from the camera app, wasn't sure how to do this)
2. Start the camera app
3. When the dialog comes up asking if the camera can use your current location, click "deny"

Results: Dialog closes, camera stays black as it likely doesn't have active focus
Expected results: Dialog closes and camera resumes

Related branches

description: updated
Changed in unity8 (Ubuntu):
assignee: nobody → Josh Arenson (josharenson)
Josh Arenson (josharenson) wrote :

As camera is now a trusted app, this issue no longer occurs with the camera. Below is an app that still reproduces the issues. It includes a script to clear the trust.db as well.

lp:~josharenson/+junk/trustStoreDialogFocusTest

Changed in unity8 (Ubuntu):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.01+15.04.20141117-0ubuntu1

---------------
unity8 (8.01+15.04.20141117-0ubuntu1) vivid; urgency=low

  [ josharenson ]
  * Return focus to the application after a tusted session overlay is
    closing. (LP: #1381292)

  [ Josh Arenson ]
  * Return focus to the application after a tusted session overlay is
    closing. (LP: #1381292)

  [ Albert Astals ]
  * Remove unused ResponsiveFlowView
  * Fix a few cmake warnings when running ./build.sh in a clean checkout

  [ Mirco Müller ]
  * Make sure non-square icons are not cropped. (LP: #1378417)

  [ Michael Terry ]
  * Drop the "EARLY ALPHA" scare label when running in testing mode.

  [ Michael Zanetti ]
  * unify Greeter and Lockscreen wallpaper again
  * hide quicklist when launcher hides (LP: #1387088)
  * Keep applications suspended while lockscreen is shown (LP: #1378126)
  * change spread background color to 111111

  [ Omer Akram ]
  * show password when tapped on the 'Show password' label, not just the
    checkbox. (LP: #1389832)
 -- Ubuntu daily release <email address hidden> Mon, 17 Nov 2014 13:48:33 +0000

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
Michał Sawicz (saviq) wrote :

Bug #1394645 is a duplicate, please transfer image task status from there.

Changed in canonical-devices-system-image:
status: New → Confirmed
Changed in unity8 (Ubuntu RTM):
milestone: none → 14.09-ota-1
status: New → Triaged
Changed in canonical-devices-system-image:
status: Confirmed → New
Michał Sawicz (saviq) on 2014-12-10
Changed in unity8 (Ubuntu RTM):
status: Triaged → New
milestone: 14.09-ota-1 → none
Changed in canonical-devices-system-image:
importance: Undecided → Critical
Victor Tuson Palau (vtuson) wrote :

this is critical for products, due to bug https://bugs.launchpad.net/barajas/+bug/1397199

summary: - Clicking permissions dialog in camera app causes app to lose focus
+ Clicking permissions dialog in untrusted app causes app to lose focus
Changed in canonical-devices-system-image:
milestone: none → ww51-2014
status: New → Confirmed
Michał Sawicz (saviq) on 2014-12-12
Changed in unity8 (Ubuntu RTM):
milestone: none → 14.09-ota-1
status: New → Triaged
importance: Undecided → Critical
Changed in unity8 (Ubuntu RTM):
status: Triaged → In Progress
assignee: nobody → Michael Zanetti (mzanetti)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.02+15.04.20141216~rtm-0ubuntu1

---------------
unity8 (8.02+15.04.20141216~rtm-0ubuntu1) 14.09; urgency=medium

  [ Michał Sawicz ]
  * Bump version due to new Manage Dash

  [ Albert Astals ]
  * Fix tests (LP: #1400449)
  * Allow pulling manage dash if there's no favorite scopes (LP:
    #1400774)
  * Manage Dash: Make store button work even if you have no favorites
    (LP: #1400771)
  * clickscope is back to being unfavoritable
  * Fix clicking on the manage dash list after having moved the current scope
  * ScopesList: Use the default scope style for the header

  [ Josh Arenson ]
  * Return focus to the application after a tusted session overlay is
    closing. (LP: #1381292)
 -- Ubuntu daily release <email address hidden> Tue, 16 Dec 2014 16:12:34 +0000

Changed in unity8 (Ubuntu RTM):
status: In Progress → Fix Released
Bill Filler (bfiller) on 2014-12-17
Changed in canonical-devices-system-image:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers