OSK doesn't appear after OA login

Bug #1394645 reported by Víctor R. Ruiz on 2014-11-20
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Unassigned
The Webapps-core project
Critical
Alexandre Abreu
ubuntu-keyboard
Invalid
Critical
Michael Sheldon
unity8 (Ubuntu)
Critical
Josh Arenson
unity8 (Ubuntu RTM)
Undecided
Unassigned

Bug Description

Test case.
- Remove Twitter account in System Settings.
- Open Twitter app and login.
- Tap to create new tweet/message.

Expected result.
- OSK must appear.

Actual result.
- OSK doesn't show up.

Also happens with GMail.

current build number: 116
device name: krillin
channel: ubuntu-touch/ubuntu-rtm/14.09.es-proposed

Víctor R. Ruiz (vrruiz) on 2014-11-20
description: updated
David Barth (dbarth) wrote :

In Twitter, the OSK appears when you tap in the textfield to enter your tweet. The app doesn't focus that textfield by default.

In Gmail, the "To:" textfield is focused by default, and the OSK shows up automatically during my test with image #167 (ubuntu-touch/ubuntu-rtm/devel-proposed)

Changed in webapps-core:
status: New → Incomplete
Víctor R. Ruiz (vrruiz) wrote :

Sorry. The test case should be this one:

- Open GMail app.
- Create a new account.
- After account is created, on the same app session, tap to create new message.

Expected result.
- OSK must appear.

Actual result.
- OSK doesn't show up.

Víctor R. Ruiz (vrruiz) wrote :

I can reproduce this without needing to create an account. Just remove the account from System Settings > Account and launch Gmail app for OA to re-capture the credentials.

Víctor R. Ruiz (vrruiz) on 2014-11-27
description: updated
Dave Morley (davmor2) wrote :

Confirming this, if I login and hit create a message I get no OSK, if I close the app and reopen it, it then works as expected.

Changed in webapps-core:
status: Incomplete → Confirmed
Dave Morley (davmor2) wrote :

For me this is happening on fresh installs on initial account creation, if I remove an account and re-add it, it then nolonger seems to be affected.

Interesting. I can reproduce the problem removing the account. I have
tried multiple times, and every one of them fails to show the
keyboard.

David Barth (dbarth) wrote :

I stand corrected and can confirm the issue

Changed in webapps-core:
importance: Undecided → Medium
David Barth (dbarth) wrote :

The issue is 'medium' priority, in that there is an easy workaround: the user just clicks on the textfield to reveal the OSK.

Víctor R. Ruiz (vrruiz) wrote :

> The issue is 'medium' priority, in that there is an easy workaround: the
> user just clicks on the textfield to reveal the OSK.

Nope, the OSK is not revealed clicking on the textfield.

Changed in canonical-devices-system-image:
importance: Undecided → Critical
milestone: none → ww51-2014
status: New → Confirmed
Changed in webapps-core:
importance: Medium → High
assignee: nobody → Alexandre Abreu (abreu-alexandre)

The same thing happens w/ the FB webapp, so my comment is in this context. After the OA login prompt is gone, I am not able to have the OSK popup again...

BUT

... it does work as expected when I right edge slide the app a bit to make the "switcher" appear and release the touch so that the app goes back into focus. After that touching a text field makes the OSK appear again.

This trick works very reliably and seems to point at a window/app focus issue after a trusted session ended.

Bill Filler (bfiller) on 2014-12-03
tags: added: ww51
Bill Filler (bfiller) on 2014-12-03
Changed in ubuntu-keyboard:
importance: Undecided → Critical
Changed in webapps-core:
importance: High → Critical
Changed in unity-mir (Ubuntu):
importance: Undecided → Critical
Changed in ubuntu-keyboard:
assignee: nobody → Michael Sheldon (michael-sheldon)

Looking at the logs seems to confirm Alex's suspicions, the app gets a "UbuntuWindow::handleSurfaceFocusChange(false)" event when the login prompt is loaded over the top of it, but never receives "UbuntuWindow::handleSurfaceFocusChange(true)" when the prompt closes.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qtmir (Ubuntu):
status: New → Confirmed
Michał Sawicz (saviq) on 2014-12-05
affects: unity-mir (Ubuntu) → qtmir (Ubuntu)
Bill Filler (bfiller) on 2014-12-05
Changed in ubuntu-keyboard:
status: New → Invalid
kevin gunn (kgunn72) on 2014-12-05
Changed in unity8 (Ubuntu):
importance: Undecided → Critical
Changed in qtmir (Ubuntu):
assignee: nobody → Josh Arenson (josharenson)
Changed in unity8 (Ubuntu):
assignee: nobody → Josh Arenson (josharenson)
Gerry Boland (gerboland) wrote :

This was fixed in trunk with this commit:
https://code.launchpad.net/~josharenson/unity8/fix_trust_store_focus/+merge/239567
Commit needs backporting to RTM

Michał Sawicz (saviq) on 2014-12-08
Changed in unity8 (Ubuntu):
status: New → Fix Released
Changed in unity8 (Ubuntu RTM):
milestone: none → 14.09-ota-1
status: New → Triaged
no longer affects: qtmir (Ubuntu)
no longer affects: qtmir (Ubuntu RTM)
Michał Sawicz (saviq) wrote :

Please transfer image task status to the original bug #1381292.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers