Greeter won't unlock when app raised by url dispatcher is already focused

Bug #1307489 reported by Alan Pope 🍺🐧🐱 🦄 on 2014-04-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
autopilot (Ubuntu)
Undecided
Unassigned
powerd (Ubuntu)
Undecided
Unassigned
unity-mir (Ubuntu)
Undecided
Unassigned
unity8 (Ubuntu)
Critical
Unassigned

Bug Description

I have tried this on #294 and #250 after clean boot.

Send the device a text message
Tap notification
Expect messaging app to be opened (if closed) or raised (if already opened).

On both #250 and #294 it's been unreliable at doing this. Usually if messaging-app was not open it will be opened. However generally if the app is already open then tapping the notification will not raise the app.

On #294 sometimes the OSK will just appear over the top of the welcome screen.
On #250 it generally just does nothing.

This happens irrespective whether the device was locked and sleeping or at the welcome screen awake.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: unity8 7.85+14.04.20140410.1-0ubuntu1
Uname: Linux 3.4.0-5-mako armv7l
ApportVersion: 2.14.1-0ubuntu2
Architecture: armhf
Date: Mon Apr 14 13:37:57 2014
InstallationDate: Installed on 2014-04-14 (0 days ago)
InstallationMedia: Ubuntu 14.04 LTS - armhf (20140414)
SourcePackage: unity8
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Didier Roche (didrocks) on 2014-04-14
Changed in unity8 (Ubuntu):
importance: Undecided → High
Michał Sawicz (saviq) wrote :

FWIW, it never worked when the app was already running (there simply isn't code that would deal with that).

I've been trying here and at least with "upstart-app-launch dialer-app" I've seen a 100% reliable focusing of the app, so as long as the backend (telepathy-ofono?) kicks the messaging app to start, I don't see anything wrong with how it works now.

Investigating further.

Changed in unity8 (Ubuntu):
status: New → In Progress
Mirco Müller (macslow) on 2014-04-14
Changed in unity8 (Ubuntu):
assignee: nobody → Mirco Müller (macslow)

You can replicate what the telephony backend does with:

$ url-dispatcher message:///123

Where 123 is a phone number. I've been able to replicate the "keyboard over greeter" behaviour when the messaging app was already launched and having executed the above.

In general, there's nothing new here or unforeseen behaviour that I can find.

summary: - Tapping sms notification doesn't always raise messaging-app
+ Already-running apps are not raised if triggered with url-dispatcher or
+ upstart-app-launch
Changed in unity8 (Ubuntu):
status: In Progress → Confirmed
assignee: Mirco Müller (macslow) → nobody
Michał Sawicz (saviq) wrote :

Humpf, there seems to be code dealing with that after all... But indeed it doesn't work when the app was already focused.

I.e. steps to repro:

* launch messaging app
* lock the phone, press power to turn display on
* $ url-dispatcher message:///123
→ keyboard visible over greeter

Journey working correctly:
* launch messaging app
* swipe to dash or focus another app
* lock the phone, press power to turn display on
* $ url-dispatcher message:///123

summary: - Already-running apps are not raised if triggered with url-dispatcher or
- upstart-app-launch
+ Greeter won't unlock when app raised by url dispatcher is already
+ focused
kevin gunn (kgunn72) on 2014-04-14
Changed in unity8 (Ubuntu):
importance: High → Critical
kevin gunn (kgunn72) on 2014-04-14
Changed in unity8 (Ubuntu):
status: Confirmed → Fix Committed
tags: added: r250 r294 r295
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package powerd - 0.14+14.04.20140415-0ubuntu1

---------------
powerd (0.14+14.04.20140415-0ubuntu1) trusty; urgency=low

  [ Michael Terry ]
  * Emit display state changed signals any time state changes, not just
    when requested state changes. (LP: #1307489)
 -- Ubuntu daily release <email address hidden> Tue, 15 Apr 2014 00:36:41 +0000

Changed in powerd (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package autopilot - 1.4+14.04.20140415-0ubuntu1

---------------
autopilot (1.4+14.04.20140415-0ubuntu1) trusty; urgency=low

  [ Michael Terry ]
  * Treat an upstart 'app focus' event like a successful app launch.
    (LP: #1307489)
 -- Ubuntu daily release <email address hidden> Tue, 15 Apr 2014 00:12:05 +0000

Changed in autopilot (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers